summaryrefslogtreecommitdiff
path: root/dev-qt/qtspeech/qtspeech-6.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtspeech/qtspeech-6.9999.ebuild')
-rw-r--r--dev-qt/qtspeech/qtspeech-6.9999.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/dev-qt/qtspeech/qtspeech-6.9999.ebuild b/dev-qt/qtspeech/qtspeech-6.9999.ebuild
index 52d658ae0a12..c012be997560 100644
--- a/dev-qt/qtspeech/qtspeech-6.9999.ebuild
+++ b/dev-qt/qtspeech/qtspeech-6.9999.ebuild
@@ -3,6 +3,11 @@
EAPI=8
+# tests are kind of flaky, sometimes hang, and also fail with clang
+# (not that it's unusable with clang) -- may be worth revisiting
+# eventually given qtspeech is still somewhat new (added in 6.4.0)
+QT6_RESTRICT_TESTS=1
+
inherit qt6-build
DESCRIPTION="Text-to-speech library for the Qt6 framework"
@@ -15,14 +20,6 @@ IUSE="flite qml +speechd"
# can build with neither, but then it is just mock tts and may be confusing
REQUIRED_USE="|| ( flite speechd )"
-# TODO: tests are known failing with clang and needs looking into, albeit
-# it is still usable at runtime save for applications segfaulting on exit
-# similarly to QTBUG-90626 (not that this has in-tree revdeps as of writing
-# of this). Restricting because also seen this result in hanging. Note that
-# qtspeech:6 is still somewhat new (started in 6.4.0), and should review
-# status on new major versions.
-RESTRICT="test"
-
RDEPEND="
~dev-qt/qtbase-${PV}:6
~dev-qt/qtmultimedia-${PV}:6