summaryrefslogtreecommitdiff
path: root/dev-qt/qtscxml/qtscxml-6.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtscxml/qtscxml-6.5.1.ebuild')
-rw-r--r--dev-qt/qtscxml/qtscxml-6.5.1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-qt/qtscxml/qtscxml-6.5.1.ebuild b/dev-qt/qtscxml/qtscxml-6.5.1.ebuild
new file mode 100644
index 000000000000..2fedc64db025
--- /dev/null
+++ b/dev-qt/qtscxml/qtscxml-6.5.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="State Chart XML (SCXML) support library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE=""
+
+DEPEND="
+ =dev-qt/qtbase-${PV}*[gui,network,opengl,widgets]
+ =dev-qt/qtdeclarative-${PV}*
+"
+RDEPEND="${DEPEND}"