summaryrefslogtreecommitdiff
path: root/dev-qt/qtlocation
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtlocation')
-rw-r--r--dev-qt/qtlocation/Manifest1
-rw-r--r--dev-qt/qtlocation/qtlocation-6.6.9999.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index b75e941cdfc7..b99b10863357 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -6,5 +6,6 @@ DIST qtlocation-mapboxgl-5.15.10-5a07e196.tar.gz 3726230 BLAKE2B 9dbe08088a55bc1
EBUILD qtlocation-5.15.10.ebuild 1544 BLAKE2B 2943df2242ee45db0180334464d327614bcfb6ad93cd8117e4f6c81c3ef2384199dc547743f5784a0b88e976ea5296a833fbad986eb30eb947d6004283b69dd3 SHA512 453d7c2b6ab694e98c1ec9d08af70994910e8537f75d02aca8117b9887b3e7d98ac27f391b76327668a57d5a0186ebffb4b13f727d87feaaac4f0a0e1d5a2acd
EBUILD qtlocation-6.5.2-r1.ebuild 1468 BLAKE2B ed0d13151b41de0a0f86fca85dabf14b4893a939d4e6cde9ce4de4c844aef9e54e4ff2119566d48d2ce2ca1a307b6171592a658f7446ecd23d5de12aefe721c2 SHA512 e5a83f5e17b9db8ebc5dd92ab2024be8b96f0d2edc6994c58c9d260fc0c59dafb9852db3c402e6b47022587d2807c39292d84ec2b58bdda4fca8577f948ac74b
EBUILD qtlocation-6.5.9999.ebuild 1411 BLAKE2B 843b87346b18a733fe8835e57990aef80aa48b762f7a1c0bad5ce65aad08932bdd8d92f8833953fcb2526342fea2403ed46a0fdaa52951083b5bf38cdf56cf79 SHA512 8a388a2303a712230d293ece7b6d23d7b0b31aa3776b28011327bc3400d80edfe88f66af4acb3c1079adc1e040778c5e5c8bb4c797e03f2461e9c4cbf9467947
+EBUILD qtlocation-6.6.9999.ebuild 1411 BLAKE2B 843b87346b18a733fe8835e57990aef80aa48b762f7a1c0bad5ce65aad08932bdd8d92f8833953fcb2526342fea2403ed46a0fdaa52951083b5bf38cdf56cf79 SHA512 8a388a2303a712230d293ece7b6d23d7b0b31aa3776b28011327bc3400d80edfe88f66af4acb3c1079adc1e040778c5e5c8bb4c797e03f2461e9c4cbf9467947
EBUILD qtlocation-6.9999.ebuild 1411 BLAKE2B 843b87346b18a733fe8835e57990aef80aa48b762f7a1c0bad5ce65aad08932bdd8d92f8833953fcb2526342fea2403ed46a0fdaa52951083b5bf38cdf56cf79 SHA512 8a388a2303a712230d293ece7b6d23d7b0b31aa3776b28011327bc3400d80edfe88f66af4acb3c1079adc1e040778c5e5c8bb4c797e03f2461e9c4cbf9467947
MISC metadata.xml 535 BLAKE2B 061ed9abebe579a38a262451a5e72d112adbcf4693078042f3b55be8d16b7bd430198edb732cd127deccf8c67d444b9951dd7ac8e2d0fef7de02913a3a8ba644 SHA512 823b03655b8bbb923d38d4f8358898beb2e2fa34d36e2d8d843e164027d58eb044a3e661b8dfc12cda123f15fd07d0987874b81543c47e46c670c25fa35dde87
diff --git a/dev-qt/qtlocation/qtlocation-6.6.9999.ebuild b/dev-qt/qtlocation/qtlocation-6.6.9999.ebuild
new file mode 100644
index 000000000000..1183318657ba
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-6.6.9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Location (places, maps, navigation) library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[network]
+ ~dev-qt/qtdeclarative-${PV}:6
+ ~dev-qt/qtpositioning-${PV}:6[qml]
+"
+DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # ignores QML_IMPORT_PATH (unlike other tests) and looks in
+ # the missing builddir/qml, skip rather than work around
+ tst_declarative_ui
+)
+
+src_install() {
+ qt6-build_src_install
+
+ if use test; then
+ local delete=( # sigh
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*TestGeoServicePlugin*.cmake
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*TestGeoServicePlugin*.cmake
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*UnsupportedPlacesGeoServicePlugin*.cmake
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Qml/QmlPlugins/*declarative_location_test*.cmake
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_geocodingplugin.so
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_placesplugin_unsupported.so
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_qmltestplugin.so
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_routingplugin.so
+ "${D}${QT6_QMLDIR}"/QtLocation/Test
+ )
+ # using -f given not tracking which tests may be skipped or not
+ rm -rf -- "${delete[@]}" || die
+ fi
+}