summaryrefslogtreecommitdiff
path: root/dev-qt/qtimageformats/qtimageformats-6.7.0_rc.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtimageformats/qtimageformats-6.7.0_rc.ebuild')
-rw-r--r--dev-qt/qtimageformats/qtimageformats-6.7.0_rc.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-qt/qtimageformats/qtimageformats-6.7.0_rc.ebuild b/dev-qt/qtimageformats/qtimageformats-6.7.0_rc.ebuild
new file mode 100644
index 000000000000..677332aa56b3
--- /dev/null
+++ b/dev-qt/qtimageformats/qtimageformats-6.7.0_rc.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Additional format plugins for the Qt image I/O system"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc64 ~riscv ~x86"
+fi
+
+IUSE="mng"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[gui]
+ media-libs/libwebp:=
+ media-libs/tiff:=
+ mng? ( media-libs/libmng:= )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DQT_FEATURE_jasper=OFF
+ $(qt_feature mng)
+ -DQT_FEATURE_tiff=ON
+ -DQT_FEATURE_webp=ON
+ -DQT_FEATURE_system_tiff=ON
+ -DQT_FEATURE_system_webp=ON
+ )
+
+ qt6-build_src_configure
+}