summaryrefslogtreecommitdiff
path: root/dev-qt/qtdeclarative/qtdeclarative-6.7.0_rc-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtdeclarative/qtdeclarative-6.7.0_rc-r1.ebuild')
-rw-r--r--dev-qt/qtdeclarative/qtdeclarative-6.7.0_rc-r1.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-qt/qtdeclarative/qtdeclarative-6.7.0_rc-r1.ebuild b/dev-qt/qtdeclarative/qtdeclarative-6.7.0_rc-r1.ebuild
deleted file mode 100644
index 235c4f16520f..000000000000
--- a/dev-qt/qtdeclarative/qtdeclarative-6.7.0_rc-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 2021-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-inherit python-any-r1 qt6-build
-
-DESCRIPTION="Qt Declarative (Quick 2)"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
-fi
-
-IUSE="accessibility +network opengl +sql +ssl vulkan +widgets"
-
-# behaves very badly when qtdeclarative is not already installed, also
-# other more minor issues (installs junk, sandbox/offscreen issues)
-RESTRICT="test"
-
-RDEPEND="~dev-qt/qtbase-${PV}:6[accessibility=,gui,network=,opengl=,sql?,ssl?,vulkan=,widgets=]"
-DEPEND="
- ${RDEPEND}
- vulkan? ( dev-util/vulkan-headers )
-"
-BDEPEND="
- ${PYTHON_DEPS}
- ~dev-qt/qtshadertools-${PV}:6
-"
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package sql Qt6Sql)
- $(qt_feature network qml_network)
- $(qt_feature ssl qml_ssl)
- )
-
- qt6-build_src_configure
-}