summaryrefslogtreecommitdiff
path: root/dev-qt/qt-creator/qt-creator-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qt-creator/qt-creator-9999.ebuild')
-rw-r--r--dev-qt/qt-creator/qt-creator-9999.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/dev-qt/qt-creator/qt-creator-9999.ebuild b/dev-qt/qt-creator/qt-creator-9999.ebuild
index 7e70e0a5b37d..23836162a90d 100644
--- a/dev-qt/qt-creator/qt-creator-9999.ebuild
+++ b/dev-qt/qt-creator/qt-creator-9999.ebuild
@@ -45,16 +45,19 @@ IUSE="
REQUIRED_USE="clang? ( ${LLVM_REQUIRED_USE} )"
RESTRICT="!test? ( test )"
-QT_PV=6.2.0:6 # IDE_QT_VERSION_MIN
+QT_PV=6.5.4:6
# := is used where Qt's private APIs are used for safety
COMMON_DEPEND="
+ dev-cpp/yaml-cpp:=
>=dev-qt/qt5compat-${QT_PV}
>=dev-qt/qtbase-${QT_PV}=[concurrent,dbus,gui,network,widgets,xml]
>=dev-qt/qtdeclarative-${QT_PV}=
clang? (
- dev-cpp/yaml-cpp:=
- $(llvm_gen_dep 'sys-devel/clang:${LLVM_SLOT}=')
+ $(llvm_gen_dep '
+ sys-devel/clang:${LLVM_SLOT}=
+ sys-devel/llvm:${LLVM_SLOT}=
+ ')
)
designer? ( >=dev-qt/qttools-${QT_PV}[designer] )
help? (
@@ -143,12 +146,13 @@ src_configure() {
use elibc_musl && append-lfs-flags
local mycmakeargs=(
+ -DBUILD_DEVELOPER_DOCS=$(usex doc)
+ -DBUILD_DOCS_BY_DEFAULT=$(usex doc)
-DBUILD_WITH_PCH=no
-DWITH_DOCS=$(usex doc)
- -DBUILD_DEVELOPER_DOCS=$(usex doc)
-DWITH_TESTS=$(usex test)
- # TODO: try unbundling now that slot 6 exists+unmasked (bug #934462)
+ # sticking to bundled for now until it switches to KF6's
-DBUILD_LIBRARY_KSYNTAXHIGHLIGHTING=yes
# Much can be optional, but do not want to flood users (or maintainers)
@@ -180,7 +184,9 @@ src_configure() {
-DWITH_QMLDESIGNER=$(usex qmldesigner)
- -Djournald=no # not really useful unless match qtbase (needs systemd)
+ # meant to be in sync with qtbase[journald], but think(?) not worth
+ # handling given qt-creator can use QT_FORCE_STDERR_LOGGING=1 nowadays
+ -Djournald=no
# not packaged, but allow using if found
#-DCMAKE_DISABLE_FIND_PACKAGE_LibDDemangle=yes
@@ -206,12 +212,6 @@ src_test() {
cmake_src_test --label-exclude exclude_from_precheck
}
-src_compile() {
- cmake_src_compile
-
- use doc && cmake_build {qch,html}_docs
-}
-
src_install() {
cmake_src_install