summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin261514 -> 261514 bytes
-rw-r--r--dev-python/pypy3/Manifest2
-rw-r--r--dev-python/pypy3/pypy3-7.3.9_p8.ebuild210
3 files changed, 212 insertions, 0 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 7fc0abee9238..79c8836d7be9 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/pypy3/Manifest b/dev-python/pypy3/Manifest
index 012bd4082d19..3ef7c317fcb7 100644
--- a/dev-python/pypy3/Manifest
+++ b/dev-python/pypy3/Manifest
@@ -1,4 +1,6 @@
DIST pypy3.9-gentoo-patches-7.3.9_p5.tar.xz 13044 BLAKE2B 0a6119c3393a8b2d599659cee2a57b2a06b18c8dbe0f04fcdbcdde98098c1f19f51c2f387b20fd8db48c6e9dc52f08baeea5f722caf751c0a13078df00538450 SHA512 7965425e107058231657d94e923d132368f11fbc1451f5ae93379f4fc8f8ea62f9e22786b1a97b37a8b4bdb8a295fc5517f07143d04e21b4990f653c0e5f1f05
+DIST pypy3.9-gentoo-patches-7.3.9_p8.tar.xz 15660 BLAKE2B 0d2d2c6e4795b7a30eb1e0e6ccd617cff347c318de46794fc677f8200bf95d1f6c79c180b9e0deff4af60f55f9f3c962dc415f30dc75815d4889290574a64967 SHA512 426acc3345f4629106ace49fbce6256002ae4178d2e24ab9bb44d804adc31990bc6a6873d0e4a55a54c807910fa859b9b0759e7a691fed210ccb4c5c1b650851
DIST pypy3.9-v7.3.9-src.tar.bz2 26976726 BLAKE2B bf1ed21c575901abac020120aaff07ab57f1404713211b19cbd1eb4d6ffc675b7933be8c6fffc2b69ab467963d6598534cd5aa90c02feddad596611d2a6b6581 SHA512 83f8a6a2da351c190d2d224242cbc35e35529c7a8e8d842eaf5c945cbce2e172b02a340f32af3d49df8d5288370d794d5bc95fc12dd4a13d817c925abf06198a
EBUILD pypy3-7.3.9_p5-r2.ebuild 5762 BLAKE2B 3aee68d655c6d2ab2f69dd8873e5793d341c2f8cb48a8251358c0be5787cc5d9cfc2f22a80e32c10323c58b3e44b4428a6b110e94336bd6a873b6dc7ebb022de SHA512 bf2cf7581bd27d0f2e3fcc6008e26c2fcbac4f6c8de18a628dfc06cfd5e16c1fb3d16c0da1272f073186742ec8e3329d0c4dd1ec4dc27eb85c61f182fa542375
+EBUILD pypy3-7.3.9_p8.ebuild 5764 BLAKE2B 9f6db9320c8ca19a21d745bee5ba1789d08169c05a02476fbdf776f23a560e733fda4e7f376cd8458ab936eec2b4650a8c55912e5749d29895b8996010bc67e4 SHA512 3452123bc9d9ca76aa576cd2f8cc8e102f59ddd5e8109218d8dae97b1b7a3ad9072dae8e17ec8f03af2437f05dda92e0f3a441018cc1119a19392b74fade932a
MISC metadata.xml 455 BLAKE2B 568930d8cb9c6efa7e41d2285fa487ab7aee2344c11fe5cc325d24d6dbcd1184daffcad3b262351b39a45cdf7994ed301b61946eafa1be901b7419636d2eebd9 SHA512 357104cf9ac21d9c7fa5d843cfa7e2c5883d2f11e0bc15ac0fa8ab36a9595194ac05165f5aee94c3eb98ad370f0bf16f4488819311f8f077e9f2a79586f711f0
diff --git a/dev-python/pypy3/pypy3-7.3.9_p8.ebuild b/dev-python/pypy3/pypy3-7.3.9_p8.ebuild
new file mode 100644
index 000000000000..cc432aa66089
--- /dev/null
+++ b/dev-python/pypy3/pypy3-7.3.9_p8.ebuild
@@ -0,0 +1,210 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python2_7 )
+inherit pax-utils python-any-r1 toolchain-funcs
+
+PYPY_PV=${PV%_p*}
+MY_P=pypy3.9-v${PYPY_PV/_rc/rc}
+PATCHSET="pypy3.9-gentoo-patches-${PV/_rc/rc}"
+
+DESCRIPTION="A fast, compliant alternative implementation of the Python (3.9) language"
+HOMEPAGE="
+ https://www.pypy.org/
+ https://foss.heptapod.net/pypy/pypy/
+"
+SRC_URI="
+ https://buildbot.pypy.org/pypy/${MY_P}-src.tar.bz2
+ https://dev.gentoo.org/~mgorny/dist/python/${PATCHSET}.tar.xz
+"
+S="${WORKDIR}/${MY_P}-src"
+
+LICENSE="MIT"
+# pypy3 -c 'import sysconfig; print(sysconfig.get_config_var("SOABI"))'
+# also check pypy/interpreter/pycode.py -> pypy_incremental_magic
+SLOT="0/pypy39-pp73-336"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+ensurepip gdbm +jit ncurses sqlite test tk"
+# many tests are failing upstream
+# see https://buildbot.pypy.org/summary?branch=py3.9
+RESTRICT="test"
+
+RDEPEND="
+ || (
+ >=dev-python/pypy3-exe-${PYPY_PV}_p3:3.9-${PYPY_PV}[bzip2(+),ncurses?]
+ >=dev-python/pypy3-exe-bin-${PYPY_PV}_p3:3.9-${PYPY_PV}
+ )
+ dev-lang/python-exec[python_targets_pypy3(-)]
+ dev-libs/openssl:0=
+ ensurepip? ( dev-python/ensurepip-wheels )
+ gdbm? ( sys-libs/gdbm:0= )
+ sqlite? ( dev-db/sqlite:3= )
+ tk? (
+ dev-lang/tk:0=
+ dev-tcltk/tix:0=
+ )
+ !<dev-python/pypy3-bin-7.3.0:0
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ ${PYTHON_DEPS}
+ !!dev-python/pytest-forked
+ )
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ local PATCHES=(
+ "${WORKDIR}/${PATCHSET}"
+ )
+ default
+
+ eapply_user
+}
+
+src_configure() {
+ tc-export CC
+}
+
+src_compile() {
+ mkdir bin || die
+ # switch to the layout expected for cffi module builds
+ mkdir include/pypy3.9 || die
+ # copy over to make sys.prefix happy
+ cp -p "${BROOT}"/usr/bin/pypy3.9-c-${PYPY_PV} pypy3.9-c || die
+ cp -p "${BROOT}"/usr/include/pypy3.9/${PYPY_PV}/* include/pypy3.9/ || die
+ # (not installed by pypy-exe)
+ rm pypy/module/cpyext/include/_numpypy/numpy/README || die
+ mv pypy/module/cpyext/include/* include/pypy3.9/ || die
+ mv pypy/module/cpyext/parse/*.h include/pypy3.9/ || die
+ pax-mark m pypy3.9-c
+
+ # verify the subslot
+ local soabi=$(
+ ./pypy3.9-c - <<-EOF
+ import importlib.util
+ import sysconfig
+ soabi = sysconfig.get_config_var("SOABI")
+ magic = importlib.util._RAW_MAGIC_NUMBER & 0xffff
+ print(f"{soabi}-{magic}")
+ EOF
+ )
+ [[ ${soabi} == ${SLOT#*/} ]] || die "update subslot to ${soabi}"
+
+ # Add epython.py to the distribution
+ echo 'EPYTHON="pypy3"' > lib-python/3/epython.py || die
+
+ einfo "Generating caches and CFFI modules ..."
+
+ # Generate Grammar and PatternGrammar pickles.
+ ./pypy3.9-c - <<-EOF || die "Generation of Grammar and PatternGrammar pickles failed"
+ import lib2to3.pygram
+ import lib2to3.patcomp
+ lib2to3.patcomp.PatternCompiler()
+ EOF
+
+ # Generate cffi modules
+ # Please keep in sync with pypy/tool/build_cffi_imports.py!
+ # (NB: we build CFFI modules first to avoid error log when importing
+ # build_cffi_imports).
+ cffi_targets=( pypy_util blake2/_blake2 sha3/_sha3 ssl
+ audioop syslog pwdgrp resource lzma posixshmem )
+ use gdbm && cffi_targets+=( gdbm )
+ use ncurses && cffi_targets+=( curses )
+ use sqlite && cffi_targets+=( sqlite3 )
+ use tk && cffi_targets+=( tkinter/tklib )
+
+ local t
+ # all modules except tkinter output to .
+ # tkinter outputs to the correct dir ...
+ cd lib_pypy || die
+ for t in "${cffi_targets[@]}"; do
+ # tkinter doesn't work via -m
+ ../pypy3.9-c "_${t}_build.py" || die "Failed to build CFFI bindings for ${t}"
+ done
+
+ # Verify that CFFI module list is up-to-date
+ local expected_cksum=63d4659f
+ local local_cksum=$(
+ ../pypy3.9-c - <<-EOF
+ import binascii
+ import json
+ from pypy_tools.build_cffi_imports import cffi_build_scripts as x
+ print("%08x" % (binascii.crc32(json.dumps(x).encode()),))
+ EOF
+ )
+ if [[ ${local_cksum} != ${expected_cksum} ]]; then
+ die "Please verify cffi_targets and update checksum to ${local_cksum}"
+ fi
+
+ # Cleanup temporary objects
+ find -name "*_cffi.[co]" -delete || die
+ find -type d -empty -delete || die
+}
+
+src_test() {
+ # (unset)
+ local -x PYTHONDONTWRITEBYTECODE=
+ local -x COLUMNS=80
+
+ # Test runner requires Python 2 too. However, it spawns PyPy3
+ # internally so that we end up testing the correct interpreter.
+ # (--deselect for failing doctests)
+ "${EPYTHON}" ./pypy/test_all.py --pypy=./pypy3.9-c -vv lib-python || die
+}
+
+src_install() {
+ einfo "Installing PyPy ..."
+ dodir /usr/bin
+ dosym pypy3.9-c-${PYPY_PV} /usr/bin/pypy3.9
+ dosym pypy3.9 /usr/bin/pypy3
+ insinto /usr/lib/pypy3.9
+ # preserve mtimes to avoid obsoleting caches
+ insopts -p
+ doins -r lib-python/3/. lib_pypy/.
+ insinto /usr/include
+ doins -r include/pypy3.9
+
+ # replace copied headers with symlinks
+ for x in "${BROOT}"/usr/include/pypy3.9/${PYPY_PV}/*; do
+ dosym "${PYPY_PV}/${x##*/}" "/usr/include/pypy3.9/${x##*/}"
+ done
+
+ dodoc README.rst
+
+ local dest=/usr/lib/pypy3.9
+ rm -r "${ED}${dest}"/ensurepip/_bundled || die
+ if ! use ensurepip; then
+ rm -r "${ED}${dest}"/ensurepip || die
+ fi
+ if ! use gdbm; then
+ rm -r "${ED}${dest}"/_gdbm* || die
+ fi
+ if ! use sqlite; then
+ rm -r "${ED}${dest}"/sqlite3 \
+ "${ED}${dest}"/_sqlite3* \
+ "${ED}${dest}"/test/test_sqlite.py || die
+ fi
+ if ! use tk; then
+ rm -r "${ED}${dest}"/{idlelib,tkinter} \
+ "${ED}${dest}"/_tkinter \
+ "${ED}${dest}"/test/test_{tcl,tk,ttk*}.py || die
+ fi
+
+ local -x EPYTHON=pypy3
+ local -x PYTHON=${ED}/usr/bin/pypy3.9-c-${PYPY_PV}
+ # temporarily copy to build tree to facilitate module builds
+ cp -p "${BROOT}/usr/bin/pypy3.9-c-${PYPY_PV}" "${PYTHON}" || die
+
+ einfo "Byte-compiling Python standard library..."
+ python_optimize "${ED}${dest}"
+
+ # remove to avoid collisions
+ rm "${PYTHON}" || die
+}