summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin269966 -> 269981 bytes
-rw-r--r--dev-python/identify/Manifest2
-rw-r--r--dev-python/identify/identify-2.5.32.ebuild29
-rw-r--r--dev-python/jupyterlab/Manifest2
-rw-r--r--dev-python/jupyterlab/jupyterlab-4.0.9.ebuild77
-rw-r--r--dev-python/lxml/Manifest2
-rw-r--r--dev-python/lxml/lxml-4.9.3-r2.ebuild4
-rw-r--r--dev-python/pyfakefs/Manifest4
-rw-r--r--dev-python/pyfakefs/pyfakefs-5.3.0.ebuild11
-rw-r--r--dev-python/pyfakefs/pyfakefs-5.3.1.ebuild46
-rw-r--r--dev-python/tavern/Manifest3
-rw-r--r--dev-python/tavern/files/tavern-2.6.0-py312.patch38
-rw-r--r--dev-python/tavern/tavern-2.6.0.ebuild59
13 files changed, 275 insertions, 2 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 54588f0196fb..533d7578488d 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/identify/Manifest b/dev-python/identify/Manifest
index 0b7d8f634b5b..0383f4f94dd2 100644
--- a/dev-python/identify/Manifest
+++ b/dev-python/identify/Manifest
@@ -1,3 +1,5 @@
DIST identify-2.5.31.gh.tar.gz 101612 BLAKE2B 1b74bf8b352cc0f6f0051ccdba192515a1436bfa9e41f971ac929e356737c586c48d1684b982d468e42489e97913a46357dc705a766066c9edb6e6d43f1bbf89 SHA512 00116339c82625087c58a7393bf88800608a152a56fd03b13d1e9ff8c404fa9cfc6ac6824ac1b6eadba572f0e13fb0010789bcdefb7f551b15df4c3de98f77bc
+DIST identify-2.5.32.gh.tar.gz 101673 BLAKE2B a24c0df85c482fbc04adce0be258aa96ffa387eb569365fcdf589cf5fc4d3823ade3c60a0e2e9df65610506bc0d74c532b9964af1fea367191e3c4572e62388f SHA512 104326e2c1529c89425eeaf738a65bf9fc7f2dfa99e7aae18b33c8250aa34f3ead0371dbd2dad9253100de59f618c6c8d3c033f406eec179f1dcce47fe43fc36
EBUILD identify-2.5.31.ebuild 596 BLAKE2B 1ff0ef25ec8161f1b282f48401a18dbc6d8f219918089037de21686fb0fd509123a9d606c738680280effe304933771a345dda486331c942461866adcee6966f SHA512 9c58fc5a62222484d168a4be7c7463fa343fd487098318c53e3479d0508b0d75d460e217585a9ad2036262390037c03549267749093d24a6527216d217b198aa
+EBUILD identify-2.5.32.ebuild 598 BLAKE2B 15278ce98c490e872627af90b592d7c0912e7c68454e1ef02eccfe16995ddcebeb1896cc39b32c7310917c918dc8f34eacfeb1f8e5f74a282da5e5bbbd6bd6a4 SHA512 17a7eb2058b35699616c32621ecc7bee9222b6773b6cf37faa0cab88820c3c297d806ffa8d23b63ac3335ce594b27091be61f85e1f4a8725d35057830ad5b33e
MISC metadata.xml 501 BLAKE2B da95534590927f7290f78f47e30484e3349c9058048c15522e7346a74d9a2c96141a18897b10b230adf966d3c237217ef1d2dcfe59814ccfffd58ab4c38c1ebf SHA512 8d78245bbd2e14016eb70f1d8f8d6129e6b265084f7da95bd915f01ce5af94f86bd69c33c1514195de70d0f834332d9ca968a18afb59a7016c8cb58681d04d24
diff --git a/dev-python/identify/identify-2.5.32.ebuild b/dev-python/identify/identify-2.5.32.ebuild
new file mode 100644
index 000000000000..906b58d7a709
--- /dev/null
+++ b/dev-python/identify/identify-2.5.32.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="
+ https://github.com/pre-commit/identify/
+ https://pypi.org/project/identify/
+"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/ukkonen[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/jupyterlab/Manifest b/dev-python/jupyterlab/Manifest
index b32c607fdbe5..b35282ee8803 100644
--- a/dev-python/jupyterlab/Manifest
+++ b/dev-python/jupyterlab/Manifest
@@ -1,7 +1,9 @@
DIST jupyterlab-4.0.6.tar.gz 18236816 BLAKE2B e39e7cb6fbdecfee0b5e592091f989fe94907369d057457130f8bc2f391ca4c83cc09542bc9da766413821eb4c4e9eaaca3adfeccf26b0b2f61ab5e65dac9e45 SHA512 fc4acde65f2bb24adbf95e5cde17e0225390a0c8aca10e04b7c9cf5b2bcebe529608b53ce259f081508b86216b94c71fb260c857b9fe3a2bef16cb4e7af3dcda
DIST jupyterlab-4.0.7.tar.gz 18316994 BLAKE2B 9965a2bcb0b926af17626e9aef7b37e62144685e4e6cb17b029f3b760d4d4ba583c772683078c3f7cf7fbb09d31e5214193757116873e4457596d7522ddbbf04 SHA512 2f65f8aba9db17574d5caa030437c57ca98808561645f0b30b9fd4fe2cc49f6234776a36db474051cdfeebf1d9e7f3b874189110c955edecb89506580d8917e3
DIST jupyterlab-4.0.8.tar.gz 18345373 BLAKE2B f6d3b1f53e23f5107775c442b4c69b435091035a9369423e7f474d6a6b77c163ba49b766cc4368b1764d08beea89b881389699920e9f076ad02c8266809bfee9 SHA512 991d17b1338cd172364f812698c989b1d9f853a24d97ce3eb0f89f1ebbe78bc740ab2eafb37e929ac623ac8c06188ed0dcc7ec85ab8d3d9103019c33b45fcf6b
+DIST jupyterlab-4.0.9.tar.gz 18347162 BLAKE2B b4a62088dd8b3b646af1ea02a57c915d659f31e716e6db27c076c945340a53c742cff49518e5b13ada32a9b00f83f143e5504ae897a7abf454a7c997f72e00e6 SHA512 c87451821afa28e7016acdcff315cc48578ea1735b74c2732ed2570c326901acc38fa333344e89ba1c15799ac6bf3f9332c67cdd0ce8ac38713e0be6973d1c1a
EBUILD jupyterlab-4.0.6.ebuild 2604 BLAKE2B ab246a5c4871de44eac2db2078752882d181ea8e8c273c780596bfd0290e6782ca0ad4ab8b7a62a14193d9bca24b83bdb7fa6f278a9fb0c1818343815edea503 SHA512 c1f80304ddaabcc94f3dbdaca565325b7bc3b2b80e76025b5b78ce68b25667f989fae3ef08452bce5c96cc96c62d28f3e111a88e365e52b1f46d943a9fe481bb
EBUILD jupyterlab-4.0.7.ebuild 2609 BLAKE2B 6c0604ea37428a80237f4a23d7e8aa3e5904f3e19a8e7654d9226c1ace8396a15f6e49166a4292a92450cbc00ae2a4da5643434393f0860bbdae83d3ba2330d7 SHA512 6bb8004b92d1efa460c5a583198e8b491324900767e28cd07ca88d1421a69c8bf009f44914823e30e6d8c296faaa5ee87dfc7e194c4536b7793999795b056569
EBUILD jupyterlab-4.0.8.ebuild 2609 BLAKE2B 6c0604ea37428a80237f4a23d7e8aa3e5904f3e19a8e7654d9226c1ace8396a15f6e49166a4292a92450cbc00ae2a4da5643434393f0860bbdae83d3ba2330d7 SHA512 6bb8004b92d1efa460c5a583198e8b491324900767e28cd07ca88d1421a69c8bf009f44914823e30e6d8c296faaa5ee87dfc7e194c4536b7793999795b056569
+EBUILD jupyterlab-4.0.9.ebuild 2609 BLAKE2B 6c0604ea37428a80237f4a23d7e8aa3e5904f3e19a8e7654d9226c1ace8396a15f6e49166a4292a92450cbc00ae2a4da5643434393f0860bbdae83d3ba2330d7 SHA512 6bb8004b92d1efa460c5a583198e8b491324900767e28cd07ca88d1421a69c8bf009f44914823e30e6d8c296faaa5ee87dfc7e194c4536b7793999795b056569
MISC metadata.xml 412 BLAKE2B f0b40e19f8ba9dc116f0e4a882cabab6376f22d1eaeb3eac58ecff465ee2aff3564ddbf55e4ffb8971807a39945109a164037a954419671a274d3ac558b102ea SHA512 b6149a03585ca04bc3bf6f3ea6055e8e1fcb620a771359d150df7c22ee16bf09f57c8037df2161021fac0c194be0ac5ec79a31f0511d785e0c5b1ca96d817e42
diff --git a/dev-python/jupyterlab/jupyterlab-4.0.9.ebuild b/dev-python/jupyterlab/jupyterlab-4.0.9.ebuild
new file mode 100644
index 000000000000..a9ae6842f846
--- /dev/null
+++ b/dev-python/jupyterlab/jupyterlab-4.0.9.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi xdg
+
+DESCRIPTION="JupyterLab computational environment"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyterlab/jupyterlab/
+ https://pypi.org/project/jupyterlab/
+"
+
+LICENSE="BSD MIT GPL-3 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/async-lru[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.3[${PYTHON_USEDEP}]
+ dev-python/jupyter-core[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-lsp-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-2.4.0[${PYTHON_USEDEP}]
+ <dev-python/jupyter-server-3[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab-server-2.19[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-server-3[${PYTHON_USEDEP}]
+ >=dev-python/notebook-shim-0.2[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.2[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ net-libs/nodejs
+"
+
+BDEPEND="
+ dev-python/hatch-jupyter-builder[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ >=dev-python/pytest-jupyter-0.5.3[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-cache[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # These tests call npm and want internet
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_uninstall_core_extension
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned_folder
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom_minimal_core_config
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_check
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_clear
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_build
+)
+
+EPYTEST_IGNORE=(
+ jupyterlab/tests/test_announcements.py
+)
+
+distutils_enable_tests pytest
+# TODO: package sphinx_copybutton
+#distutils_enable_sphinx docs/source dev-python/sphinx-rtd-theme dev-python/myst-parser
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}
diff --git a/dev-python/lxml/Manifest b/dev-python/lxml/Manifest
index 19c6c5bc5d39..de9d7fdac42b 100644
--- a/dev-python/lxml/Manifest
+++ b/dev-python/lxml/Manifest
@@ -1,4 +1,4 @@
DIST lxml-4.9.3-patches-2.tar.xz 24288 BLAKE2B 47b7c486a1c1616c875111bd53b14d4211a1eee3f412985f4022e71b85b087abd71d36919fb025257f17de404329284898ddc639f85e8b15ade21778fa218d98 SHA512 713172b4c907db6479a0a803a842824825b212a9b645c1ca356f793658bd6c63113ea248278e7c46b512e22e3130696e9fc5127fea82a67372d920733fc160b0
DIST lxml-4.9.3.gh.tar.gz 958628 BLAKE2B ffdf3fe781a03815f7c026229d313721c93375ebafad9b4a20c5d8a380a631401e546d8701a94d8c49615fb6a71e84940d8ca0299b47a37c1c9596db36659113 SHA512 903bd4935c7708b459aee9befcf3f6e3e3aaa9adc122591ea923b6e3d8fd288f07cab3f5f0edb08e3bf9db80414324f0a1a8e5a5089f9cda82f6c50f5df59423
-EBUILD lxml-4.9.3-r2.ebuild 2919 BLAKE2B 38840aae6ffc940f7ae60e82467170f9dc2a1a6a163b314b5465656074c6cf690794ca5afe194a77ab30677d34e6138e3af252b44d6ac2a6e2ee524c289725bc SHA512 9b7370a6604aebeebd2630e78f3551e2a71300562f1cbd88e66ff8f4a12aa0d9748aef759c476186450a62a71a24d1c34319ee4eef0bf683e0f2f7a2515a7bca
+EBUILD lxml-4.9.3-r2.ebuild 2995 BLAKE2B f48ccbfdca26f9eb6e03a1823645e32c1815b653d9228c1b87036a16d01c89418765da5b0c0038f2e91eea1e1cc07f4018e8a1f901c79628437514b0d7d7ed6b SHA512 130dabb41404a1ad058c1efd9ff582e0c14441abe6a1733d716353a86167701041c9cc43554358a1ecdd83cba36019d618424421f1602772fe78ac80e6e45947
MISC metadata.xml 463 BLAKE2B 9bcd092b61568f5d467230617b101f36245c41078e6a66c7ff63b22a6b4095de2ba3a59e48ce8b7842ce58d1255fa293995652daa3fab4c3af988498eaa30e97 SHA512 2ba5e340b59e0de4e472380e9c19b1f6f573e86e5c3c2e075f6151d369e94eea70e3ce36bfb5ece4da3fa69459e3ff83368f1df8302aa5754ae52f13c8f2312e
diff --git a/dev-python/lxml/lxml-4.9.3-r2.ebuild b/dev-python/lxml/lxml-4.9.3-r2.ebuild
index 01ddc28bb840..cd6b75b3c807 100644
--- a/dev-python/lxml/lxml-4.9.3-r2.ebuild
+++ b/dev-python/lxml/lxml-4.9.3-r2.ebuild
@@ -76,6 +76,10 @@ python_prepare_all() {
}
python_compile() {
+ local DISTUTILS_ARGS=(
+ # by default it adds -w to CFLAGS
+ --warnings
+ )
tc-export PKG_CONFIG
distutils-r1_python_compile
}
diff --git a/dev-python/pyfakefs/Manifest b/dev-python/pyfakefs/Manifest
index e8ca967d8118..1e87eaff022a 100644
--- a/dev-python/pyfakefs/Manifest
+++ b/dev-python/pyfakefs/Manifest
@@ -1,3 +1,5 @@
DIST pyfakefs-5.3.0.gh.tar.gz 224241 BLAKE2B de6d1b420bcfe710bef00c4f8d9cd4fa838341a7285d89a02607701f0011ccbe7f1974c5eec502994f787661496f74332bc4d4aa3389023ae02607a968c33be5 SHA512 25d967390f66ba5881429a37b62110ef129aae989efe66740c3a04fccfcbc601476d23427ac23d5df82a1e1a8102d557f0cca39b94fa0c7e69b6dca80d1e435e
-EBUILD pyfakefs-5.3.0.ebuild 856 BLAKE2B 4c880b4ea2c173d883f2889f19c101d9326696e14cca0856a21dd7ff3bd1beb900448fc3f658d33285f2bc64fda48db6136a727cd171387734b8ee9360b80b62 SHA512 f6422c21a3301de8c0bad78bc5f6f56e7157a5fdf36f4b811be8f9a0b21d34a259aaee122bddb26ff660afadc4ddd70dd3cafb93f812074c6f6d406d312eb355
+DIST pyfakefs-5.3.1.gh.tar.gz 225234 BLAKE2B 2688a40ce22a112ce80de8795e3c0b0dd7e2cd46b41c442c5e13085ec614e323a5558cfa48e0e5c79c7c418a739b3f0a6202bb007e8c201ac3fbcc3b209a3d9f SHA512 6d2b16327e8f40d98ac84ea8662dc359aa1b590e1de71761d511b084268d44ee2950cd2af1ec4e722fcb6e7dd14b93e01969fa5cc12e178e97ca2ce69073deea
+EBUILD pyfakefs-5.3.0.ebuild 1155 BLAKE2B 0833728dc7ae88a62b3889d7ace0ff56b22a88620ebcc5dd64b01955550ab2b787d1b7d86755d59f040543dfa3980e4ec98cda00367c2f4d38a0a442baf95878 SHA512 7e7c44a677f2f986b447b50d729f5c3b6080f818a9dfb2661dec2ab8abc6914c150c9439bde207779fa91f8b1c6d91dc0f2175e6d83c69d96ff6d0cbecd014f6
+EBUILD pyfakefs-5.3.1.ebuild 1163 BLAKE2B 4a9c342c031ef158a8a4e53f37c049117efa09d62480a7cdc289cd28874b8c979c233cad7e4313154e87f067bd605279724f139bb258a35e7f4dbe57224797fa SHA512 853a90288a483d4ea9806417a8b8cb6daabae25e684229335f8cb6f57472b183c6d3ad2cccee8f0b9076cfd26a38e32d0cd3cab898ceb9eeb322861377549f9a
MISC metadata.xml 395 BLAKE2B add696dab9f93cad522087325d7cea08bb0d6905a093c0dd721b8ee0cc5f06a97e8b29663920e5131fd1cfaf38a1fb1c22908daa155025713ffbf18d87a2d5ec SHA512 454f9cf42ae315bb9d4b7c9a2a8b9a690163befc8f738b1fe4a145f1f3a9a5f59693e4cd1ebd4c501005cac1ab81c8b57b2316ac50739dfa96919b6de4850b9a
diff --git a/dev-python/pyfakefs/pyfakefs-5.3.0.ebuild b/dev-python/pyfakefs/pyfakefs-5.3.0.ebuild
index 10285776eca0..c34b2eaeac96 100644
--- a/dev-python/pyfakefs/pyfakefs-5.3.0.ebuild
+++ b/dev-python/pyfakefs/pyfakefs-5.3.0.ebuild
@@ -25,11 +25,22 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv
distutils_enable_tests pytest
python_test() {
+ local EPYTEST_DESELECT=()
local EPYTEST_IGNORE=(
# test for regression with opentimelineio package
pyfakefs/pytest_tests/segfault_test.py
)
+ case ${EPYTHON} in
+ python3.12)
+ EPYTEST_DESELECT+=(
+ # happens with pandas + zstandard [cffi backend]
+ # https://github.com/pytest-dev/pyfakefs/issues/910
+ pyfakefs/tests/patched_packages_test.py::TestPatchedPackages::test_read_{csv,table}
+ )
+ ;;
+ esac
+
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest -p pyfakefs.pytest_plugin
}
diff --git a/dev-python/pyfakefs/pyfakefs-5.3.1.ebuild b/dev-python/pyfakefs/pyfakefs-5.3.1.ebuild
new file mode 100644
index 000000000000..d5a9d7aac337
--- /dev/null
+++ b/dev-python/pyfakefs/pyfakefs-5.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A fake file system that mocks the Python file system modules"
+HOMEPAGE="
+ https://github.com/pytest-dev/pyfakefs/
+ https://pypi.org/project/pyfakefs/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pyfakefs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ local EPYTEST_IGNORE=(
+ # test for regression with opentimelineio package
+ pyfakefs/pytest_tests/segfault_test.py
+ )
+
+ case ${EPYTHON} in
+ python3.12)
+ EPYTEST_DESELECT+=(
+ # happens with pandas + zstandard [cffi backend]
+ # https://github.com/pytest-dev/pyfakefs/issues/910
+ pyfakefs/tests/patched_packages_test.py::TestPatchedPackages::test_read_{csv,table}
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pyfakefs.pytest_plugin
+}
diff --git a/dev-python/tavern/Manifest b/dev-python/tavern/Manifest
index c2eed64b5ba9..bc3dec8e9c08 100644
--- a/dev-python/tavern/Manifest
+++ b/dev-python/tavern/Manifest
@@ -1,5 +1,8 @@
+AUX tavern-2.6.0-py312.patch 1704 BLAKE2B 9973ce4194c392e705be5bab9aa4b4919a5ce36855b9a51d5988eaf78fdee3b27fbf891cfd01135ef7bdc50dee91b6e6cccb308ee5687db04548d7d7a0eca033 SHA512 a0efcb2187ad760d59c67b9af8c00f3a7d6b74bc94fc1eeae132345ef90c6ac1b6404b766e8d912ca2f0ffc395e0dfaf6f14f190f761149a221c51ae71b53bd4
DIST tavern-2.3.0.gh.tar.gz 211676 BLAKE2B 80506d846036c7a68bf27c30e734a92983eadaff07e68a101e120a6284be750bc195817f1686cdaabe8dfe906720e5b41d22098db8f91e911438a60a2cbdd5db SHA512 2c1292cd047195b6e2059514f517b29caebeac3af370b298938cbbc8b5bc861dd818c3e45e25a65fa1acbbae96f36aa2d024edcee49b0086d459f3d41d4052ed
DIST tavern-2.5.0.gh.tar.gz 217343 BLAKE2B bcb9d7f753b14351cd98e12e9d392f9effa716651f8686d053dc72080a2b738b02f78665f2bb07012b4c6ec7b39a661dfdc74a0272c036718cc13e2d731b4cee SHA512 9d957f815b57ba01d9707c1a3e8f715f062194efd0b24d82ebb99aec4bb83965e31a6538f3ff7748d3acd52b32cd38a097a4d36fe71faf1703dbf70ff0454111
+DIST tavern-2.6.0.gh.tar.gz 217509 BLAKE2B 99d9990757930a45a86a914fcf656b63266266869542cbd9b59850c7d648f54993ad5f409f12d09fbb12383c7586ecaeed323b04b478d62c7331cf514faa970a SHA512 1165dcc41244259d2ef7f69370dd35a40a9411b2a5c05e5dae45fc413d88478cd49aa540175a4a65dcf7dcd0eb2ee06b4f97059eb5d69ed5684893a8d5e8fcdc
EBUILD tavern-2.3.0.ebuild 1239 BLAKE2B 942e4e8999d4bcb14ed13e64372bbc71421664b761ae75c5d6483fd7656ebb9b4bce7a5d1b99d899980c3d846cc9d7882fa0ccfa8e4c64662688c4e35b824995 SHA512 df36c2cadd47f54b615ee2fd68d9c0ab287915ffb77498c8250eabc511e5860248b1bbe49c94d525e8d885ccde7691eaead88584cffcea5042a89e647e8f9743
EBUILD tavern-2.5.0.ebuild 1248 BLAKE2B bc8dc7bb5516fe88b6dcf98a9289fcb8850ae3c98f6ca4c3cbacc162048e576f81b6a1f81fcd5e93671aeead7314cedf374492a3d4ce722aeff790637504e9a8 SHA512 0d6fcfcb8bff0a0643486271beb8abdb6183f71b8fdfe0d675f5d6c5f3c76e2e8caf0e4b769c5c8e35f98d8c04d73aba3c1df5fa3ace62235a0a94c01edffa8f
+EBUILD tavern-2.6.0.ebuild 1345 BLAKE2B 35f495f9d310019357080a49837d811746623d62f08f6b2b86f69bbd3635017a0ebbbc335d96c1f0c51bc9645afa71f76cdd6c3fc104014bd808c48ed5ddff18 SHA512 b52d5fc9c473e180412a8301626f3d2ba21010d8237b1ad35f5ca48d6578c46e40e54d7872344bdc99f709bc63a941f702640e9a26a3e167a571ec2080cd0311
MISC metadata.xml 722 BLAKE2B 0ed7dd19f49aae7940de52b0df249979458b3950422e1089886929499d7a92d16a3a6e101b52313569900af6aec4e26388ae6d0673d5b1acef1e1615ed87d34a SHA512 3c30524ee5129700db664b5dab8635463ee17d4a45295583d79755c1f5b1dbba9ac611fcec3e9584028bfe96cf913f4f4b9d8da67a0e8ff6cde1ebedbf57c15a
diff --git a/dev-python/tavern/files/tavern-2.6.0-py312.patch b/dev-python/tavern/files/tavern-2.6.0-py312.patch
new file mode 100644
index 000000000000..679b0c9d2358
--- /dev/null
+++ b/dev-python/tavern/files/tavern-2.6.0-py312.patch
@@ -0,0 +1,38 @@
+From 8c09a6f31d84904dcf411e50102ac1ad159e4dd9 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sun, 19 Nov 2023 08:56:20 +0100
+Subject: [PATCH] Fix assertion in TestCheckParseValues::test_warns_bad_type
+
+Fix the assertion in TestCheckParseValues::test_warns_bad_type
+to use `.assert_called_with()` rather than non-existing `.called_with()`
+method. The latter is wrongly interpreted as calling a mocked method
+in Python < 3.12, and therefore does not test anything at all. Starting
+with Python 3.12, it results in an error:
+
+ AttributeError: 'called_with' is not a valid assertion. Use a spec for the mock if 'called_with' is meant to be an attribute.
+
+Fixing the call also revealed that the assertion was incorrect, so I've
+updated it to match the current call.
+---
+ tests/unit/test_helpers.py | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/tests/unit/test_helpers.py b/tests/unit/test_helpers.py
+index 0d3da1c4..19fddc08 100644
+--- a/tests/unit/test_helpers.py
++++ b/tests/unit/test_helpers.py
+@@ -300,10 +300,10 @@ def test_warns_bad_type(self, item):
+ with patch("tavern._core.dict_util.logger.warning") as wmock:
+ _check_and_format_values("{fd}", {"fd": item})
+
+- assert wmock.called_with(
+- "Formatting 'fd' will result in it being coerced to a string (it is a {})".format(
+- type(item)
+- )
++ wmock.assert_called_with(
++ "Formatting '%s' will result in it being coerced to a string (it is a %s)",
++ "fd",
++ type(item),
+ )
+
+ @pytest.mark.parametrize("item", [1, "a", 1.3, format_keys("{s}", {"s": 2})])
diff --git a/dev-python/tavern/tavern-2.6.0.ebuild b/dev-python/tavern/tavern-2.6.0.ebuild
new file mode 100644
index 000000000000..0f7c20bb2375
--- /dev/null
+++ b/dev-python/tavern/tavern-2.6.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool, library, and Pytest plugin for testing RESTful APIs"
+HOMEPAGE="
+ https://github.com/taverntesting/tavern/
+ https://pypi.org/project/tavern/
+"
+SRC_URI="
+ https://github.com/taverntesting/tavern/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/paho-mqtt[${PYTHON_USEDEP}]
+ >=dev-python/pyjwt-2.6.0[${PYTHON_USEDEP}]
+ dev-python/pykwalify[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/python-box[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-6.0.1[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/stevedore[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/Faker[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}/${P}-py312.patch"
+ )
+
+ # strip unnecessary pins, upstream doesn't update them a lot
+ sed -i -E -e 's:,?<=?[0-9.]+::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p tavern
+}