summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin270865 -> 271181 bytes
-rw-r--r--dev-python/hishel/Manifest3
-rw-r--r--dev-python/hishel/hishel-0.0.25.ebuild55
-rw-r--r--dev-python/hishel/metadata.xml12
-rw-r--r--dev-python/pbs-installer/Manifest3
-rw-r--r--dev-python/pbs-installer/metadata.xml12
-rw-r--r--dev-python/pbs-installer/pbs-installer-2024.4.1.ebuild31
-rw-r--r--dev-python/pdm/Manifest2
-rw-r--r--dev-python/pdm/pdm-2.13.3.ebuild113
-rw-r--r--dev-python/snakeoil/Manifest2
-rw-r--r--dev-python/snakeoil/snakeoil-0.10.8.ebuild33
11 files changed, 266 insertions, 0 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 578f6ae5c131..0d7113202014 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/hishel/Manifest b/dev-python/hishel/Manifest
new file mode 100644
index 000000000000..f7e741b821f0
--- /dev/null
+++ b/dev-python/hishel/Manifest
@@ -0,0 +1,3 @@
+DIST hishel-0.0.25.gh.tar.gz 825114 BLAKE2B dd7d7bec47700a1ab07976ba31b951adacf7e917dd7ba09419cc6e3b81f1b6609a1f7f14a6c176b0c151ed255cf099f3da60122717b2be9161bd41b7ba080f36 SHA512 16aec1ea495075b4932e1e9d16b07af060b49bb74faed097343bde99c5d2b656b36762b2f2d67fd46c31b700206eec77ecdfb364a1c2cd19bb67c3055abc9e98
+EBUILD hishel-0.0.25.ebuild 1611 BLAKE2B efc386f50eca4161cc3c6da7bcb7e3171bbaae9eb83d0ca48e9918fc5b0b9c07963547c00c21b98f67c286b8e1a76ac6cea419abfe8817cbf08020d8977bab20 SHA512 0bc674f0e7ffab7d6c464ca23e1d80c26e7a337f969d4f763c6fa4dfa82454f08934f96c5285c1e09983a3b26f2cad0299aa1ef83051f346aa47594540cff0b4
+MISC metadata.xml 378 BLAKE2B 24bb3b6d47931488021a625ac5f4eca9575efaebabc4af29fcd42ea8468a0a8da077d88b98c6f348c7528d7b338fbf553475894fe0726f11ca48c6c5d4720f61 SHA512 ae67451815773cffe43a0e16ae42020f1c29fb83ad711633666b065be586a08e4da5ebcee8e35d7f0c0084c018713760a1f20b4b9a7f2a5d43691589be357b42
diff --git a/dev-python/hishel/hishel-0.0.25.ebuild b/dev-python/hishel/hishel-0.0.25.ebuild
new file mode 100644
index 000000000000..5d674e566749
--- /dev/null
+++ b/dev-python/hishel/hishel-0.0.25.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="An elegant HTTP Cache implementation for HTTPX and HTTP Core"
+HOMEPAGE="
+ https://github.com/karpetrosyan/hishel
+ https://pypi.org/project/hishel/
+"
+SRC_URI="https://github.com/karpetrosyan/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ test? (
+ dev-python/anyio[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # tests that need anysqlite
+ "tests/_async/test_storages.py::test_sqlitestorage[asyncio]"
+ "tests/_async/test_storages.py::test_sqlitestorage[trio]"
+
+ # tests that need a running redis instance
+ "tests/_async/test_storages.py::test_redisstorage[asyncio]"
+ "tests/_async/test_storages.py::test_redisstorage_expired[asyncio]"
+ "tests/_async/test_storages.py::test_sqlite_expired[asyncio]"
+ "tests/_sync/test_storages.py::test_redisstorage[asyncio]"
+ "tests/_sync/test_storages.py::test_redisstorage_expired[asyncio]"
+ "tests/_sync/test_storages.py::test_redisstorage[trio]"
+ "tests/_sync/test_storages.py::test_redisstorage_expired[trio]"
+)
+
+python_prepare_all() {
+ sed -e 's:mock_s3:mock_aws:g' \
+ -e '/import anysqlite/ d' \
+ -i tests/_async/test_storages.py \
+ tests/_sync/test_storages.py || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/hishel/metadata.xml b/dev-python/hishel/metadata.xml
new file mode 100644
index 000000000000..5cf037972bfe
--- /dev/null
+++ b/dev-python/hishel/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">hishel</remote-id>
+ <remote-id type="github">karpetrosyan/hishel</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pbs-installer/Manifest b/dev-python/pbs-installer/Manifest
new file mode 100644
index 000000000000..1f9144215756
--- /dev/null
+++ b/dev-python/pbs-installer/Manifest
@@ -0,0 +1,3 @@
+DIST pbs-installer-2024.4.1.gh.tar.gz 68006 BLAKE2B 5455b00dd08881e78fbbc9b565e9224ee7d04f17855da9869fcb420fcbf8ee3743e6f21113d406bcfb66e786788735bd1ef2d3bfa30a14a5a74fb2c36e8f3d0a SHA512 407ffc7a7f5430d8f889f32b53614cc2c5e3fb05937905d6b43c7ca9151f3d5cb794bcd60633e4945dc62555cc6575d75e0b7b7a1e5dc0c9f99c2318fada3a10
+EBUILD pbs-installer-2024.4.1.ebuild 656 BLAKE2B 7f3bdaa0ceacf196c2456c99dd146c58451183f22e9a3598d2f9d308b434b57f5d366864c67d9f905653ec845f7382a449cf53c1e65709dae62fef139421b7a9 SHA512 a04491179e2d9b7543ecddfcb30c9384fba78b69c76104c438b47ca086d5df2b3dbb31fcf0446e9956c54324862c8979f2b65db45411f1bfc5111da283c5dc1a
+MISC metadata.xml 389 BLAKE2B a37933cd9532954bab2a95cd74e8418c74b1fcf22e1916c39307c7f55e90ec8a086ab923a02111708e81b1a4103c1460a946f11d2f20eb837cc3dbe3386f45b9 SHA512 15f19301b81afb97098afd2174c89f0dd5f0cbe7fc1f7a31d13fc68c11d70d2f9190e1417d3d980503f278c7c3bbc6fc322bd0aeaa3de3da72e6e58190aaf107
diff --git a/dev-python/pbs-installer/metadata.xml b/dev-python/pbs-installer/metadata.xml
new file mode 100644
index 000000000000..10fd06206281
--- /dev/null
+++ b/dev-python/pbs-installer/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pbs-installer</remote-id>
+ <remote-id type="github">frostming/pbs-installer</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pbs-installer/pbs-installer-2024.4.1.ebuild b/dev-python/pbs-installer/pbs-installer-2024.4.1.ebuild
new file mode 100644
index 000000000000..dfe012214833
--- /dev/null
+++ b/dev-python/pbs-installer/pbs-installer-2024.4.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="Installer for Python Build Standalone"
+HOMEPAGE="
+ https://pypi.org/project/pbs-installer/
+ https://github.com/frostming/pbs-installer/
+
+"
+SRC_URI="https://github.com/frostming/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/zstandard[${PYTHON_USEDEP}]
+"
+
+# upstream does not provide any tests
+RESTRICT=test
+
+python_configure_all() {
+ export PDM_BUILD_SCM_VERSION=${PV}
+}
diff --git a/dev-python/pdm/Manifest b/dev-python/pdm/Manifest
index 72387a8ef931..1bc0f32d70d9 100644
--- a/dev-python/pdm/Manifest
+++ b/dev-python/pdm/Manifest
@@ -1,3 +1,5 @@
DIST pdm-2.12.4.tar.gz 2598160 BLAKE2B 9eecae679a577c9d6172a07ad633be8b840ac5d972ad0e468b368dabc716203d10c5f0c78e87b815aa30af3be37f6370bcb6623fc5d272a52b6c3e4490112455 SHA512 12cabaff90f962ac195a484ea2bafa8a5ec9debdaf90b59b81d28eee51f854b9ac6d894e22a16c5ad8b69740c5df6a6573942a82c4ea5482819e60bc903c8358
+DIST pdm-2.13.3.tar.gz 2609678 BLAKE2B 58eb9fda4bc30fc37ef43b38fa140252242c22a062c4ddef49e90c0ece102cb36ea2186b02fb995a895c6eb80c0da9e602c42c15e83158b3e19fa5d0f55e8d6a SHA512 ea4b0e51d13effe8749a95237799de304047dcec8efc22a41d0985c97ff39447065a9fc84f4510b18055527dd64695bcee4129abcf34221573b2b9d39c2a3c92
EBUILD pdm-2.12.4.ebuild 2704 BLAKE2B 5bc1fc583ed61400cb41cf923f8a2bd4118cc83980d7bd666d419c698241b4ad3762e2d97663568365ef275f2890d3c838de2007ea33b5a9232c1f996ee4a43e SHA512 2b1c4a2b619d7c0a8531f3068bbaa36e85c1f6a77639f0209cf9ef47422abf10303eb7d8a4a71001e45d877247805c30d5751115c490a8808293f5b3a9c31f28
+EBUILD pdm-2.13.3.ebuild 4779 BLAKE2B c3c63b30e3bc3de202d41bfbf1a7f4a26f8e663f0a5194bde4d0e6ec4cab43384b587b030a1e919e5a8a2b3124a3acc40ae45b55051c4be49d7020d5b818bb78 SHA512 1dee8ae655f3c6ef5836ce88b25ce65b9a45ca8655733b24c609ea0f03b4c90759c04e0e1a2d76201df2c81da4318f1e7fd8290c082242f0078da47e36a81abe
MISC metadata.xml 474 BLAKE2B c1471e124a955920e30f73dfa43a87999c30c2bb9615590f601befcc07f7d939ec68908e67c7345fca4cb0f0524d33507aeac9936fa30d449d1dde17094048d3 SHA512 a07256061dda5a8cf8b0e15205ac36651a4e5b594fdedbfe16d1d3264e1ac42847d1dc222d2857232ac5206d67feda432751695d85d0c4c7b03fd7228db8b1ab
diff --git a/dev-python/pdm/pdm-2.13.3.ebuild b/dev-python/pdm/pdm-2.13.3.ebuild
new file mode 100644
index 000000000000..0b2f82066443
--- /dev/null
+++ b/dev-python/pdm/pdm-2.13.3.ebuild
@@ -0,0 +1,113 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python package and dependency manager supporting the latest PEP standards"
+HOMEPAGE="
+ https://pdm-project.org/
+ https://github.com/pdm-project/pdm/
+ https://pypi.org/project/pdm/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-python/blinker[${PYTHON_USEDEP}]
+ >=dev-python/dep-logic-0.2.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ dev-python/truststore[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/hishel[${PYTHON_USEDEP}]
+ dev-python/pbs-installer[${PYTHON_USEDEP}]
+ dev-python/pyproject-hooks[${PYTHON_USEDEP}]
+ >=dev-python/unearth-0.15.0[${PYTHON_USEDEP}]
+ <dev-python/findpython-1[${PYTHON_USEDEP}]
+ >=dev-python/findpython-0.6.0[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ dev-python/shellingham[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ >=dev-python/resolvelib-1.0.1[${PYTHON_USEDEP}]
+ dev-python/installer[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ 'tests/cli/test_build.py::test_build_with_no_isolation[False]'
+ tests/test_project.py::test_access_index_with_auth
+ tests/cli/test_others.py::test_build_distributions
+ 'tests/models/test_candidates.py::test_expand_project_root_in_url[demo @ file:///${PROJECT_ROOT}/tests/fixtures/artifacts/demo-0.0.1.tar.gz]'
+ 'tests/models/test_candidates.py::test_expand_project_root_in_url[-e file:///${PROJECT_ROOT}/tests/fixtures/projects/demo-#-with-hash#egg=demo]'
+ tests/models/test_candidates.py::test_find_candidates_from_find_links
+ tests/cli/test_build.py::test_build_single_module
+ tests/cli/test_build.py::test_build_single_module_with_readme
+ tests/cli/test_build.py::test_build_package
+ tests/cli/test_build.py::test_build_src_package
+ tests/cli/test_build.py::test_build_package_include
+ tests/cli/test_build.py::test_build_src_package_by_include
+ tests/cli/test_build.py::test_build_with_config_settings
+ tests/cli/test_build.py::test_cli_build_with_config_settings
+ tests/cli/test_build.py::test_build_ignoring_pip_environment
+ tests/cli/test_others.py::test_show_self_package
+ tests/cli/test_publish.py::test_publish_and_build_in_one_run
+ "tests/cli/test_hooks.py::test_hooks[build]"
+ "tests/cli/test_hooks.py::test_hooks[publish]"
+ "tests/cli/test_hooks.py::test_skip_option_from_signal[build-pre_build]"
+ "tests/cli/test_hooks.py::test_skip_option_from_signal[build-post_build]"
+ "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-pre_publish]"
+ "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-pre_build]"
+ "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-post_build]"
+ "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-post_publish]"
+ "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:all-build]"
+ "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:all-publish]"
+ "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:pre,:post-build]"
+ "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:pre,:post-publish]"
+ "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[pre-build]"
+ "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[pre-publish]"
+ "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[post-build]"
+ "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[post-publish]"
+ "tests/cli/test_venv.py::test_conda_backend_create[True]"
+ "tests/cli/test_venv.py::test_conda_backend_create[False]"
+ # hangs on interactive keyring prompts
+ tests/cli/test_config.py::test_repository_overwrite_default
+ tests/cli/test_config.py::test_hide_password_in_output_repository
+ tests/cli/test_config.py::test_hide_password_in_output_pypi
+ # junk output, sigh
+ tests/cli/test_others.py::test_info_command_json
+ # why does it try to use python 2.7?!
+ tests/cli/test_run.py::test_import_another_sitecustomize
+ )
+ [[ ${EPYTHON} != python3.10 ]] && EPYTEST_DESELECT+=(
+ # test seems hardcoded to 3.10
+ tests/test_project.py::test_project_packages_path
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m "not network and not integration and not path" \
+ -p pytest_mock
+}
diff --git a/dev-python/snakeoil/Manifest b/dev-python/snakeoil/Manifest
index 0edb72bfa73a..df8feba02d09 100644
--- a/dev-python/snakeoil/Manifest
+++ b/dev-python/snakeoil/Manifest
@@ -1,8 +1,10 @@
DIST snakeoil-0.10.5.tar.gz 183358 BLAKE2B 6154eb0b5ce55aefc67484dc33c8a6e36ee903bce4293045252a8c9a3b4ecfc27690c720bb46842c1bca8c14ef59fbae4d3c1f02ebd46a7c91c1c9fbd1aa1532 SHA512 fafc04aa65423ebb3db66daa9c239bdf0968722b8ac14c1206dd3f26e3960d832fd15001e320463f98ca142ec7e1d6bff73ebc0ab10c3c5d3cde241b8160fdc3
DIST snakeoil-0.10.6.tar.gz 174265 BLAKE2B e1d80bdd0eb37604f77b385e31b45a4b5437cf33ca01593b0ec091351e221dd5fea1b631d2962807fd63e5b59cbfa9d953149bf686821011bb37525156cbef79 SHA512 2534398ede5a112c493ffb59c32ad8f1eecea8992d8f97ae37d8d825a428383338820d9a70f784999690367c84eca2bd2cbdb21a73f2b426157a9a917efeb729
DIST snakeoil-0.10.7.tar.gz 174373 BLAKE2B 73a58adbb653b979b9c3f4b3cbdeef8ec5a3c8ba6262788a9694a41779660efcef724e1b318be1819dd2c2e2170d7d9e8e6bc615d0ad824cccb662527e204bfc SHA512 b84851f39565a0cfdb32e86744472426ac7502507c12e9869ab5f1eb15913ef6372a1f55465a1e6dbf3832a98bb14856004948dbc1197c454ac046423bfb15af
+DIST snakeoil-0.10.8.tar.gz 174380 BLAKE2B 96c5f4e106513ee8061c6278345ac132510202faa0e915b362170ee7de5f23f0b7bfdc671c0c07721f57eeeb90df5f6851be70d4541295029d93126ea680e50b SHA512 7088cd3fb34bc666a51ddd59b0bf6c9d9da2f04727057ffa5b74ffb188efd63153afcf45442e99b8e1611642b71cf92518dafcacb85717dfa82370df18458497
EBUILD snakeoil-0.10.5.ebuild 821 BLAKE2B 9661ad8b23f8a27cf8d7090d7f166aa0b959dd13bea73fff7c97e5718374d08d02d2c3b829a9657a117a13c8f2b1bc6a644d7e827e327cd9e00e12619b965db5 SHA512 54131fffa348484fc1b430bd16652f466bbb8b7b6956f6c2453fa3feede9bea40c09702e094dea6287a9a288a7335871a366d1ce3ae98d2e7ba5a401c83d77c0
EBUILD snakeoil-0.10.6.ebuild 821 BLAKE2B 9661ad8b23f8a27cf8d7090d7f166aa0b959dd13bea73fff7c97e5718374d08d02d2c3b829a9657a117a13c8f2b1bc6a644d7e827e327cd9e00e12619b965db5 SHA512 54131fffa348484fc1b430bd16652f466bbb8b7b6956f6c2453fa3feede9bea40c09702e094dea6287a9a288a7335871a366d1ce3ae98d2e7ba5a401c83d77c0
EBUILD snakeoil-0.10.7.ebuild 821 BLAKE2B 21079b46f66768a41e5ea3e70815a2ed360332a7396aa088276380211ac715f92ebdf5b74685c5bc777d92193fac09a7bd2990391e7bc0468c2b72a3f47317d1 SHA512 829967a92e3f6aeb560f364a8fcb7fe8db65fd15ac9056304ed01abf275e02533403a8098fa20eb4827a4a5da03616ef0a7e60ae1f13516a9da641b75daf67ee
+EBUILD snakeoil-0.10.8.ebuild 821 BLAKE2B 21079b46f66768a41e5ea3e70815a2ed360332a7396aa088276380211ac715f92ebdf5b74685c5bc777d92193fac09a7bd2990391e7bc0468c2b72a3f47317d1 SHA512 829967a92e3f6aeb560f364a8fcb7fe8db65fd15ac9056304ed01abf275e02533403a8098fa20eb4827a4a5da03616ef0a7e60ae1f13516a9da641b75daf67ee
EBUILD snakeoil-9999.ebuild 829 BLAKE2B 9e862576e4914c0907924cd9d0374bb82cbe3657135962416064814ba8a8de654fbdf9b83ef3a4538c803dccc0c1fff45e37477a7bbb8bd4ef30df320d18dee9 SHA512 578c9faa484bf4b10ae25c0eac097abfcd1243d82a2728cc2e02991b1f817e06c70ce52b3047256f67f915f9e0318423265f634feba97a45f971d964863e2ac0
MISC metadata.xml 394 BLAKE2B 1f11a6a69a1ed5736bdddaf949b97760d2986eaf848bbceafa706dae01dd8e84f2977d130179324856e35353702e8f84e2cf7b2e30587b5f21a7113237825c3e SHA512 71abd7d9037eb4412a992bcf6933999f0dfec0c39465fe5bcb63e6a8437ff901764c03ad65e363f4ce5d8789f364b7f732542c7f298f1d04a2a68343acbc2129
diff --git a/dev-python/snakeoil/snakeoil-0.10.8.ebuild b/dev-python/snakeoil/snakeoil-0.10.8.ebuild
new file mode 100644
index 000000000000..95d88af8d962
--- /dev/null
+++ b/dev-python/snakeoil/snakeoil-0.10.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/pkgcore/snakeoil.git
+ https://github.com/pkgcore/snakeoil.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
+ inherit pypi
+fi
+
+DESCRIPTION="misc common functionality and useful optimizations"
+HOMEPAGE="https://github.com/pkgcore/snakeoil"
+
+LICENSE="BSD BSD-2 MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/flit-core-3.8[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest