summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin269787 -> 269790 bytes
-rw-r--r--dev-python/pkgcraft/Manifest4
-rw-r--r--dev-python/pkgcraft/pkgcraft-0.0.9.ebuild81
-rw-r--r--dev-python/pkgcraft/pkgcraft-9999.ebuild4
4 files changed, 86 insertions, 3 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index ad20de2f4324..38ff6e42852f 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/pkgcraft/Manifest b/dev-python/pkgcraft/Manifest
index b2bab1e24319..18a718fecb3f 100644
--- a/dev-python/pkgcraft/Manifest
+++ b/dev-python/pkgcraft/Manifest
@@ -1,4 +1,6 @@
DIST pkgcraft-0.0.8.tar.gz 416513 BLAKE2B 8bf16807990344777981f21efe91fc57503f56a0f55c9be3eef9d407d09e9f3601318b7191968fa379fd31f4c9b0bee37e6af68ae792d9398735cf0298165495 SHA512 bfa049ecb003574bcb77fc7f76b58cb2ded8163888bd08ac982fefb8ec4f8cccb51a16f1e1cbffdc0da83965927fdc918983bc8b48b99b3cd43bb697aa6107dd
+DIST pkgcraft-0.0.9.tar.gz 431872 BLAKE2B 6c6ed1677c891c0e5579c7e28342876c2d7cbe03f2fcf3f8ad9f994302570d1d2398d2b4a55ec1a2fd82bbea518a4d2f76e9cabe760f0d9779b8d55170c1d940 SHA512 13988ff6822a5f9b715f3a9e8593a21d6ac530a91ca98790bd8a1c3e5958c97e440ce0610d25ed518f6d485837c9aded2ba145facf98e217325802777a33b3a7
EBUILD pkgcraft-0.0.8.ebuild 2012 BLAKE2B ae707d13af737fded4979cdea6df1c5e6cbc751577ffaf11baaa32f464cf39ec24856bf4b9771d50cf25e974b3a2815c5d6ddfc37c2c16389ef1115197cec23f SHA512 176e58b8d657d3f848152c52cfba865d462c67c5618340a54192c99b02faffbc956674da22ed770925cd8ec7e406e46deae8ff72236000195edec9ee6643412e
-EBUILD pkgcraft-9999.ebuild 2012 BLAKE2B ae707d13af737fded4979cdea6df1c5e6cbc751577ffaf11baaa32f464cf39ec24856bf4b9771d50cf25e974b3a2815c5d6ddfc37c2c16389ef1115197cec23f SHA512 176e58b8d657d3f848152c52cfba865d462c67c5618340a54192c99b02faffbc956674da22ed770925cd8ec7e406e46deae8ff72236000195edec9ee6643412e
+EBUILD pkgcraft-0.0.9.ebuild 2017 BLAKE2B b03ec93383f0dd77568d6abe350c764f5c5c1f03e146dec81194319e6a13f06baf415f0a3690d79dfa97e2c2cd9b7d8449ba2ff2dc907d244cc851e00d5b3878 SHA512 29052660a8a9bb8a7638ae3d4878975b5800b01811e4dc6605f7788a65b8f0419f8c1e3832c6dddeca43491ced60435c4d36def6fc4121efefb6711df206ecfc
+EBUILD pkgcraft-9999.ebuild 2017 BLAKE2B b03ec93383f0dd77568d6abe350c764f5c5c1f03e146dec81194319e6a13f06baf415f0a3690d79dfa97e2c2cd9b7d8449ba2ff2dc907d244cc851e00d5b3878 SHA512 29052660a8a9bb8a7638ae3d4878975b5800b01811e4dc6605f7788a65b8f0419f8c1e3832c6dddeca43491ced60435c4d36def6fc4121efefb6711df206ecfc
MISC metadata.xml 454 BLAKE2B 5085311aaebe3c2cc696fee5da4ee272e47936a4f729c2007efce94097087a987985fb972df477fb72eead3402555924ca8b8f183b69af357453ad93daeb946e SHA512 ba7457ec4b43f1664042599d4e23506e496d1f2212ea7aa02c58fd9d796915dace2817bfb1c71e6f022e9490215248e2a705b223a087d91255b97b23f82f9c23
diff --git a/dev-python/pkgcraft/pkgcraft-0.0.9.ebuild b/dev-python/pkgcraft/pkgcraft-0.0.9.ebuild
new file mode 100644
index 000000000000..b61769cf7136
--- /dev/null
+++ b/dev-python/pkgcraft/pkgcraft-0.0.9.ebuild
@@ -0,0 +1,81 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for pkgcraft"
+HOMEPAGE="
+ https://pypi.org/project/pkgcraft/
+ https://github.com/pkgcraft/pkgcraft-python/
+"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcraft/pkgcraft-python.git"
+ inherit git-r3
+
+ PKGCRAFT_VERSION_MAX="99999" # extra 9 here or 9999 isn't mergable per DEPEND below
+ PKGCRAFT_VERSION_MIN="9999"
+else
+ SRC_URI="https://github.com/pkgcraft/pkgcraft-python/releases/download/v${PV}/${P/-python}.tar.gz"
+ S="${WORKDIR}"/${P/-python}
+
+ KEYWORDS="~amd64 ~arm64"
+
+ PKGCRAFT_VERSION_MAX="9999"
+ PKGCRAFT_VERSION_MIN="0.0.14"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+examples"
+
+DEPEND="
+ <sys-libs/pkgcraft-${PKGCRAFT_VERSION_MAX}
+ >=sys-libs/pkgcraft-${PKGCRAFT_VERSION_MIN}:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-python/cython-3[${PYTHON_USEDEP}]
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ if [[ ${PV} != 9999 ]] ; then
+ local actual_pkgcraft_min=$(sed -En '/^MIN_VERSION =/{s/[^0-9.]//gp}' setup.py || die)
+ if [[ ${actual_pkgcraft_min} != ${PKGCRAFT_VERSION_MIN} ]] ; then
+ eerror "Expected minimum pkgcraft-c version: ${PKGCRAFT_VERSION_MIN}"
+ eerror "Actual minimum pkgcraft-c version: ${actual_pkgcraft_min}"
+ die "Mismatch between setup.py's MIN_VERSION and ebuild!"
+ fi
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_install() {
+ # Conditional because these aren't installed officially right now
+ # and the naming is just for convenience.
+ if use examples ; then
+ while IFS= read -r -d '' file ; do
+ python_newexe "${S}"/examples/${file##*/} pkgcraft-${file##*/}
+ done < <(find "${S}"/examples -type f -executable -print0 || die)
+ fi
+
+ distutils-r1_python_install
+}
diff --git a/dev-python/pkgcraft/pkgcraft-9999.ebuild b/dev-python/pkgcraft/pkgcraft-9999.ebuild
index 1e6dfefa9b31..b61769cf7136 100644
--- a/dev-python/pkgcraft/pkgcraft-9999.ebuild
+++ b/dev-python/pkgcraft/pkgcraft-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -28,7 +28,7 @@ else
KEYWORDS="~amd64 ~arm64"
PKGCRAFT_VERSION_MAX="9999"
- PKGCRAFT_VERSION_MIN="0.0.13"
+ PKGCRAFT_VERSION_MIN="0.0.14"
fi
LICENSE="MIT"