summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin260130 -> 260126 bytes
-rw-r--r--dev-python/ansible-pygments/Manifest3
-rw-r--r--dev-python/ansible-pygments/ansible-pygments-0.1.1-r1.ebuild (renamed from dev-python/ansible-pygments/ansible-pygments-0.1.1.ebuild)10
-rw-r--r--dev-python/ansible-pygments/files/ansible-pygments-0.1.1-tests_pygments2_14.patch75
-rw-r--r--dev-python/pytest-verbose-parametrize/Manifest2
-rw-r--r--dev-python/pytest-verbose-parametrize/pytest-verbose-parametrize-1.7.0.ebuild4
-rw-r--r--dev-python/python-xmp-toolkit/Manifest2
-rw-r--r--dev-python/python-xmp-toolkit/files/python-xmp-toolkit-2.0.1-test.patch68
-rw-r--r--dev-python/sphinx-rtd-theme/Manifest2
-rw-r--r--dev-python/sphinx-rtd-theme/sphinx-rtd-theme-1.2.0.ebuild2
-rw-r--r--dev-python/sphinx_ansible_theme/Manifest2
-rw-r--r--dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.9.1.ebuild2
-rw-r--r--dev-python/sphinxcontrib-jquery/Manifest2
-rw-r--r--dev-python/sphinxcontrib-jquery/sphinxcontrib-jquery-3.0.0.ebuild2
-rw-r--r--dev-python/stomp-py/Manifest2
-rw-r--r--dev-python/stomp-py/stomp-py-8.1.0.ebuild33
16 files changed, 193 insertions, 18 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 2718dfc2c826..bd69fb5456a8 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/ansible-pygments/Manifest b/dev-python/ansible-pygments/Manifest
index f01594308bb1..eafe6043ebcf 100644
--- a/dev-python/ansible-pygments/Manifest
+++ b/dev-python/ansible-pygments/Manifest
@@ -1,3 +1,4 @@
+AUX ansible-pygments-0.1.1-tests_pygments2_14.patch 4663 BLAKE2B f198da4ffccc4acc7d64397e9e654407cff934a8764054154775c5e5208503096270a35fb712daeb2ff0d834b9638ffaab2f3fee3bbe5d902fde48e1de53a3ea SHA512 0ced02d842fac488a37015503bb1fe163bfe842f20717374ca5b87319e5f80bee6da11b0eef7c311cd750c89248ab5a92a44f402cd0b3fcedd86d26ac9d28679
DIST ansible-pygments-0.1.1.tar.gz 8446 BLAKE2B ff631dd24c723035db7ab11a6c3fc0c90e8cebd72e6b0fa0d8b2c4bc4250ff5fb1e4180366e4ee084aab90bf24a8c3b2ecfad2c421b9f0cfdbf7675c94f0fcf7 SHA512 1ad2f4568d46d7fc617c6e674bcd9aea48e14307d91c476b51a04f778b452f18cb983d87d4872664d567b984193edee2af7964854fb2f3ae37ab4bce09c387d4
-EBUILD ansible-pygments-0.1.1.ebuild 554 BLAKE2B eff74e00f5300152e38a6e9345ce4b41440898c291cfb1772bfc4bc2a9dbbc16f4f873fbc2736b5e70199bbb216c3c602a9ddddef9b0ace712658bb7c9d322df SHA512 5ef06d73e6a9165a8e57b67c490253dcfe670ce6ba6e615bc53f0cb5362c1faf66736f8c2cc6b9c1e948002c14653a97b7cad407de531b619f2299180bc41bfc
+EBUILD ansible-pygments-0.1.1-r1.ebuild 619 BLAKE2B c578599ff8ff7e89fabecaa3a8157815789e14e25e829adc7cfc7e4318decb7353a757a9f8f08cc88f9f2df2db5d57465be95a61a612b4097cf4bf131c1fac9a SHA512 bc14dd545061fbda5a9692fc998141ba8e7fe97fc83d8155674e1d782458077bc6f68ae89d10581beef76f2389fbc7b136890bb1d8b72ad601fb3f1dc2427528
MISC metadata.xml 786 BLAKE2B 5883f03ffc7b0850bc8ecc90c91a15a9498ced9ee196a4f8d2a97a77a41957cb05a40ebf671ddbdf226886b94e9a5e796376094924712544a07559e0858aa5a8 SHA512 c7736962fe565be524294a30630e7cfd2820d1e9ace6f6dbd307ad46a252947ce368057d5ea5d20889a5ccdbb7f3418496affad5f8ed345e0e0808bd4abbe4ed
diff --git a/dev-python/ansible-pygments/ansible-pygments-0.1.1.ebuild b/dev-python/ansible-pygments/ansible-pygments-0.1.1-r1.ebuild
index 0f4d366bc7b9..245c0808deda 100644
--- a/dev-python/ansible-pygments/ansible-pygments-0.1.1.ebuild
+++ b/dev-python/ansible-pygments/ansible-pygments-0.1.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
DISTUTILS_USE_PEP517="poetry"
inherit distutils-r1
@@ -16,7 +16,11 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~riscv"
-# 2.11.0+ needed in order for tests to pass
-RDEPEND=">=dev-python/pygments-2.11.0[${PYTHON_USEDEP}]"
+# 2.14.0+ needed in order for tests to pass
+RDEPEND=">=dev-python/pygments-2.14.0[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.1.1-tests_pygments2_14.patch
+)
distutils_enable_tests pytest
diff --git a/dev-python/ansible-pygments/files/ansible-pygments-0.1.1-tests_pygments2_14.patch b/dev-python/ansible-pygments/files/ansible-pygments-0.1.1-tests_pygments2_14.patch
new file mode 100644
index 000000000000..d58a13256ac5
--- /dev/null
+++ b/dev-python/ansible-pygments/files/ansible-pygments-0.1.1-tests_pygments2_14.patch
@@ -0,0 +1,75 @@
+Backported upstream commit 0ddab3516217ac2067b6e980f5b2a6b2ac1be3fa
+
+--- a/tests/lexer_test.py
++++ b/tests/lexer_test.py
+@@ -86,41 +86,41 @@ def test_ansible_output_lexer():
+
+ <span class="k">TASK</span> <span class="p">[</span><span class="l">paused</span><span class="p">]</span> <span class="nv">************************************************************************************************************************************</span>
+ <span class="w">Sunday 11 November 2018 20:16:48 +0100 (0:00:00.041) 0:07:59.637 *******</span>
+-<span class="gd">--- before</span><span class="w"></span>
+-<span class="gi">+++ after</span><span class="w"></span>
+-<span class="gu">@@ -1,5 +1,5 @@</span><span class="w"></span>
+-<span class="w"> </span>{<span class="w"></span>
+-<span class="gd">- &quot;exists&quot;: false,</span><span class="w"></span>
+-<span class="gd">- &quot;paused&quot;: false,</span><span class="w"></span>
+-<span class="gd">- &quot;running&quot;: false</span><span class="w"></span>
+-<span class="gi">+ &quot;exists&quot;: true,</span><span class="w"></span>
+-<span class="gi">+ &quot;paused&quot;: true,</span><span class="w"></span>
+-<span class="gi">+ &quot;running&quot;: true</span><span class="w"></span>
+-<span class="w"> </span>}<span class="w"></span>
++<span class="gd">--- before</span>
++<span class="gi">+++ after</span>
++<span class="gu">@@ -1,5 +1,5 @@</span>
++<span class="w"> </span>{
++<span class="gd">- &quot;exists&quot;: false,</span>
++<span class="gd">- &quot;paused&quot;: false,</span>
++<span class="gd">- &quot;running&quot;: false</span>
++<span class="gi">+ &quot;exists&quot;: true,</span>
++<span class="gi">+ &quot;paused&quot;: true,</span>
++<span class="gi">+ &quot;running&quot;: true</span>
++<span class="w"> </span>}
+ <span class="w">\ No newline at end of file</span>
+
+ <span class="k">changed</span><span class="p">:</span> <span class="p">[</span><span class="nv">localhost</span><span class="p">]</span>
+
+ <span class="k">TASK</span> <span class="p">[</span><span class="l">volumes (more volumes)</span><span class="p">]</span> <span class="nv">********************************************************************************************************************</span>
+ <span class="w">Sunday 11 November 2018 20:19:25 +0100 (0:00:00.607) 0:10:36.974 *******</span>
+-<span class="gd">--- before</span><span class="w"></span>
+-<span class="gi">+++ after</span><span class="w"></span>
+-<span class="gu">@@ -1,11 +1,11 @@</span><span class="w"></span>
+-<span class="w"> </span>{<span class="w"></span>
+-<span class="w"> </span> &quot;expected_binds&quot;: [<span class="w"></span>
+-<span class="gd">- &quot;/tmp:/tmp:rw&quot;,</span><span class="w"></span>
+-<span class="gd">- &quot;/:/whatever:rw,z&quot;</span><span class="w"></span>
+-<span class="gi">+ &quot;/tmp:/somewhereelse:ro,Z&quot;,</span><span class="w"></span>
+-<span class="gi">+ &quot;/tmp:/tmp:rw&quot;</span><span class="w"></span>
+-<span class="w"> </span> ],<span class="w"></span>
+-<span class="w"> </span> &quot;expected_volumes&quot;: {<span class="w"></span>
+-<span class="gd">- &quot;/tmp&quot;: {},</span><span class="w"></span>
+-<span class="gd">- &quot;/whatever&quot;: {}</span><span class="w"></span>
+-<span class="gi">+ &quot;/somewhereelse&quot;: {},</span><span class="w"></span>
+-<span class="gi">+ &quot;/tmp&quot;: {}</span><span class="w"></span>
+-<span class="w"> </span> },<span class="w"></span>
+-<span class="w"> </span> &quot;running&quot;: true<span class="w"></span>
+-<span class="w"> </span>}<span class="w"></span>
++<span class="gd">--- before</span>
++<span class="gi">+++ after</span>
++<span class="gu">@@ -1,11 +1,11 @@</span>
++<span class="w"> </span>{
++<span class="w"> </span> &quot;expected_binds&quot;: [
++<span class="gd">- &quot;/tmp:/tmp:rw&quot;,</span>
++<span class="gd">- &quot;/:/whatever:rw,z&quot;</span>
++<span class="gi">+ &quot;/tmp:/somewhereelse:ro,Z&quot;,</span>
++<span class="gi">+ &quot;/tmp:/tmp:rw&quot;</span>
++<span class="w"> </span> ],
++<span class="w"> </span> &quot;expected_volumes&quot;: {
++<span class="gd">- &quot;/tmp&quot;: {},</span>
++<span class="gd">- &quot;/whatever&quot;: {}</span>
++<span class="gi">+ &quot;/somewhereelse&quot;: {},</span>
++<span class="gi">+ &quot;/tmp&quot;: {}</span>
++<span class="w"> </span> },
++<span class="w"> </span> &quot;running&quot;: true
++<span class="w"> </span>}
+ <span class="w">\ No newline at end of file</span>
+
+ <span class="k">changed</span><span class="p">:</span> <span class="p">[</span><span class="nv">localhost</span><span class="p">]</span>
diff --git a/dev-python/pytest-verbose-parametrize/Manifest b/dev-python/pytest-verbose-parametrize/Manifest
index 689e16c9e726..a616eb726b87 100644
--- a/dev-python/pytest-verbose-parametrize/Manifest
+++ b/dev-python/pytest-verbose-parametrize/Manifest
@@ -1,4 +1,4 @@
AUX pytest-verbose-parametrize-1.7.0_collections-abc.patch 205 BLAKE2B e884904bba85f2873d61d3a946ac8f8f521aab3a38814bc1d0412c37331c439e9b22d5c4dd8129422c8d1d9293352742d506f13118f2d1b2055a71c3d140742a SHA512 45318b475d70fb4e8eb9eba4c087a6a47fe30460166571d272c7cefcd7ac3ec8356cf448114ba3b58b360f22b0a7bbfcc9c349ccf091cb99e1f9aff6f0563edb
DIST pytest-verbose-parametrize-1.7.0.tar.gz 12301 BLAKE2B 908d8c9d82861783931dc25c6b522e13f252e4b04e01a2f6a0e646cd63720816242ef143041abf0aa6b67fb574d5f84d05029edd11e589728b0e5b63f92f898e SHA512 ac81cdf002d60b4af916c4beb4c832c9c39dc9dcfa3eea7385b093f9ea18391cbf968a4e908abdb23523a7cb1e294dce2017083414e61eef6762f157319e2cf4
-EBUILD pytest-verbose-parametrize-1.7.0.ebuild 1020 BLAKE2B f89b54690c156dc38a34ef8da8e07534733f59a98027dbe94d2a7669510e718b7393d1643a1caa206b6511116a32feaaf2323e64ecbe623d4e1519b782ea5fec SHA512 dd447de09ce8f1a10d8701b740214eeb1b842846f120482f1245be36feaf5bd4e5688f94e7281c93c7b3d130d483f47abb86b913ebcf1e8093c045934868d66f
+EBUILD pytest-verbose-parametrize-1.7.0.ebuild 1020 BLAKE2B 02716a3fed8c64f43e03aa7a2a5c59466810c2308afee260a9b549952f6e4ac67534bf4c5e608c273ef5c5fb816f8aa39eddd0987112b485d80d478bf02b3b87 SHA512 38fd2e0e49aa5bc1db2210019246fe8b5b96100ed7e99e09a732aece3f6716f0a77ee57ff52d943164166bb2576ad42162eefc847aabe60710f00e6502a87b6c
MISC metadata.xml 423 BLAKE2B b5a526d2a86e90e9298b3314083255abbd049f9ed168630e8cbd5fff23c7932f27b0629131b0863711fa25f8a39a7190d1deecdca99a1b1481b46d683b1338b1 SHA512 b0e5ccb327c700f7041b33bfd136fd4f360c4b862101a1440abccab51d82598e00c1435fcb1cdf47427f8c67390f30b763671ef0b76f77431645b1bfff0ed85c
diff --git a/dev-python/pytest-verbose-parametrize/pytest-verbose-parametrize-1.7.0.ebuild b/dev-python/pytest-verbose-parametrize/pytest-verbose-parametrize-1.7.0.ebuild
index 9b169a2d88d0..6fdc73564714 100644
--- a/dev-python/pytest-verbose-parametrize/pytest-verbose-parametrize-1.7.0.ebuild
+++ b/dev-python/pytest-verbose-parametrize/pytest-verbose-parametrize-1.7.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
diff --git a/dev-python/python-xmp-toolkit/Manifest b/dev-python/python-xmp-toolkit/Manifest
index 6b2f179455b7..84b2085b1fb3 100644
--- a/dev-python/python-xmp-toolkit/Manifest
+++ b/dev-python/python-xmp-toolkit/Manifest
@@ -1,4 +1,4 @@
-AUX python-xmp-toolkit-2.0.1-test.patch 397 BLAKE2B 059d415194f4544de5e4f6bfcbc2bec466b14e72e46792ac762115dd8b33bcd87ebfcdc9412695bd5b75483ac6e82024c083725ed73713c1bad100c30f22448a SHA512 f70eb11fe5b46ec0fac9a4a5c56a7a5b9dc75427b53e8159ec873a74afde23ca4bf5940b185932fc566a10f8a47d2ff8e56fa514eac1b06c94135cfa7070747b
+AUX python-xmp-toolkit-2.0.1-test.patch 2953 BLAKE2B 84794d759a96cdd2d56f9b254a4564ab1d2a6e0453c8d3130ae2f461db487875d5bc6f6989b2423f36b6cae38e578cf3afc5d1f1576534e33abdcf846c0de6f2 SHA512 903caa29a67b9332cee721882e28da7cb3f565ad97d0c75b6a1b14e8e62156a6afea370843cd2bf700d4703a1fed94a3eaa932a0ee493681190897ab80dbae6f
DIST python-xmp-toolkit-2.0.1.tar.gz 3576384 BLAKE2B cbe73d08d101d0d44c368fd1f1c6f1c8308ece5ca26f164f78312d901fb5d0387a5d2a6519d527b3625d11e338df5c366bed8a7361ac822ac887ef8be3a74948 SHA512 46f83b03574b2d742f6c6efb5b94a549068557ad6338e74fc62368c265d05f0b66a4dd36b17cd51b39f7b6cfbfb1210d54cc44c69e9a9e3da3392ee5f11de3bd
EBUILD python-xmp-toolkit-2.0.1-r2.ebuild 889 BLAKE2B 8f5651b4affbf5c1b6437763e9d23562d41d95b5285acb2a989dc9a754843a3d9ce878028d08c24479b8e914075d8f89b02bbaebb5a49367da43f94d62ab8513 SHA512 641e88b585dc4a1dc19ba0cbe2b906d7038afa947b0fabe1aa09fea9cfa2cefd0cb9680c8037dd08b16190eb7cd8fe79e2e0a82033f9b45a6f9d3899e92d2832
MISC metadata.xml 417 BLAKE2B 818d54b619c9571b00493c9c463f4e2899c187071918f9e74189d8be23b97f4cd9a8ca0313c5f26507f9e581d8e268be3fe17f03c3f409b1eb333540fb48d380 SHA512 dc5ef8f44af10a54da69fc6bbd392c4da30ecc49c829f2f8c26022e2d42da3ab0a705f31bd72f404454fe76daf1162ecb72ea1e106c93a48cdf100b59f492a91
diff --git a/dev-python/python-xmp-toolkit/files/python-xmp-toolkit-2.0.1-test.patch b/dev-python/python-xmp-toolkit/files/python-xmp-toolkit-2.0.1-test.patch
index 7679542cf535..e2adc3c05403 100644
--- a/dev-python/python-xmp-toolkit/files/python-xmp-toolkit-2.0.1-test.patch
+++ b/dev-python/python-xmp-toolkit/files/python-xmp-toolkit-2.0.1-test.patch
@@ -1,7 +1,67 @@
-diff -r -U1 python-xmp-toolkit-2.0.1.orig/test/test_exempi.py python-xmp-toolkit-2.0.1/test/test_exempi.py
---- python-xmp-toolkit-2.0.1.orig/test/test_exempi.py 2014-03-09 19:42:07.000000000 +0700
-+++ python-xmp-toolkit-2.0.1/test/test_exempi.py 2020-01-21 18:16:13.470778818 +0700
-@@ -539,2 +539,3 @@
+Squashed patches of the following:
+
+- https://github.com/exmakhina/python-xmp-toolkit/commit/3f7546173980610e0687f4eae4eb28aa026e4674
+ gentoo commit 14321e655b7b3f6e531c0a079cb131dbd767e1be
+
+- https://github.com/exmakhina/python-xmp-toolkit/commit/1459510907764746534ce41afa85a3bedd7029b9
+ test: disable tests involving BlueSquare.gif
+
+- https://github.com/exmakhina/python-xmp-toolkit/commit/bd8a0babef830e9a2c06150f6277ba0ddb1220bd
+ libxmp: exempi: exempi returns char-sized bool, not int
+
+diff --git a/libxmp/exempi.py b/libxmp/exempi.py
+index 683e240..cddc038 100644
+--- a/libxmp/exempi.py
++++ b/libxmp/exempi.py
+@@ -1693,6 +1693,7 @@ def check_error(success):
+ Return value from library function indicating success or failure.
+ """
+
++ success = success & 0xff
+ # Unfortunately the success parameter does not seem to always be reliable
+ # so we supplement it by explicitly checking the error code.
+ ecode = EXEMPI.xmp_get_error()
+diff --git a/test/common_fixtures.py b/test/common_fixtures.py
+index 135a795..363246c 100644
+--- a/test/common_fixtures.py
++++ b/test/common_fixtures.py
+@@ -44,7 +44,6 @@ samplefiles = {
+ 'BlueSquare.ai' : libxmp.consts.XMP_FT_ILLUSTRATOR,
+ 'BlueSquare.avi' : libxmp.consts.XMP_FT_AVI,
+ 'BlueSquare.eps' : libxmp.consts.XMP_FT_EPS,
+- 'BlueSquare.gif' : libxmp.consts.XMP_FT_GIF,
+ 'BlueSquare.indd' : libxmp.consts.XMP_FT_INDESIGN,
+ 'BlueSquare.jpg' : libxmp.consts.XMP_FT_JPEG,
+ 'BlueSquare.mov' : libxmp.consts.XMP_FT_MOV,
+diff --git a/test/samples.py b/test/samples.py
+index 4a97203..a7e0412 100644
+--- a/test/samples.py
++++ b/test/samples.py
+@@ -65,7 +65,6 @@ samplefiles = {
+ 'BlueSquare.ai' : libxmp.consts.XMP_FT_ILLUSTRATOR,
+ 'BlueSquare.avi' : libxmp.consts.XMP_FT_AVI,
+ 'BlueSquare.eps' : libxmp.consts.XMP_FT_EPS,
+- 'BlueSquare.gif' : libxmp.consts.XMP_FT_GIF,
+ 'BlueSquare.indd' : libxmp.consts.XMP_FT_INDESIGN,
+ 'BlueSquare.jpg' : libxmp.consts.XMP_FT_JPEG,
+ 'BlueSquare.mov' : libxmp.consts.XMP_FT_MOV,
+diff --git a/test/test_exempi.py b/test/test_exempi.py
+index 690ce15..54065e2 100644
+--- a/test/test_exempi.py
++++ b/test/test_exempi.py
+@@ -422,7 +422,6 @@ class TestExempi(unittest.TestCase):
+ """Verify that check_file_format function works as expected."""
+ pairs = { 'avi': libxmp.consts.XMP_FT_AVI,
+ 'eps': libxmp.consts.XMP_FT_EPS,
+- 'gif': libxmp.consts.XMP_FT_GIF,
+ 'indd': libxmp.consts.XMP_FT_INDESIGN,
+ 'jpg': libxmp.consts.XMP_FT_JPEG,
+ 'mov': libxmp.consts.XMP_FT_MOV,
+@@ -540,6 +539,7 @@ class TestIteration(unittest.TestCase):
+ self.assertEqual(props, ["2006, Hubert Figuiere"])
+
+ @unittest.skip("Issue x1")
def test_single_namespace_single_path_leaf_names(self):
+ """Get just leaf names from a single path, single namespace."""
+ # TODO: why?
diff --git a/dev-python/sphinx-rtd-theme/Manifest b/dev-python/sphinx-rtd-theme/Manifest
index 19a8ff630af6..629ea8810478 100644
--- a/dev-python/sphinx-rtd-theme/Manifest
+++ b/dev-python/sphinx-rtd-theme/Manifest
@@ -1,5 +1,5 @@
DIST sphinx_rtd_theme-1.1.1.tar.gz 2783043 BLAKE2B c132cc4bba5459ca29740222cc917aac0fa5afb26748b1bd3d457ed0a02e63cd973deecd9a3d509187f54ae85798cb63fdfaa293615eae278228753808fd8c50 SHA512 c3e6e3a9d25b9c48a9830e696ca5c8f0c185a0328c76032cbe6dcfb93cda7ad9a724ec4e0e2a99079db28f35aa61ef2f569b87ce98a01c47a9701a6070bc395e
DIST sphinx_rtd_theme-1.2.0.tar.gz 2784826 BLAKE2B 62d0af56a29d66831447009991a5e0fb0a483ca91ac2ef7e7ce0b19510281308b49219efd0c6e1bd8fc95c2acae233133ce2f89b7507c2b20f0f322e59ab06e0 SHA512 dd407c648c5512a79e31a106825c6f9ec4696b14d950830ab36faf912ea804b48b3a5d09c6a144e9cead773e4c057cbc809d7582deea1b253ce71b756f7f6b10
EBUILD sphinx-rtd-theme-1.1.1.ebuild 928 BLAKE2B 422df804a1618c0153013e4be2555a06a43c745674420f67a3bf4009e838c32c8888ee455e0c81350a4da9c95c348deea4da0819add8d2721ca499b8a73bab1c SHA512 edc55ca1d21b5580d9af90e0ec3a0c37bc9ba5cc404c9b7fcd68a30aa0847d3e05e666150d426bcbd23bf60245449f58370dbaaa3e2984eedfaca0311649a032
-EBUILD sphinx-rtd-theme-1.2.0.ebuild 1041 BLAKE2B d7927a9f304922a970973072af4ceb8bc15430458d872d2fc6e2e55e7a0cabd31e44f9d7783e2a7d751b82e621d386cfca1496adf49df9fb84c7ebb73ce428f2 SHA512 71d4134e7673e6d202824de221a2e843929aa64f02019d6900a985aa0db264907117b26cf93e8d8f0b0e92e16c42e53050bb465d394b6139c34c3689f34d4646
+EBUILD sphinx-rtd-theme-1.2.0.ebuild 1048 BLAKE2B a91f81339bda20b290f879c1b1780a323d31ae9c781a1f7cd15f2eec1607c41710d302e4a6f74a85e33d209c51573a7da830399040fe4624dcec1449217c604c SHA512 4ade4fd02e908c98df47279e6bcd19cfcbed992f557fdc8a02d7325c409f53768062eb5881a25492c65c22cdaacadc08a04d0578ad5ce0a016e914f836c0df2c
MISC metadata.xml 412 BLAKE2B bed5105c13db0478a4b6129d634b8028b80cfb4e7969705ed0a693286d7f1645608ba6e6066cd3219c267c097bc1bd7d1ee13531d91d8cb4fdf6a5f107ef2252 SHA512 a0e7ce66d5f68145471452e49c173aaddcb502c9ba35af543240e5fbe9b24c0bd94ecf5782d5d81c23b3e63b80cf0cab4e39d279fb635f17275702e9a56bd5bc
diff --git a/dev-python/sphinx-rtd-theme/sphinx-rtd-theme-1.2.0.ebuild b/dev-python/sphinx-rtd-theme/sphinx-rtd-theme-1.2.0.ebuild
index afd2d94b8781..160e823b6cd8 100644
--- a/dev-python/sphinx-rtd-theme/sphinx-rtd-theme-1.2.0.ebuild
+++ b/dev-python/sphinx-rtd-theme/sphinx-rtd-theme-1.2.0.ebuild
@@ -16,7 +16,7 @@ HOMEPAGE="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~x86"
RDEPEND="
dev-python/docutils[${PYTHON_USEDEP}]
diff --git a/dev-python/sphinx_ansible_theme/Manifest b/dev-python/sphinx_ansible_theme/Manifest
index 8bdb862035d5..e2a1777e72ba 100644
--- a/dev-python/sphinx_ansible_theme/Manifest
+++ b/dev-python/sphinx_ansible_theme/Manifest
@@ -1,5 +1,5 @@
DIST sphinx-ansible-theme-0.10.1.tar.gz 49575 BLAKE2B 605e153739605e85da19022ececaee8884df8d200ee5ce65a0e695e4bd4a305b5997624e18b593a3566b17c2cd9336b961280c7da6758d370a42555321a2de69 SHA512 8e5eada24f536320e3d7bb83138ebc38c1353db6b4cc0c7eaca95078ccb4d645c5e62ce83fe1ba88aa25c13999914d7d93b817eb893d47802eee9cd40cba483d
DIST sphinx-ansible-theme-0.9.1.tar.gz 34505 BLAKE2B 533e665b30f5aa450e4a2240c55c4992340b9f6ee03d27758bf119dfe2eef987fbd4b98136349af376557d8e9a78e5391a648b9886136995d05410b0c26561f2 SHA512 f78602af8affe7be59988f466cf6a2aa67e174086f338cad855369a7bbee5a76d07bcffa8406dea5a819127b26d69e29b0d90dab38b82524b3e317f9082d0379
EBUILD sphinx_ansible_theme-0.10.1.ebuild 763 BLAKE2B 6498fcf12efa46ec9f145449e0faa39b45afa20f70c8bce068428dac33fe0c0e4bc4a212428b36b6d03793b6cbcaf43ddf15543af9136e89b624a280f56f9be8 SHA512 6d714d58005ff454118907b6182125688fb5e394629492f1c505b9640680b7af854ef71da00dfec3fd1baf24670f0118da2e4a0ee6b519d7e65e610816b5b67e
-EBUILD sphinx_ansible_theme-0.9.1.ebuild 779 BLAKE2B f6b88ce69d47eea58c85a57add1ea574d96591ffebdb3e9473268a49696f4aae6d7e96addb4367912184f187cb2f14db7e4bce1e264302ffef969430f7bd7d29 SHA512 4bd1392d20848af7879c33ed98d45e4c3f89547c244357500090966d9bddc364c8723e934667567a6e7d27504a82d8de0173153f4c5fe3938b4897dbf0cd5af1
+EBUILD sphinx_ansible_theme-0.9.1.ebuild 779 BLAKE2B e150fd2ae5135fa7586fb36f94afc010349e6affae2a9115a8306c9d2327a92a393b2cb21ce63b17c0f020fa9e9faf10e95997f05b5e2f90fb45e475db9466fb SHA512 2bc98069a5a144f72381bf8a66d44ddbd39b1eecfec6b94f08120b7d8054cd7366e0392a2b11fc772eb5d16e47432c89fe5f890a4dce16a2f2dcea91046e6fb7
MISC metadata.xml 532 BLAKE2B a684e40deb310344be8b988f801674872c61052843664b13ce22e08d0c38f629a32749fbc31661fe56c997e2d8ad84d0bc689cb671d047025b8ebade6ed9b8c5 SHA512 6562c3cedeae7bf0097119c2c13dd6c6fbb230c5be33927fa101b8daf4f759c8356d2c760cb7fbc880c2b385a60aa314857d656cf02250c62232cebaf1787a15
diff --git a/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.9.1.ebuild b/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.9.1.ebuild
index d7bad106fa3f..6f4c7f906d2a 100644
--- a/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.9.1.ebuild
+++ b/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.9.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
MY_PN="${PN//_/-}"
diff --git a/dev-python/sphinxcontrib-jquery/Manifest b/dev-python/sphinxcontrib-jquery/Manifest
index 1b6e2ada6472..1fb93191539e 100644
--- a/dev-python/sphinxcontrib-jquery/Manifest
+++ b/dev-python/sphinxcontrib-jquery/Manifest
@@ -1,3 +1,3 @@
DIST jquery-3.0.0.gh.tar.gz 121750 BLAKE2B 5b160fa1434b111683824442a0ecb0da230dba7f29161495859845282e1b6471faa256be6fffc2d34c6fc97e4e188bb1247284613bf65bf322fcb77463b6cf83 SHA512 a681f42734f2925b597f8d90c7b90a3f6df9549d1c97195799670542c5eabdc4d4d4aecfef29f56bd74ffad18ab179cc47f27b8395c11388259473690601901a
-EBUILD sphinxcontrib-jquery-3.0.0.ebuild 729 BLAKE2B b41fd4f671f22c8e82f8eb25ed197efb4e0a0b37ccd06686ef1c32f2f30f5b9f83c182ca309957411e066355f3a09afd2da989a783f549174e187f891f12aa1c SHA512 7df228f102665eb86f16011a5d588bc93e88146056dcb542850ba0e5ed378e9903576e103c191af19924309f0d18581ebb23f88d9856d34d517c93286c044c14
+EBUILD sphinxcontrib-jquery-3.0.0.ebuild 736 BLAKE2B 845bdd033761d5a59eaa5df4de020ff6a25cc84690ae73474a91d9f3eb00ab851d19e1e1f406bddcb891e64a7c122bcc922719ad7e21467d7cdfb910f249f32d SHA512 ae36db4fe3e83607710907a38018092a4767f2934a555da5f9369f30616030d31b298966a0f55c8124e58826c461b8759ec26be7588a24f695a336cfb5a8f717
MISC metadata.xml 409 BLAKE2B 8710eef90c8bbe37c7e21c242608c637c26bcd7953274f5ed958cb4faa9102e03d19d57212e5bce9c59f504cf8820f1c5149569b3d766049ecccf6a758a375c9 SHA512 5fbc9e23858c95f46baf32101072b60f081243a801dcf4bbb03708cadaa4516dbfccdd81c7a5a5a17e9c78233efdaf28dcd70c0e00470f9dfa8691a0405fbae8
diff --git a/dev-python/sphinxcontrib-jquery/sphinxcontrib-jquery-3.0.0.ebuild b/dev-python/sphinxcontrib-jquery/sphinxcontrib-jquery-3.0.0.ebuild
index c58e3b8c78bd..d65d6615c392 100644
--- a/dev-python/sphinxcontrib-jquery/sphinxcontrib-jquery-3.0.0.ebuild
+++ b/dev-python/sphinxcontrib-jquery/sphinxcontrib-jquery-3.0.0.ebuild
@@ -23,7 +23,7 @@ S=${WORKDIR}/${MY_P}
# MIT for jQuery
LICENSE="0BSD MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~x86"
BDEPEND="
test? (
diff --git a/dev-python/stomp-py/Manifest b/dev-python/stomp-py/Manifest
index f129ced984ee..f4f1025152da 100644
--- a/dev-python/stomp-py/Manifest
+++ b/dev-python/stomp-py/Manifest
@@ -1,3 +1,5 @@
DIST stomp.py-8.0.1.tar.gz 35300 BLAKE2B 12209e99066fb5bb1f3015398f5eb27186322ce9d92feca46adc4d275aff1d5138908da69abe3be512325bd30a3a21773886ba5fa21917c71d13bc53b0977de4 SHA512 009189cd07c379641c9fa3b3af1df70c9e26b77bbb6d2443a78b56ff9895b4382e90a753db83f4a863fae5ef5765c660d2f82ef14ab6e74817bc83e7ea8ba6d3
+DIST stomp.py-8.1.0.tar.gz 39808 BLAKE2B c6efb19fbee81142f251c4bf4114b445878b81fa457260a306cb82ef5e9c57f0b75e3dc8cd6035676e688f1d33081cdf936ac6ccc0628819722849d60f4d8602 SHA512 7385842a23fbe6022c386489641948932e805430ce71c09079d9484fe17d02241ee705d92a1bcdf873eebcbacf68f44bbf884ea103c8963944b84758073fdac7
EBUILD stomp-py-8.0.1.ebuild 1060 BLAKE2B db1a0c5ebb663559f586be366455e0ced04006fd1e875dee24f985f739d904a4c46c60bdfd95a40df7aad245ba1ae7440274621a7fb0ad08553ae53ac668b2ae SHA512 c612d9e59cd891b8b0172e10ac0a6730e2af5e6d038f0561ab4f49ede7e1e04cb6396f3b024df37de0588959551462a9b840f2b0620bdffd8c8858bc0b82bfc6
+EBUILD stomp-py-8.1.0.ebuild 1062 BLAKE2B d59dd37b63dfafe477e2d3c8a0d1220629be64afd530680acf85a7a68e7f2af7b96d5e5955c5512e098532972abd1d2d214a07b827c11557eecca9712e6c20e0 SHA512 af5a0622c5ca21fef2531c6fa14b926439bd77f53d4c7f9075a19bff3a0b627b96f3f9c1ed929f61e66e4ef8a6e660307a0f26663bacb2ffcdf7ad4921169717
MISC metadata.xml 402 BLAKE2B 2cca58b54cd707a4c0db87e034f4e6387e9243aabe392cd0046d11b6d2074c57285798db5a81d7f3f6854a9a43436a193678d384ccde45af0552bc50b26e77ba SHA512 770aac685fa99c5e3a01bab4864d6af4c9c810ad52c4f8a2a0c32a4303f0e5e9a1573d7ad6220737e6fa4093c5a1430fb2a7765a151bcd5aa9925e059d5bed41
diff --git a/dev-python/stomp-py/stomp-py-8.1.0.ebuild b/dev-python/stomp-py/stomp-py-8.1.0.ebuild
new file mode 100644
index 000000000000..2aaf49e80681
--- /dev/null
+++ b/dev-python/stomp-py/stomp-py-8.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_PN="${PN//-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python client library for the STOMP messaging protocol"
+HOMEPAGE="https://pypi.org/project/stomp.py/ https://github.com/jasonrbriggs/stomp.py/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="<dev-python/docopt-0.7.0[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"/${MY_P}
+
+# stomp.py test suite requires quite a few appropriately configured
+# messaging servers (as of 7.0.0: RabbitMQ, ActiveMQ, ActiveMQ Artemis,
+# stompserver). Upstream relies on Docker to provide those servers, however
+# doing the same in src_test would require both granting the portage user
+# extra permissions and packaging the base image (trying to download it
+# on the fly would violate the network sandbox).
+# Side note: PyPI tarballs do not include tests.
+RESTRICT="test"