summaryrefslogtreecommitdiff
path: root/dev-python/zope-testing/zope-testing-4.7-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zope-testing/zope-testing-4.7-r1.ebuild')
-rw-r--r--dev-python/zope-testing/zope-testing-4.7-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/zope-testing/zope-testing-4.7-r1.ebuild b/dev-python/zope-testing/zope-testing-4.7-r1.ebuild
new file mode 100644
index 000000000000..0a0141ce6a97
--- /dev/null
+++ b/dev-python/zope-testing/zope-testing-4.7-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Zope testing helpers"
+HOMEPAGE="https://pypi.org/project/zope.testing/ https://github.com/zopefoundation/zope.testing"
+SRC_URI="mirror://pypi/${MY_PN::1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-python/namespace-zope[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # remove .pth files since dev-python/namespace-zope handles the ns
+ find "${D}" -name '*.pth' -delete || die
+}