summaryrefslogtreecommitdiff
path: root/dev-python/zope-i18nmessageid/zope-i18nmessageid-6.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zope-i18nmessageid/zope-i18nmessageid-6.0.1.ebuild')
-rw-r--r--dev-python/zope-i18nmessageid/zope-i18nmessageid-6.0.1.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/zope-i18nmessageid/zope-i18nmessageid-6.0.1.ebuild b/dev-python/zope-i18nmessageid/zope-i18nmessageid-6.0.1.ebuild
deleted file mode 100644
index 486a85e5fec4..000000000000
--- a/dev-python/zope-i18nmessageid/zope-i18nmessageid-6.0.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYPI_PN=${PN/-/.}
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Zope support for i18nmessageid (tagging source of i18n strings)"
-HOMEPAGE="
- https://pypi.org/project/zope.i18nmessageid/
- https://github.com/zopefoundation/zope.i18nmessageid/
-"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
-
-RDEPEND="
- !dev-python/namespace-zope
-"
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # strip rdep specific to namespaces
- sed -i -e "s:'setuptools'::" setup.py || die
- distutils-r1_src_prepare
-}
-
-python_compile() {
- distutils-r1_python_compile
- find "${BUILD_DIR}" -name '*.pth' -delete || die
-}
-
-python_test() {
- cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
- distutils_write_namespace zope
- eunittest
-}