summaryrefslogtreecommitdiff
path: root/dev-python/zope-deprecation/zope-deprecation-4.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zope-deprecation/zope-deprecation-4.2.0.ebuild')
-rw-r--r--dev-python/zope-deprecation/zope-deprecation-4.2.0.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/zope-deprecation/zope-deprecation-4.2.0.ebuild b/dev-python/zope-deprecation/zope-deprecation-4.2.0.ebuild
deleted file mode 100644
index fcdf3e8efdab..000000000000
--- a/dev-python/zope-deprecation/zope-deprecation-4.2.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 pypy3 )
-inherit distutils-r1
-
-MY_PN=${PN/-/.}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Zope Deprecation Infrastructure"
-HOMEPAGE="https://github.com/zopefoundation/zope.deprecation"
-SRC_URI="mirror://pypi/${MY_PN::1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/namespace-zope[${PYTHON_USEDEP}]"
-# note: nosetests are not actually used or enforced via test_requires
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-S=${WORKDIR}/${MY_P}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- find "${ED}" -name '*.pth' -delete || die
-}