summaryrefslogtreecommitdiff
path: root/dev-python/zope-configuration/zope-configuration-5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zope-configuration/zope-configuration-5.0.ebuild')
-rw-r--r--dev-python/zope-configuration/zope-configuration-5.0.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/zope-configuration/zope-configuration-5.0.ebuild b/dev-python/zope-configuration/zope-configuration-5.0.ebuild
deleted file mode 100644
index f3ff3f642fea..000000000000
--- a/dev-python/zope-configuration/zope-configuration-5.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYPI_PN=${PN/-/.}
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Zope Configuration Architecture"
-HOMEPAGE="
- https://pypi.org/project/zope.configuration/
- https://github.com/zopefoundation/zope.configuration/
- https://zopeconfiguration.readthedocs.io/en/latest/
-"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
-
-RDEPEND="
- dev-python/zope-i18nmessageid[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
- >=dev-python/zope-schema-4.9[${PYTHON_USEDEP}]
- !dev-python/namespace-zope
-"
-BDEPEND="
- test? (
- dev-python/manuel[${PYTHON_USEDEP}]
- dev-python/zope-testing[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # strip rdep specific to namespaces
- sed -i -e "/'setuptools'/d" setup.py || die
- distutils-r1_src_prepare
-}
-
-python_compile() {
- distutils-r1_python_compile
- find "${BUILD_DIR}" -name '*.pth' -delete || die
-}
-
-python_test() {
- cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
- distutils_write_namespace zope
- eunittest
-}