summaryrefslogtreecommitdiff
path: root/dev-python/zope-configuration/zope-configuration-4.4.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zope-configuration/zope-configuration-4.4.0-r1.ebuild')
-rw-r--r--dev-python/zope-configuration/zope-configuration-4.4.0-r1.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/zope-configuration/zope-configuration-4.4.0-r1.ebuild b/dev-python/zope-configuration/zope-configuration-4.4.0-r1.ebuild
deleted file mode 100644
index 5657afef002d..000000000000
--- a/dev-python/zope-configuration/zope-configuration-4.4.0-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-MY_PN=${PN/-/.}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Zope Configuration Architecture"
-HOMEPAGE="https://github.com/zopefoundation/zope.configuration
- https://docs.zope.org/zope.configuration/"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-
-RDEPEND="dev-python/zope-i18nmessageid[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
- >=dev-python/zope-schema-4.9[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/manuel[${PYTHON_USEDEP}]
- dev-python/zope-testing[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
-
-python_test() {
- eunittest src
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- # remove .pth files since dev-python/namespace-zope handles the ns
- find "${D}" -name '*.pth' -delete || die
-}