summaryrefslogtreecommitdiff
path: root/dev-python/zict/zict-0.1.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zict/zict-0.1.4.ebuild')
-rw-r--r--dev-python/zict/zict-0.1.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/zict/zict-0.1.4.ebuild b/dev-python/zict/zict-0.1.4.ebuild
new file mode 100644
index 000000000000..7c2c1e3d994b
--- /dev/null
+++ b/dev-python/zict/zict-0.1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mutable mapping tools"
+HOMEPAGE="https://github.com/dask/zict/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/HeapDict[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/HeapDict[${PYTHON_USEDEP}]
+ dev-python/lmdb[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test || die
+}