summaryrefslogtreecommitdiff
path: root/dev-python/zc-lockfile/zc-lockfile-2.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zc-lockfile/zc-lockfile-2.0-r1.ebuild')
-rw-r--r--dev-python/zc-lockfile/zc-lockfile-2.0-r1.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/zc-lockfile/zc-lockfile-2.0-r1.ebuild b/dev-python/zc-lockfile/zc-lockfile-2.0-r1.ebuild
deleted file mode 100644
index ea01aea3ca95..000000000000
--- a/dev-python/zc-lockfile/zc-lockfile-2.0-r1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-MY_P=${PN/-/.}-${PV}
-DESCRIPTION="Basic inter-process locks"
-HOMEPAGE="
- https://github.com/zopefoundation/zc.lockfile/
- https://pypi.org/project/zc.lockfile/
-"
-SRC_URI="mirror://pypi/${PN::1}/${PN/-/.}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv ~sparc x86"
-
-BDEPEND="
- test? (
- dev-python/zope-testing[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=( CHANGES.rst README.rst )
-
-distutils_enable_tests unittest
-
-python_prepare_all() {
- # rdep is only needed for namespace
- sed -i -e '/install_requires.*setuptools/d' setup.py || die
- # use implicit namespace
- sed -i -e '/namespace_packages/d' setup.py || die
- # do not install README into site-packages
- sed -e '/^ include_package_data/d' -i setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${EPYTHON}" -m unittest zc.lockfile.tests -v || die
-}