summaryrefslogtreecommitdiff
path: root/dev-python/ypy-websocket
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ypy-websocket')
-rw-r--r--dev-python/ypy-websocket/Manifest2
-rw-r--r--dev-python/ypy-websocket/ypy-websocket-0.9.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/ypy-websocket/Manifest b/dev-python/ypy-websocket/Manifest
index 7b5d710a2106..c20940f8b03e 100644
--- a/dev-python/ypy-websocket/Manifest
+++ b/dev-python/ypy-websocket/Manifest
@@ -1,3 +1,5 @@
DIST ypy-websocket-0.8.4.gh.tar.gz 13416 BLAKE2B 9dd988d6eceb624bae2385180c408971a776f06324407506886c2ef5b8e713277a4c4fb0a2d328a20695d4db8808997c125bfb48faa60c93fe38bb1a1e899766 SHA512 20794b182bbf3958df9f3097ab8c4657acef1ca294c751e0524bc5a36cd7b7a6a2766ae9295cd5f9fc31070813d5b56e0e1e25e22931f63171f88b4757bb1584
+DIST ypy-websocket-0.9.0.gh.tar.gz 13677 BLAKE2B 663cf37af7ddddc1bf208da05bc92fc36d866b1a1f86eb2ae1d8362b023db95b68085b5d9eb35b5f34e106f41a819249db6a3d5d102f1c6a5bf04828d2a9cfc7 SHA512 5a193285fafc206de116e087ba10f37ee6e7238968d9c3e88537e054fd8c2238f9bf55c2b2dcb5871b8af9b080caba912a3526e124c33ea3156f19621312cdb4
EBUILD ypy-websocket-0.8.4.ebuild 874 BLAKE2B 0b6e5033b6dfa0db728f8770cfc8ff8af14ccd435c6f484033b8c3be13fa79e5d94bec4f9080f04c1aafa7a3235aeb3dab3812aaa3e4ae1683e37190dc1090f3 SHA512 07b87293c9373232601e08dd744346f14d489e76f6b1f90278020a2ca65ee215af3bbd47bfff4530940c11fa6906a1ea2251ebb7430cfb5a883d25411a5db604
+EBUILD ypy-websocket-0.9.0.ebuild 1099 BLAKE2B c4f41487e2e7674ea8ed39cb5da6ddaeb271649a0e631ad736824d89e28ce43ee480105306139f84106b250f79b952439f9288e41b77187ebd87bb6dfac6a550 SHA512 5b9beea8e330231eb18be1c08a867512de43d2c06d9cca1bc26955ed4f7a9f1b195f02cd2f074d38029fa61cfc1b7d7f8e93020490d201e1d484110af92ecd61
MISC metadata.xml 414 BLAKE2B a58b2ac27d2f9e1a1d06c8fd9dcb6f9d1654fd2665d6d676a734ba228b71f6da488b835b7cb5739a6acad7102a669356e8f872bc96ce40b6ab0104699f8a7379 SHA512 533c2d5a8363cc5575d8ee08a3642f8b6fd11311fdef7d6902cc5e19fb33512ca2d9a6ecde76e909a6192a48449d612bb2b6db7b96ad1d99a89d67b06b749d76
diff --git a/dev-python/ypy-websocket/ypy-websocket-0.9.0.ebuild b/dev-python/ypy-websocket/ypy-websocket-0.9.0.ebuild
new file mode 100644
index 000000000000..f068e06e1ea7
--- /dev/null
+++ b/dev-python/ypy-websocket/ypy-websocket-0.9.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to y-crdt "
+HOMEPAGE="
+ https://pypi.org/project/ypy-websocket/
+ https://github.com/y-crdt/ypy-websocket/
+"
+SRC_URI="
+ https://github.com/y-crdt/ypy-websocket/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ <dev-python/anyio-4[${PYTHON_USEDEP}]
+ >=dev-python/anyio-3.6.1[${PYTHON_USEDEP}]
+ <dev-python/aiosqlite-1[${PYTHON_USEDEP}]
+ >=dev-python/aiosqlite-0.18.0[${PYTHON_USEDEP}]
+ <dev-python/y-py-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/y-py-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Requires internet and nodejs
+ tests/test_ypy_yjs.py
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # lower the necessary version
+ sed -i -e '/anyio/s:3.6.2:3.6.1:' pyproject.toml || die
+ distutils-r1_src_prepare
+}