summaryrefslogtreecommitdiff
path: root/dev-python/yarl/yarl-1.6.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/yarl/yarl-1.6.3.ebuild')
-rw-r--r--dev-python/yarl/yarl-1.6.3.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-python/yarl/yarl-1.6.3.ebuild b/dev-python/yarl/yarl-1.6.3.ebuild
index 451ae527610e..dd7465b90388 100644
--- a/dev-python/yarl/yarl-1.6.3.ebuild
+++ b/dev-python/yarl/yarl-1.6.3.ebuild
@@ -27,3 +27,10 @@ distutils_enable_tests pytest
PATCHES=(
"${FILESDIR}"/${PN}-1.4.2-test-without-coverage.patch
)
+
+python_test() {
+ cd tests || die
+ # broken by CPython CVE fix
+ epytest \
+ --deselect tests/test_url_query.py::test_semicolon_as_separator
+}