summaryrefslogtreecommitdiff
path: root/dev-python/yarl/yarl-1.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/yarl/yarl-1.3.0.ebuild')
-rw-r--r--dev-python/yarl/yarl-1.3.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/yarl/yarl-1.3.0.ebuild b/dev-python/yarl/yarl-1.3.0.ebuild
new file mode 100644
index 000000000000..97d08d1e295c
--- /dev/null
+++ b/dev-python/yarl/yarl-1.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Yet another URL library"
+HOMEPAGE="https://github.com/aio-libs/yarl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/multidict-4.0[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # don't use pytest-runner for tests
+ sed -i 's|"pytest-runner"||' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v tests || die "Tests fail with ${EPYTHON}"
+}