summaryrefslogtreecommitdiff
path: root/dev-python/yarl/yarl-1.2.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/yarl/yarl-1.2.6.ebuild')
-rw-r--r--dev-python/yarl/yarl-1.2.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/yarl/yarl-1.2.6.ebuild b/dev-python/yarl/yarl-1.2.6.ebuild
new file mode 100644
index 000000000000..e1c3de99fca3
--- /dev/null
+++ b/dev-python/yarl/yarl-1.2.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Yet another URL library"
+HOMEPAGE="https://github.com/aio-libs/yarl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/multidict-4.0[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py test
+}