summaryrefslogtreecommitdiff
path: root/dev-python/yarl/yarl-0.9.8-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/yarl/yarl-0.9.8-r1.ebuild')
-rw-r--r--dev-python/yarl/yarl-0.9.8-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/yarl/yarl-0.9.8-r1.ebuild b/dev-python/yarl/yarl-0.9.8-r1.ebuild
new file mode 100644
index 000000000000..cbc00b0b70d0
--- /dev/null
+++ b/dev-python/yarl/yarl-0.9.8-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Yet another URL library"
+HOMEPAGE="https://github.com/aio-libs/yarl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/multidict[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest-runner[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test || die
+}