summaryrefslogtreecommitdiff
path: root/dev-python/yara-python/yara-python-4.2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/yara-python/yara-python-4.2.3.ebuild')
-rw-r--r--dev-python/yara-python/yara-python-4.2.3.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-python/yara-python/yara-python-4.2.3.ebuild b/dev-python/yara-python/yara-python-4.2.3.ebuild
deleted file mode 100644
index 9ff3e50e376c..000000000000
--- a/dev-python/yara-python/yara-python-4.2.3.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-inherit distutils-r1
-
-DESCRIPTION="Python interface for a malware identification and classification tool"
-HOMEPAGE="https://github.com/VirusTotal/yara-python"
-SRC_URI="https://github.com/virustotal/yara-python/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc64 x86"
-
-RDEPEND="${PYTHON_DEPS}
- =app-forensics/yara-$(ver_cut 1-2)*"
-DEPEND="${RDEPEND}"
-
-distutils_enable_tests unittest
-
-python_configure_all() {
- cat >> setup.cfg <<-EOF
- [build_ext]
- dynamic-linking = True
- EOF
-}
-
-python_test() {
- "${EPYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
-}