summaryrefslogtreecommitdiff
path: root/dev-python/xxhash/xxhash-3.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xxhash/xxhash-3.2.0.ebuild')
-rw-r--r--dev-python/xxhash/xxhash-3.2.0.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/xxhash/xxhash-3.2.0.ebuild b/dev-python/xxhash/xxhash-3.2.0.ebuild
deleted file mode 100644
index f17d2e60c0cd..000000000000
--- a/dev-python/xxhash/xxhash-3.2.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python binding for the xxHash library"
-HOMEPAGE="
- https://github.com/ifduyue/python-xxhash/
- https://pypi.org/project/xxhash/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~x86"
-
-DEPEND="
- >=dev-libs/xxhash-0.8.0
-"
-RDEPEND="
- ${DEPEND}
-"
-
-distutils_enable_tests unittest
-
-python_configure_all() {
- export XXHASH_LINK_SO=1
-}
-
-python_test() {
- cd tests || die
- eunittest
-}