summaryrefslogtreecommitdiff
path: root/dev-python/xxhash/xxhash-2.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xxhash/xxhash-2.0.0.ebuild')
-rw-r--r--dev-python/xxhash/xxhash-2.0.0.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/dev-python/xxhash/xxhash-2.0.0.ebuild b/dev-python/xxhash/xxhash-2.0.0.ebuild
deleted file mode 100644
index a27b42c102fa..000000000000
--- a/dev-python/xxhash/xxhash-2.0.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python binding for the xxHash library"
-HOMEPAGE="https://github.com/ifduyue/python-xxhash
- https://pypi.org/project/xxhash/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-LICENSE="MIT"
-
-KEYWORDS="~amd64"
-SLOT="0"
-
-RDEPEND=">=dev-libs/xxhash-0.8.0"
-BDEPEND="${RDEPEND}"
-
-distutils_enable_tests unittest
-
-python_configure_all() {
- export XXHASH_LINK_SO=1
-}
-
-python_test() {
- cd tests || die
- "${EPYTHON}" -m unittest discover -v || die "tests failed with ${EPYTHON}"
-}