summaryrefslogtreecommitdiff
path: root/dev-python/xlrd/xlrd-0.9.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xlrd/xlrd-0.9.4.ebuild')
-rw-r--r--dev-python/xlrd/xlrd-0.9.4.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/xlrd/xlrd-0.9.4.ebuild b/dev-python/xlrd/xlrd-0.9.4.ebuild
deleted file mode 100644
index ec0657e68011..000000000000
--- a/dev-python/xlrd/xlrd-0.9.4.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for developers to extract data from Microsoft Excel (tm) spreadsheet files"
-HOMEPAGE="
- http://www.python-excel.org/
- https://github.com/python-excel/xlrd/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~ppc-aix ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
-IUSE=""
-
-PATCHES=( "${FILESDIR}"/${PN}-0.9.3-column.patch )
-
-python_prepare_all() {
- # Remove this if examples get reintroduced
- sed -i -e "s/test_names_demo/_&/" tests/test_open_workbook.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${PYTHON}" -m unittest discover || die "Test failed with ${EPYTHON}"
-}