summaryrefslogtreecommitdiff
path: root/dev-python/xkbcommon
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xkbcommon')
-rw-r--r--dev-python/xkbcommon/Manifest4
-rw-r--r--dev-python/xkbcommon/xkbcommon-1.5.1.ebuild (renamed from dev-python/xkbcommon/xkbcommon-1.0.ebuild)9
2 files changed, 4 insertions, 9 deletions
diff --git a/dev-python/xkbcommon/Manifest b/dev-python/xkbcommon/Manifest
index 41a1f9837f23..850d0bc752e6 100644
--- a/dev-python/xkbcommon/Manifest
+++ b/dev-python/xkbcommon/Manifest
@@ -1,3 +1,3 @@
-DIST python-xkbcommon-1.0.gh.tar.gz 27258 BLAKE2B 3106877f8e87f50453a358eec4e6431642b00a6a2bc23d3088ef22379984869ec84cd042a1ac53dd72783f3005dad1efddf3f87410204b88bfde4f9da0044c97 SHA512 c7793d6f5517771006ff5a9c01deb9a37717157d7171af49ff459dc96b3b16a1d2d4c0f1272b5a8f683390de1e8e6a6ff92472f18828c7e38e0f2a1ee6f34f07
-EBUILD xkbcommon-1.0.ebuild 856 BLAKE2B 80e0c98d0cc44b04dad46821a87a47628efe395c8feacaa70549b5625b4d351e5766a5990db9939fb1b1568d9054adcca90a5680c38f6c9fe3dff80f5297c894 SHA512 27406451b5ae1916ad02c7f1dba080da62e07281048bfd9634c408574c3258b22b200a3a656f3739a0724c4b4e523d03265f37585290ede28f34bc71d61f3e87
+DIST xkbcommon-1.5.1.tar.gz 80170 BLAKE2B 8dec8c632d1d3c5d4f47992feea7431e21a9bb6477cbb35039003606ad6c52136255e89373bfe663cfaeb5d7b575ca0504af05568d56dcf99c53f509cf636408 SHA512 0fe7fa5760a77f9652e1985d16bf9ef0f6a95f96a196a032f4d7639bca5da644e0439f81ff76b02a06a2e2448277d86ed798de72cbfadeb2369ffaf2d322cb65
+EBUILD xkbcommon-1.5.1.ebuild 743 BLAKE2B 930fff638f4b199ed70c4d5003a9e0bcd93548324836fcadd046bb0339541ddf0053a66cb3238b5a2cb2fbebfb184361e03a7506faf116c664a9c3bac2882ea2 SHA512 d44e5a5c958dfc3d7a477002d0b7372fbf23cec809d8b691be505cd4ef969274dcacdae720645335803de3578554f4405d9ab438037371481f5401a6c60974ea
MISC metadata.xml 355 BLAKE2B fef5c9392775c817ce5754bc6c70a30048e0aa252593229667b515d27421e95377f2199c121f43b112ef957a4172440417221fecf30ce9d068b23278bc2e2e4a SHA512 21fd7e00d1b727d6b281977fa4659c620259577dc346213437af17742ee4ceff367e0ccd45c8bb03f15afe6c0a1c885e1b3f9ebbd47b50518ec2953580b17df4
diff --git a/dev-python/xkbcommon/xkbcommon-1.0.ebuild b/dev-python/xkbcommon/xkbcommon-1.5.1.ebuild
index 93848742bb21..68cfe64014bf 100644
--- a/dev-python/xkbcommon/xkbcommon-1.0.ebuild
+++ b/dev-python/xkbcommon/xkbcommon-1.5.1.ebuild
@@ -7,19 +7,13 @@ DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..13} pypy3 )
-inherit distutils-r1
+inherit distutils-r1 pypi
-MY_P=python-xkbcommon-${PV}
DESCRIPTION="Python bindings for libxkbcommon using cffi"
HOMEPAGE="
https://github.com/sde1000/python-xkbcommon/
https://pypi.org/project/xkbcommon/
"
-SRC_URI="
- https://github.com/sde1000/python-xkbcommon/archive/refs/tags/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
LICENSE="MIT"
SLOT="0"
@@ -39,5 +33,6 @@ distutils_enable_tests pytest
python_test() {
rm -rf xkbcommon || die
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest
}