summaryrefslogtreecommitdiff
path: root/dev-python/xdoctest/xdoctest-1.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xdoctest/xdoctest-1.1.0.ebuild')
-rw-r--r--dev-python/xdoctest/xdoctest-1.1.0.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/xdoctest/xdoctest-1.1.0.ebuild b/dev-python/xdoctest/xdoctest-1.1.0.ebuild
deleted file mode 100644
index 8b1835fb1658..000000000000
--- a/dev-python/xdoctest/xdoctest-1.1.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="A rewrite of Python's builtin doctest module but without all the weirdness"
-HOMEPAGE="https://github.com/Erotemic/xdoctest/"
-SRC_URI="
- https://github.com/Erotemic/xdoctest/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
-"
-# dev-python/nbformat-5.1.{0..2} did not install package data
-BDEPEND="
- test? (
- >=dev-python/nbformat-5.1.2-r1[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-#distutils_enable_sphinx docs/source \
-# dev-python/autoapi \
-# dev-python/sphinx-rtd-theme
-
-EPYTEST_DESELECT=(
- tests/test_pytest_cli.py::test_simple_pytest_import_error_cli
-)
-
-python_test() {
- epytest --pyargs tests xdoctest
-}