summaryrefslogtreecommitdiff
path: root/dev-python/xcffib/xcffib-1.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xcffib/xcffib-1.5.0.ebuild')
-rw-r--r--dev-python/xcffib/xcffib-1.5.0.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-python/xcffib/xcffib-1.5.0.ebuild b/dev-python/xcffib/xcffib-1.5.0.ebuild
index fbb6ddf9f2de..680167b6ad2a 100644
--- a/dev-python/xcffib/xcffib-1.5.0.ebuild
+++ b/dev-python/xcffib/xcffib-1.5.0.ebuild
@@ -36,6 +36,14 @@ BDEPEND="
distutils_enable_tests pytest
+src_prepare() {
+ # remove invalid cffi dependency
+ # https://github.com/tych0/xcffib/pull/167
+ sed -i -e '/dependencies/d' setup.py || die
+
+ distutils-r1_src_prepare
+}
+
python_test() {
rm -rf xcffib || die
epytest