summaryrefslogtreecommitdiff
path: root/dev-python/xarray
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xarray')
-rw-r--r--dev-python/xarray/Manifest4
-rw-r--r--dev-python/xarray/xarray-2024.5.0.ebuild85
-rw-r--r--dev-python/xarray/xarray-2024.6.0.ebuild2
3 files changed, 2 insertions, 89 deletions
diff --git a/dev-python/xarray/Manifest b/dev-python/xarray/Manifest
index a387dc146dce..56ef0a476026 100644
--- a/dev-python/xarray/Manifest
+++ b/dev-python/xarray/Manifest
@@ -1,5 +1,3 @@
-DIST xarray-2024.5.0.tar.gz 3710689 BLAKE2B 04d2d9c70c90bccd0f269dde91be8a3f213b2dfe2d380b041abe946d118e80d0816ef09ed7e225b7bb164902c1943c1be335f1cac815d12c4aace6a0217379bb SHA512 d3aa6ef73afd2fd8a5c5551631ca5385d14221474bdab4c404cee1405b370c2f998c895bfd3506e6ccc1b2f511996b0eebefb331768df047d5e8b398ad2f9199
DIST xarray-2024.6.0.tar.gz 3715179 BLAKE2B 42fa46883d27f656dca9b82e1647bd94a62a427582cd52d847131a8e01caf77a597fcc128453fee1f68c38897a9f995dd4c644e9b68b551ee1c28bc0d48e9465 SHA512 b6f24f834d71cca84f6a485858571a17bcb250915d4f84c886c9e16fc240ae3c3e91d573726e8a09f1dbe269abbfae97498868476eef1a90813ddb29c6a6db62
-EBUILD xarray-2024.5.0.ebuild 3037 BLAKE2B a51b24716ae5f767f354374b85b56cc7cbcd7e5304bd2b2700945ade90b21ecb071533e87c69790eeb3d6ec4b0cbf8f3289ecc380fba7c2ad9707847964a9db4 SHA512 1cd5c6d0a0280a97725972d5d37029226a6a5b5aa59e95e59abc00e74c7590f801b9e13eedce1a794cf619156d9c203220391400b9f18949274eda904ef15f4f
-EBUILD xarray-2024.6.0.ebuild 3445 BLAKE2B 873d29c2b5bab5332c70bbaa9f3d1217014704c4edc069d5834719309fe941ec1f7829812871065e1ba89d2cbe12715d82d0b17532f9f90152dbd8146ef9db1e SHA512 42173534f2ad500a563b2a4a656432b89b0bcc172c475cb4e729f8af316db30a4f63e18562c44bc7a951efbbd6eec2f3b3e575c25746ca7b458019ab899ed1a2
+EBUILD xarray-2024.6.0.ebuild 3442 BLAKE2B 409d5dc1839b146c371da158a7a59fd407a73b3cf0c9c6a99658cb0233f287af1e7cdbcee9ba482b0770049721b6b76d61867f0e0aa59c082e2c38489522d1b7 SHA512 fe20674a054f9dbf83c22e95343c81ff0b84ea019657d1dc630726fe1c2776e5cf41923475f195030da5a865dc076fcad1e7ca96d6bc52a29fa17d0a608d20b7
MISC metadata.xml 509 BLAKE2B d470cc092eb055215a5868c22f9ec458057cfad600357fa1f658ed4537a6a6f68bda1422c4a665f1963ce0a6049e691befc3ca4baa60cc898364ad5f18164979 SHA512 602755896a3655295058afc8543a4bb64192d5c625f2edd86291c1f23d171f051a4238466163c2d469874aff3e68770fc76177e720870492266fb14e6faf6ce7
diff --git a/dev-python/xarray/xarray-2024.5.0.ebuild b/dev-python/xarray/xarray-2024.5.0.ebuild
deleted file mode 100644
index 67e63004b7d8..000000000000
--- a/dev-python/xarray/xarray-2024.5.0.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="N-D labeled arrays and datasets in Python"
-HOMEPAGE="
- https://xarray.pydata.org/
- https://github.com/pydata/xarray/
- https://pypi.org/project/xarray/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~loong ~riscv x86"
-IUSE="big-endian"
-
-RDEPEND="
- <dev-python/numpy-2[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.23[${PYTHON_USEDEP}]
- >=dev-python/pandas-2.0[${PYTHON_USEDEP}]
- >=dev-python/packaging-23.1[${PYTHON_USEDEP}]
-"
-# note: most of the test dependencies are optional
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/bottleneck[${PYTHON_USEDEP}]
- dev-python/cftime[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/toolz[${PYTHON_USEDEP}]
- !hppa? ( >=dev-python/scipy-1.4[${PYTHON_USEDEP}] )
- )
-"
-
-EPYTEST_XDIST=1
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=()
- if ! has_version ">=dev-python/scipy-1.4[${PYTHON_USEDEP}]" ; then
- EPYTEST_DESELECT+=(
- 'xarray/tests/test_missing.py::test_interpolate_na_2d[coords1]'
- )
-
- if ! has_version "dev-python/scipy[${PYTHON_USEDEP}]" ; then
- EPYTEST_DESELECT+=(
- xarray/tests/test_calendar_ops.py::test_interp_calendar
- )
- fi
- fi
-
- if use big-endian ; then
- EPYTEST_DESELECT+=(
- # Appears to be a numpy issue in display? See bug #916460.
- 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1677-09-21T00:12:43.145224193-ns-int64-20-True]'
- 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1970-09-21T00:12:44.145224808-ns-float64-1e+30-True]'
- 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1677-09-21T00:12:43.145225216-ns-float64--9.223372036854776e+18-True]'
- 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1677-09-21T00:12:43.145224193-ns-int64-None-False]'
- 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1677-09-21T00:12:43.145225-us-int64-None-False]'
- 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1970-01-01T00:00:01.000001-us-int64-None-False]'
- 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1677-09-21T00:21:52.901038080-ns-float32-20.0-True]'
- )
- fi
-
- if [[ ${ABI} != *64* ]]; then
- EPYTEST_DESELECT+=(
- # these tests hardcode object sizes for 64-bit arches
- # https://github.com/pydata/xarray/issues/9127
- xarray/tests/test_dataarray.py::TestDataArray::test_repr_multiindex
- xarray/tests/test_dataarray.py::TestDataArray::test_repr_multiindex_long
- xarray/tests/test_dataset.py::TestDataset::test_repr_multiindex
- xarray/tests/test_formatting.py::test_array_repr_dtypes_unix
- )
- fi
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
diff --git a/dev-python/xarray/xarray-2024.6.0.ebuild b/dev-python/xarray/xarray-2024.6.0.ebuild
index 94e04ad80a78..4f9911e2079c 100644
--- a/dev-python/xarray/xarray-2024.6.0.ebuild
+++ b/dev-python/xarray/xarray-2024.6.0.ebuild
@@ -17,7 +17,7 @@ HOMEPAGE="
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+KEYWORDS="amd64 arm64 ~loong ~riscv x86"
IUSE="big-endian"
RDEPEND="