summaryrefslogtreecommitdiff
path: root/dev-python/xarray/xarray-0.12.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xarray/xarray-0.12.1.ebuild')
-rw-r--r--dev-python/xarray/xarray-0.12.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/xarray/xarray-0.12.1.ebuild b/dev-python/xarray/xarray-0.12.1.ebuild
new file mode 100644
index 000000000000..c6f3b7e7c290
--- /dev/null
+++ b/dev-python/xarray/xarray-0.12.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="N-D labeled arrays and datasets in Python"
+HOMEPAGE="http://xarray.pydata.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/numpy-1.14[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.19.2[${PYTHON_USEDEP}]"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/dask-0.18.2[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-1.1[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.10.8-skip-broken-test.patch"
+)
+
+python_test() {
+ pytest -v || die
+}