summaryrefslogtreecommitdiff
path: root/dev-python/wxpython/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/wxpython/files')
-rw-r--r--dev-python/wxpython/files/wxpython-2.8-no-preservatives-added.patch16
-rw-r--r--dev-python/wxpython/files/wxpython-2.8.11-drop-editra.patch48
-rw-r--r--dev-python/wxpython/files/wxpython-2.8.12.1-disable-egging-mode.patch34
-rw-r--r--dev-python/wxpython/files/wxpython-3.0-wxversion-demo.patch10
-rw-r--r--dev-python/wxpython/files/wxpython-3.0.0.0-wxversion-scripts.patch211
5 files changed, 0 insertions, 319 deletions
diff --git a/dev-python/wxpython/files/wxpython-2.8-no-preservatives-added.patch b/dev-python/wxpython/files/wxpython-2.8-no-preservatives-added.patch
deleted file mode 100644
index 5e4221d51506..000000000000
--- a/dev-python/wxpython/files/wxpython-2.8-no-preservatives-added.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Portage preserve-libs removes the linker name (.so) of a library but leaves
-the soname (.so.4) and realname (.so.4.0) installed. findLib searches for
-mywxlibname.* and returns true if anything is found. Disaster ensues.
-
-
---- a/wxPython/config.py
-+++ b/wxPython/config.py
-@@ -612,7 +612,7 @@ def findLib(name, libdirs):
- dirs = libdirs[:]
- for d in dirs:
- p = os.path.join(d, name)
-- if glob.glob(p+'*') != []:
-+ if glob.glob(p+'*.so') != []:
- return True
- return False
-
diff --git a/dev-python/wxpython/files/wxpython-2.8.11-drop-editra.patch b/dev-python/wxpython/files/wxpython-2.8.11-drop-editra.patch
deleted file mode 100644
index 9555bb57ef44..000000000000
--- a/dev-python/wxpython/files/wxpython-2.8.11-drop-editra.patch
+++ /dev/null
@@ -1,48 +0,0 @@
---- a/wxPython/setup.py
-+++ b/wxPython/setup.py
-@@ -887,13 +887,6 @@ WX_PKGLIST = [ 'wx',
- 'wx.tools',
- 'wx.tools.XRCed',
- 'wx.tools.XRCed.plugins',
-- 'wx.tools.Editra',
-- 'wx.tools.Editra.src',
-- 'wx.tools.Editra.src.autocomp',
-- 'wx.tools.Editra.src.eclib',
-- 'wx.tools.Editra.src.ebmlib',
-- 'wx.tools.Editra.src.extern',
-- 'wx.tools.Editra.src.syntax',
- ]
-
- if not EGGing:
-@@ -920,7 +913,6 @@ else:
- opj('scripts/pywrap'),
- opj('scripts/pywxrc'),
- opj('scripts/xrced'),
-- opj('scripts/editra'),
- ]
- if os.name == 'nt':
- SCRIPTS.append( opj('scripts/genaxmodule') )
-@@ -934,15 +926,6 @@ DATA_FILES += find_data_files('wx/tools/XRCed', '*.txt', '*.xrc', '*.htb')
- DATA_FILES += find_data_files('wx/tools/XRCed/plugins', '*.crx')
- DATA_FILES += find_data_files('wx/tools/XRCed/plugins/bitmaps', '*.png')
-
--DATA_FILES += find_data_files('wx/tools/Editra/docs', '*.txt')
--DATA_FILES += find_data_files('wx/tools/Editra/locale', '*.mo')
--DATA_FILES += find_data_files('wx/tools/Editra/pixmaps',
-- '*.png', '*.icns', '*.ico', 'README', 'AUTHORS', 'COPYING')
--DATA_FILES += find_data_files('wx/tools/Editra/plugins', '*.egg')
--DATA_FILES += find_data_files('wx/tools/Editra/src', 'README')
--DATA_FILES += find_data_files('wx/tools/Editra/styles', '*.ess')
--DATA_FILES += find_data_files('wx/tools/Editra/tests/syntax', '*')
--DATA_FILES += find_data_files('wx/tools/Editra', '[A-Z]*', recursive=False)
-
-
- ## import pprint
-@@ -993,7 +976,6 @@ if EGGing:
- 'pyshell = wx.py.PyShell:main',
- 'pywrap = wx.py.PyWrap:main',
- 'helpviewer = wx.tools.helpviewer:main',
-- 'editra = wx.tools.Editra.launcher:main',
- 'xrced = wx.tools.XRCed.xrced:main',
- ],
- },
diff --git a/dev-python/wxpython/files/wxpython-2.8.12.1-disable-egging-mode.patch b/dev-python/wxpython/files/wxpython-2.8.12.1-disable-egging-mode.patch
deleted file mode 100644
index 1497a2c70761..000000000000
--- a/dev-python/wxpython/files/wxpython-2.8.12.1-disable-egging-mode.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From c4072ed7bc923039e544319f52d0761b7a4600a4 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Mon, 22 Apr 2013 18:02:37 +0200
-Subject: [PATCH] Trigger 'EGGing' mode only by 'bdist_egg' and not 'egg_info'.
-
-We use the 'egg_info' command to explicitly enforce temporary EGG file
-location outside the source tree on Gentoo. As a result, our build
-command activates the 'EGGing' mode and wxPython is not installed
-properly.
-
-I believe that the 'EGGing' mode should be activated only by an explicit
-call to 'bdist_egg' command where the expected files are actually
-created. The 'egg_info' command is a more broad one and is often used
-implicitly, e.g. by the 'install' command.
----
- config.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/config.py b/config.py
-index 4fbd83f..b45707d 100644
---- a/config.py
-+++ b/config.py
-@@ -23,7 +23,7 @@
- import sys, os, glob, fnmatch, tempfile
- import subprocess
-
--EGGing = 'bdist_egg' in sys.argv or 'egg_info' in sys.argv
-+EGGing = 'bdist_egg' in sys.argv
- if not EGGing:
- from distutils.core import setup, Extension
- else:
---
-1.8.1.5
-
diff --git a/dev-python/wxpython/files/wxpython-3.0-wxversion-demo.patch b/dev-python/wxpython/files/wxpython-3.0-wxversion-demo.patch
deleted file mode 100644
index a4f6b0b07a3c..000000000000
--- a/dev-python/wxpython/files/wxpython-3.0-wxversion-demo.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- demo/demo.org
-+++ demo/demo.py
-@@ -1,4 +1,7 @@
- #!/usr/bin/env python
-
-+import wxversion
-+wxversion.select("3.0")
-+
- import Main
- Main.main()
diff --git a/dev-python/wxpython/files/wxpython-3.0.0.0-wxversion-scripts.patch b/dev-python/wxpython/files/wxpython-3.0.0.0-wxversion-scripts.patch
deleted file mode 100644
index 9f0cb8922267..000000000000
--- a/dev-python/wxpython/files/wxpython-3.0.0.0-wxversion-scripts.patch
+++ /dev/null
@@ -1,211 +0,0 @@
---- a/distrib/PyAlaMode.desktop
-+++ b/distrib/PyAlaMode.desktop
-@@ -1,8 +1,8 @@
- [Desktop Entry]
--Name=PyAlaMode
-+Name=PyAlaMode (3.0)
- Comment=GUI Python Shell with Filling and editor windows
--Exec=pyalamode
--Icon=PyCrust
-+Exec=pyalamode-3.0
-+Icon=PyCrust-3.0
- Terminal=false
- Type=Application
- Categories=Development;
---- a/distrib/PyCrust.desktop
-+++ b/distrib/PyCrust.desktop
-@@ -1,8 +1,8 @@
- [Desktop Entry]
--Name=PyCrust
-+Name=PyCrust (3.0)
- Comment=GUI Python Shell with Filling
--Exec=pycrust
--Icon=PyCrust
-+Exec=pycrust-3.0
-+Icon=PyCrust-3.0
- Terminal=false
- Type=Application
- Categories=Development;
---- a/distrib/PyShell.desktop
-+++ b/distrib/PyShell.desktop
-@@ -1,8 +1,8 @@
- [Desktop Entry]
--Name=PyShell
-+Name=PyShell (3.0)
- Comment=GUI Python Shell
--Exec=pyshell
--Icon=PyCrust
-+Exec=pyshell-3.0
-+Icon=PyCrust-3.0
- Terminal=false
- Type=Application
- Categories=Development;
---- a/distrib/PySlices.desktop
-+++ b/distrib/PySlices.desktop
-@@ -1,8 +1,8 @@
- [Desktop Entry]
--Name=PySlices
-+Name=PySlices (3.0)
- Comment=GUI Python Shell with Filling
--Exec=pyslices
--Icon=PySlices
-+Exec=pyslices-3.0
-+Icon=PySlices-3.0
- Terminal=false
- Type=Application
- Categories=Development;
---- a/distrib/PySlicesShell.desktop
-+++ b/distrib/PySlicesShell.desktop
-@@ -1,9 +1,8 @@
--
- [Desktop Entry]
--Name=PySlicesShell
-+Name=PySlicesShell (3.0)
- Comment=GUI Python Shell
--Exec=pysliceshell
--Icon=PySlices
-+Exec=pysliceshell-3.0
-+Icon=PySlices-3.0
- Terminal=false
- Type=Application
- Categories=Development;
---- a/distrib/XRCed.desktop
-+++ b/distrib/XRCed.desktop
-@@ -1,8 +1,8 @@
- [Desktop Entry]
--Name=XRCed
-+Name=XRCed (3.0)
- Comment=wxPython XRC resource editor
--Exec=xrced
--Icon=XRCed
-+Exec=xrced-3.0
-+Icon=XRCed-3.0
- Terminal=false
- Type=Application
- Categories=Development;
---- a/scripts/genaxmodule
-+++ b/scripts/genaxmodule
-@@ -1,4 +1,6 @@
- #!/usr/bin/env python
-+import wxversion
-+wxversion.select("3.0")
-
- from wx.tools.genaxmodule import main
- main()
---- a/scripts/helpviewer
-+++ b/scripts/helpviewer
-@@ -1,4 +1,6 @@
- #!/usr/bin/env python
-+import wxversion
-+wxversion.select("3.0")
-
- from wx.tools.helpviewer import main
- main()
---- a/scripts/img2png
-+++ b/scripts/img2png
-@@ -1,4 +1,6 @@
- #!/usr/bin/env python
-+import wxversion
-+wxversion.select("3.0")
-
- from wx.tools.img2png import main
- main()
---- a/scripts/img2py
-+++ b/scripts/img2py
-@@ -1,4 +1,6 @@
- #!/usr/bin/env python
-+import wxversion
-+wxversion.select("3.0")
-
- from wx.tools.img2py import main
- main()
---- a/scripts/img2xpm
-+++ b/scripts/img2xpm
-@@ -1,4 +1,6 @@
- #!/usr/bin/env python
-+import wxversion
-+wxversion.select("3.0")
-
- from wx.tools.img2xpm import main
- main()
---- a/scripts/pyalacarte
-+++ b/scripts/pyalacarte
-@@ -1,4 +1,6 @@
- #!/usr/bin/env python
-+import wxversion
-+wxversion.select("3.0")
-
- from wx.py.PyAlaCarte import main
- main()
---- a/scripts/pyalamode
-+++ b/scripts/pyalamode
-@@ -1,4 +1,6 @@
- #!/usr/bin/env python
-+import wxversion
-+wxversion.select("3.0")
-
- from wx.py.PyAlaMode import main
- main()
---- a/scripts/pycrust
-+++ b/scripts/pycrust
-@@ -1,4 +1,6 @@
- #!/usr/bin/env python
-+import wxversion
-+wxversion.select("3.0")
-
- from wx.py.PyCrust import main
- main()
---- a/scripts/pyshell
-+++ b/scripts/pyshell
-@@ -1,4 +1,6 @@
- #!/usr/bin/env python
-+import wxversion
-+wxversion.select("3.0")
-
- from wx.py.PyShell import main
- main()
---- a/scripts/pyslices
-+++ b/scripts/pyslices
-@@ -1,4 +1,6 @@
- #!/usr/bin/env python
-+import wxversion
-+wxversion.select("3.0")
-
- from wx.py.PySlices import main
- main()
---- a/scripts/pysliceshell
-+++ b/scripts/pysliceshell
-@@ -1,4 +1,6 @@
- #!/usr/bin/env python
-+import wxversion
-+wxversion.select("3.0")
-
- from wx.py.PySlicesShell import main
- main()
---- a/scripts/pywrap
-+++ b/scripts/pywrap
-@@ -1,4 +1,6 @@
- #!/usr/bin/env python
-+import wxversion
-+wxversion.select("3.0")
-
- from wx.py.PyWrap import main
- main()
---- a/scripts/pywxrc
-+++ b/scripts/pywxrc
-@@ -1,4 +1,6 @@
- #!/usr/bin/env python
-+import wxversion
-+wxversion.select("3.0")
-
- from wx.tools.pywxrc import main
- main()
---- a/scripts/xrced
-+++ b/scripts/xrced
-@@ -1,4 +1,6 @@
- #!/usr/bin/env python
-+import wxversion
-+wxversion.select("3.0")
-
- from wx.tools.XRCed.xrced import main
- main()