summaryrefslogtreecommitdiff
path: root/dev-python/www-authenticate/www-authenticate-0.9.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/www-authenticate/www-authenticate-0.9.2.ebuild')
-rw-r--r--dev-python/www-authenticate/www-authenticate-0.9.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/www-authenticate/www-authenticate-0.9.2.ebuild b/dev-python/www-authenticate/www-authenticate-0.9.2.ebuild
new file mode 100644
index 000000000000..95e755f95e81
--- /dev/null
+++ b/dev-python/www-authenticate/www-authenticate-0.9.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="WWW-Authenticate header parser"
+HOMEPAGE="https://github.com/alexsdutton/www-authenticate"
+SRC_URI="https://github.com/alexsdutton/www-authenticate/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests tests.py || die
+}