summaryrefslogtreecommitdiff
path: root/dev-python/whoosh
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/whoosh')
-rw-r--r--dev-python/whoosh/Manifest4
-rw-r--r--dev-python/whoosh/metadata.xml1
-rw-r--r--dev-python/whoosh/whoosh-2.7.4-r2.ebuild (renamed from dev-python/whoosh/whoosh-2.7.4-r1.ebuild)6
3 files changed, 6 insertions, 5 deletions
diff --git a/dev-python/whoosh/Manifest b/dev-python/whoosh/Manifest
index 65443922813b..3b9060e96f76 100644
--- a/dev-python/whoosh/Manifest
+++ b/dev-python/whoosh/Manifest
@@ -1,4 +1,4 @@
AUX whoosh-2.7.4-tests-specify-utf8.patch 319 BLAKE2B b889ccda8723208af56659616ead64b1779c1bd96abff594a099ddeaa9aac3be86603dd0825507b30a900f38d80b184dfdbddfa42087969ec7fbce43cc8c1617 SHA512 53dc8336ac9895659d92001cb22137011d9da753c299bc3fecd34ed6b42f0f169967dfd41b0403462e54e62af1f6390c58386a91a89ddc880a4fe0a4e05ce14b
DIST Whoosh-2.7.4.tar.gz 968741 BLAKE2B 698ec603eb1201f2b1a934785f84108cb5d91114c9a4e1943cfcd2c8c878f7fb0a0868d54d3a11f8aa30890179c555bdc11cbf34962f5f4781c6d43a090ba872 SHA512 7cdefdcf52b704ffe50c00718c42677e2ddfe879f81ad2d14b580b0e026cc0ebb6b9ddc99d8709eaff4eb9b83f654b042c8792821e1ed90aa85cfa6f82845074
-EBUILD whoosh-2.7.4-r1.ebuild 951 BLAKE2B 44614c3141871f95690ca85f3ea395f313e23787db959910c8030ffeb2cc6f3ad58788dbbc37c00e99512b6a1bae57e75a5ccc9255d831e990204e4642baa8a0 SHA512 b2ee09d070fd3bde49f01e778309e5d34b6c2fdd9524bcd295995944380c9ff7d1d2bfb7785e190b2f0859a848f12d4c234507a4be2996c7eb9e02c8c6938a19
-MISC metadata.xml 761 BLAKE2B 5d3afd52974b702eb26f977f515504376f882070bf446569394569c7a08729d360d0a36ec6be4105388efdc573ed0149c04c6663df4370230b03652ac8cf57c4 SHA512 40e03c23018f70b331f168e19b78b54f1ad74b516227c2d4a8274dbd6b9fb058bd073a041d897253838c8f8ff9bfcfaeb1f6dd5312c4c4d6592acfbca4099fe9
+EBUILD whoosh-2.7.4-r2.ebuild 982 BLAKE2B 378c9b403830696d115895f599d4377b0f6d7fcb9d8f052f71b1feaaf7158a37c03d33080058e81526184e99b51417f1ec2c726cbfc8aaeec25244976c4b7aaa SHA512 b48f2a26b891c81bd0c9c72e44564fddc14f07d8f70ebe2e68e9a388193f96d291909eb8fcb9b62d50b09bf549bb6cb30f9490b0b1d3b930c5b785446b85b998
+MISC metadata.xml 785 BLAKE2B 2ac7c8f0d06f362228b5a9a34fef5f5127bacbf11f0569edd70b0f90733ba14a43abbdec3e503b809e75b8ca09da30b08e4671aaa6fd648c5fb8a1f910418739 SHA512 ee5f1cdc409cf433c5e7ead9ae11f67fbc8652e2087cb359e41b3e547ae31b680f6d1bc9da194fcc70b197eac34a10636847aa5bf0775e816ea23ebceb7f282d
diff --git a/dev-python/whoosh/metadata.xml b/dev-python/whoosh/metadata.xml
index 4c79be83af60..88829be92af2 100644
--- a/dev-python/whoosh/metadata.xml
+++ b/dev-python/whoosh/metadata.xml
@@ -9,6 +9,7 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
+ <stabilize-allarches/>
<longdescription lang="en">
Whoosh is a fast, featureful full-text indexing and searching
library implemented in pure Python. Programmers can use it to
diff --git a/dev-python/whoosh/whoosh-2.7.4-r1.ebuild b/dev-python/whoosh/whoosh-2.7.4-r2.ebuild
index 0630af64ea82..a84125c4a715 100644
--- a/dev-python/whoosh/whoosh-2.7.4-r1.ebuild
+++ b/dev-python/whoosh/whoosh-2.7.4-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1
DESCRIPTION="Fast, pure-Python full text indexing, search and spell checking library"