summaryrefslogtreecommitdiff
path: root/dev-python/werkzeug/werkzeug-3.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/werkzeug/werkzeug-3.0.1.ebuild')
-rw-r--r--dev-python/werkzeug/werkzeug-3.0.1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-python/werkzeug/werkzeug-3.0.1.ebuild b/dev-python/werkzeug/werkzeug-3.0.1.ebuild
index c34e787e2827..97ac07ce6e41 100644
--- a/dev-python/werkzeug/werkzeug-3.0.1.ebuild
+++ b/dev-python/werkzeug/werkzeug-3.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -49,7 +49,12 @@ BDEPEND="
distutils_enable_tests pytest
python_test() {
- local EPYTEST_DESELECT=()
+ local EPYTEST_DESELECT=(
+ # RequestRedirect class started incidentally being tested
+ # with pytest-8, though the test isn't prepared for that
+ # https://github.com/pallets/werkzeug/issues/2845
+ 'tests/test_exceptions.py::test_response_body[RequestRedirect]'
+ )
if ! has_version "dev-python/cryptography[${PYTHON_USEDEP}]"; then
EPYTEST_DESELECT+=(
"tests/test_serving.py::test_server[https]"