summaryrefslogtreecommitdiff
path: root/dev-python/werkzeug/werkzeug-2.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/werkzeug/werkzeug-2.0.2.ebuild')
-rw-r--r--dev-python/werkzeug/werkzeug-2.0.2.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/dev-python/werkzeug/werkzeug-2.0.2.ebuild b/dev-python/werkzeug/werkzeug-2.0.2.ebuild
index a3124ca8879c..2393f1d4daef 100644
--- a/dev-python/werkzeug/werkzeug-2.0.2.ebuild
+++ b/dev-python/werkzeug/werkzeug-2.0.2.ebuild
@@ -17,11 +17,10 @@ SRC_URI="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 sparc x86"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
BDEPEND="
test? (
- dev-python/cryptography[${PYTHON_USEDEP}]
!hppa? ( !ia64? (
$(python_gen_cond_dep '
dev-python/greenlet[${PYTHON_USEDEP}]
@@ -30,11 +29,23 @@ BDEPEND="
dev-python/pytest-timeout[${PYTHON_USEDEP}]
dev-python/pytest-xprocess[${PYTHON_USEDEP}]
dev-python/watchdog[${PYTHON_USEDEP}]
+ !alpha? ( !hppa? ( !ia64? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ ) ) )
)"
distutils_enable_tests pytest
python_test() {
+ local EPYTEST_DESELECT=()
+ if ! has_version "dev-python/cryptography[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ "tests/test_serving.py::test_server[https]"
+ tests/test_serving.py::test_ssl_dev_cert
+ tests/test_serving.py::test_ssl_object
+ )
+ fi
+
distutils_install_for_testing --via-venv
# the default portage tempdir is too long for AF_UNIX sockets