summaryrefslogtreecommitdiff
path: root/dev-python/websockets/websockets-11.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/websockets/websockets-11.0.ebuild')
-rw-r--r--dev-python/websockets/websockets-11.0.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/websockets/websockets-11.0.ebuild b/dev-python/websockets/websockets-11.0.ebuild
deleted file mode 100644
index b9486a23c5db..000000000000
--- a/dev-python/websockets/websockets-11.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for building WebSocket servers and clients in Python"
-HOMEPAGE="
- https://websockets.readthedocs.io/
- https://github.com/aaugustin/websockets/
- https://pypi.org/project/websockets/
-"
-# tests are missing pypi sdist, as of 11.0
-SRC_URI="
- https://github.com/aaugustin/websockets/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="+native-extensions"
-
-distutils_enable_tests pytest
-
-src_configure() {
- export BUILD_EXTENSION=$(usex native-extensions)
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # very fragile to speed
- tests/legacy/test_protocol.py::ServerTests::test_local_close_receive_close_frame_timeout
- )
-
- epytest tests
-}