summaryrefslogtreecommitdiff
path: root/dev-python/websockets/websockets-10.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/websockets/websockets-10.2.ebuild')
-rw-r--r--dev-python/websockets/websockets-10.2.ebuild23
1 files changed, 14 insertions, 9 deletions
diff --git a/dev-python/websockets/websockets-10.2.ebuild b/dev-python/websockets/websockets-10.2.ebuild
index e43c8d5084ee..4287b1679bd3 100644
--- a/dev-python/websockets/websockets-10.2.ebuild
+++ b/dev-python/websockets/websockets-10.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
inherit distutils-r1
@@ -16,14 +16,19 @@ SRC_URI="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv sparc x86"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-distutils_enable_tests unittest
+distutils_enable_tests pytest
-src_prepare() {
- # these fail due to timeouts on slower hardware
- sed -e 's:test_keepalive_ping_with_no_ping_timeout:_&:' \
- -e 's:test_keepalive_ping(:_&:' \
- -i tests/legacy/test_protocol.py || die
- distutils-r1_src_prepare
+python_test() {
+ local EPYTEST_DESELECT=(
+ # very fragile to speed
+ tests/legacy/test_protocol.py::ServerTests::test_local_close_receive_close_frame_timeout
+ )
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ tests/test_utils.py::SpeedupsTests::test_apply_mask_non_contiguous_memoryview
+ tests/legacy/test_client_server.py::SecureClientServerTests::test_http_request_ws_endpoint
+ )
+
+ epytest tests
}