summaryrefslogtreecommitdiff
path: root/dev-python/webencodings/webencodings-0.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/webencodings/webencodings-0.5.1.ebuild')
-rw-r--r--dev-python/webencodings/webencodings-0.5.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/webencodings/webencodings-0.5.1.ebuild b/dev-python/webencodings/webencodings-0.5.1.ebuild
new file mode 100644
index 000000000000..6b07f5c88aeb
--- /dev/null
+++ b/dev-python/webencodings/webencodings-0.5.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Character encoding aliases for legacy web content"
+HOMEPAGE="https://github.com/SimonSapin/python-webencodings https://pypi.org/project/webencodings/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm arm64 hppa ia64 ~mips ~ppc ~ppc64 sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all(){
+ cat >> setup.cfg <<- EOF
+ [pytest]
+ python_files=test*.py
+ EOF
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v -v || die
+}