summaryrefslogtreecommitdiff
path: root/dev-python/webcolors/webcolors-24.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/webcolors/webcolors-24.6.0.ebuild')
-rw-r--r--dev-python/webcolors/webcolors-24.6.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/webcolors/webcolors-24.6.0.ebuild b/dev-python/webcolors/webcolors-24.6.0.ebuild
new file mode 100644
index 000000000000..79c4c8ebedc0
--- /dev/null
+++ b/dev-python/webcolors/webcolors-24.6.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Color names and value formats defined by the HTML and CSS specifications"
+HOMEPAGE="
+ https://github.com/ubernostrum/webcolors/
+ https://pypi.org/project/webcolors/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+
+distutils_enable_tests unittest