summaryrefslogtreecommitdiff
path: root/dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9.ebuild')
-rw-r--r--dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9.ebuild b/dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9.ebuild
new file mode 100644
index 000000000000..830d26ee8aaf
--- /dev/null
+++ b/dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A library for computing contrast ratios, as required by WCAG 2.0"
+HOMEPAGE="
+ https://github.com/gsnedders/wcag-contrast-ratio/
+ https://pypi.org/project/wcag-contrast-ratio/"
+SRC_URI="
+ https://github.com/gsnedders/wcag-contrast-ratio/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest test.py
+}