summaryrefslogtreecommitdiff
path: root/dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9-r1.ebuild')
-rw-r--r--dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9-r1.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9-r1.ebuild b/dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9-r1.ebuild
index ca2999f57266..cec8f300bb3a 100644
--- a/dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9-r1.ebuild
+++ b/dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9-r1.ebuild
@@ -4,25 +4,29 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
inherit distutils-r1
DESCRIPTION="A library for computing contrast ratios, as required by WCAG 2.0"
HOMEPAGE="
https://github.com/gsnedders/wcag-contrast-ratio/
- https://pypi.org/project/wcag-contrast-ratio/"
+ https://pypi.org/project/wcag-contrast-ratio/
+"
SRC_URI="
https://github.com/gsnedders/wcag-contrast-ratio/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
BDEPEND="
test? (
dev-python/hypothesis[${PYTHON_USEDEP}]
- )"
+ )
+"
distutils_enable_tests pytest