summaryrefslogtreecommitdiff
path: root/dev-python/virtualenv
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/virtualenv')
-rw-r--r--dev-python/virtualenv/Manifest2
-rw-r--r--dev-python/virtualenv/virtualenv-20.7.1.ebuild97
2 files changed, 99 insertions, 0 deletions
diff --git a/dev-python/virtualenv/Manifest b/dev-python/virtualenv/Manifest
index f89901e2be45..4da1b9d77f1f 100644
--- a/dev-python/virtualenv/Manifest
+++ b/dev-python/virtualenv/Manifest
@@ -1,7 +1,9 @@
DIST virtualenv-20.4.7.tar.gz 10625204 BLAKE2B 1233ea45f771fb425b99c966904e2c5444e5fcb617b1d7cd34cdac097ee15566b7f4c841d444393723ed369193f33bef90ea7caa5b3c20aaf65fbde2f865abf7 SHA512 a554fb32cc46cb1cef2a2655bdae598efb52a4e71223eb10d9a36b124390546250aa11cf7da991a41ef4697523ec4562a31e35b5ab7ee8aba748ea4ff28e088b
DIST virtualenv-20.6.0.tar.gz 8700762 BLAKE2B 718bbfda175ab4ef0820ba66b480060c0371c54a3e6c622c816d8c30141951c85b4f461fa03f71912a767b8d6a40733ab253062466e38a4a2e18b3169812e6a1 SHA512 7eff570f407a4986336d5a34bdcab1621d953aa6900d41962a85a5a44d7b68d378cda4a1bc1ddbfbc468580e051a98c37be17b0a52babbb00166718a987a591c
DIST virtualenv-20.7.0.tar.gz 8714219 BLAKE2B 81b5ee144614a7c854e03599270d03454f991520e8381b98ef01b64e91bb7520a3949e5af9710ceb6292be6b7b7e3738ed7a08324b5ada37f8f4941b408fb425 SHA512 af0f993045013814d9397419fc9d789a1ad64dc53818cbeceb5146e418a8535f76b74ed36b4b164d6974660be77de91cda244eb70b810c8c9fb522ba1088813a
+DIST virtualenv-20.7.1.tar.gz 8714303 BLAKE2B 9ba0714fa842a4d4dc07f8a47536ad95f049c7d4149be7d859af55e6f26aef5d61c80399a8e03de183b7e170ac47eab6bee263c5d3df79eac6a00c63cb368873 SHA512 4d0127ef38655c6370c874a99dc3a92f2d1e50428496878e64aaf52a944f54fb6fc8397c1b4943c40c7cd5c19ee93cccfab735f38d3dcc202372e1081f0ea23f
EBUILD virtualenv-20.4.7.ebuild 4256 BLAKE2B 8fbe67f90a9b7079b5eb6b6e9c6c28fcc887fdcfa1bf31ba9fa02c62166ee8f7e42d1a98336110d452907133a0d75892b7d28c202a8075f88b32ac354dd57ca3 SHA512 db31bfb20d836ad986acff3b6ff5d16ef00a78379b02cf7d6be853aaaa08cbcbfcd7de106d47d398e9b8125644fc9daa164bfa6cb09a302e1f3135b709f38bb3
EBUILD virtualenv-20.6.0.ebuild 4276 BLAKE2B 6533c59050af3916bdf02e38671cb6fa6558bacb9ca47af9a9282594fb5d97d3c8eb405db4c6f41a180203ba54dd77066f7bab75deebc8a101d078b22e8dd5c2 SHA512 f49d6360516804b898fa90bfd4a0592c58ed224e1abea528730f041e7f3cc15d68bf2628323feb5c05f724fdb1c085dd940ffdaedceae7010551f6ebc00d08d0
EBUILD virtualenv-20.7.0.ebuild 4254 BLAKE2B 001e09ffdad208c5386993419b56dd0f0c35504d6591896a306b39e70f01ecbc0f47ef800f8b50bb502ee10eeb03d952d7c65cd6ec94823450c7b8d83c2b4fca SHA512 501bb46fb0e7ee7fabba977a25a4ab8b4168e18e5655226900320543e15dd95f84d0932bafd6a5230f3e7424e66c560ba853cc515cb2995dea7dea020595abad
+EBUILD virtualenv-20.7.1.ebuild 4254 BLAKE2B 001e09ffdad208c5386993419b56dd0f0c35504d6591896a306b39e70f01ecbc0f47ef800f8b50bb502ee10eeb03d952d7c65cd6ec94823450c7b8d83c2b4fca SHA512 501bb46fb0e7ee7fabba977a25a4ab8b4168e18e5655226900320543e15dd95f84d0932bafd6a5230f3e7424e66c560ba853cc515cb2995dea7dea020595abad
MISC metadata.xml 405 BLAKE2B 65152299182652973b0a6387a690d6e04066d9ac05167d6f0ef7d27036813a793503d16e65514093869ed596227123f493dfdba021a094b0021b6c5b98cc0cf7 SHA512 13db4a863e2a82bae1d177967fc45821a59fddc9afc5c9bbbc0abf64fd2c57cb1f7053443d4721c3c91b6562c1b3844560fccc5853f14bce387aabc620167eb6
diff --git a/dev-python/virtualenv/virtualenv-20.7.1.ebuild b/dev-python/virtualenv/virtualenv-20.7.1.ebuild
new file mode 100644
index 000000000000..1c6b72d16019
--- /dev/null
+++ b/dev-python/virtualenv/virtualenv-20.7.1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=manual
+
+inherit distutils-r1
+
+DESCRIPTION="Virtual Python Environment builder"
+HOMEPAGE="
+ https://virtualenv.pypa.io/en/stable/
+ https://pypi.org/project/virtualenv/
+ https://github.com/pypa/virtualenv/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/backports-entry_points_selectable-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/distlib-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-41[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-0.12[${PYTHON_USEDEP}]
+ ' pypy3)"
+# coverage is used somehow magically in virtualenv, maybe it actually
+# tests something useful
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/pip-20.0.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-freezegun-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-1.3.4[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ )"
+
+# (unpackaged deps)
+#distutils_enable_sphinx docs \
+# dev-python/sphinx-argparse \
+# dev-python/sphinx_rtd_theme \
+# dev-python/towncrier
+distutils_enable_tests pytest
+
+src_configure() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ local deselect=(
+ tests/unit/activation/test_xonsh.py
+ tests/unit/seed/embed/test_bootstrap_link_via_app_data.py::test_seed_link_via_app_data
+ tests/unit/create/test_creator.py::test_cross_major
+ )
+ [[ ${EPYTHON} == pypy3 ]] && deselect+=(
+ 'tests/unit/create/test_creator.py::test_create_no_seed[root-pypy3-posix-copies-isolated]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[root-pypy3-posix-copies-global]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[venv-pypy3-posix-copies-isolated]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[venv-pypy3-posix-copies-global]'
+ 'tests/unit/create/test_creator.py::test_zip_importer_can_import_setuptools'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.9-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.9--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.10-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.10--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.9-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.9--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.10-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.10--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3--bin-]'
+ )
+
+ distutils_install_for_testing
+ epytest ${deselect[@]/#/--deselect }
+}
+
+pkg_postinst() {
+ elog "Please note that while virtualenv package no longer supports"
+ elog "Python 2.7, you can still create py2.7 virtualenvs via:"
+ elog " $ virtualenv -p 2.7 ..."
+}