summaryrefslogtreecommitdiff
path: root/dev-python/virtualenv
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/virtualenv')
-rw-r--r--dev-python/virtualenv/Manifest4
-rw-r--r--dev-python/virtualenv/virtualenv-16.7.10-r1.ebuild (renamed from dev-python/virtualenv/virtualenv-16.7.10.ebuild)31
-rw-r--r--dev-python/virtualenv/virtualenv-20.0.31-r1.ebuild (renamed from dev-python/virtualenv/virtualenv-20.0.31.ebuild)21
3 files changed, 27 insertions, 29 deletions
diff --git a/dev-python/virtualenv/Manifest b/dev-python/virtualenv/Manifest
index ec137845c21a..52e4c61665c6 100644
--- a/dev-python/virtualenv/Manifest
+++ b/dev-python/virtualenv/Manifest
@@ -3,6 +3,6 @@ AUX virtualenv-16.7.7-tests.patch 2092 BLAKE2B fe9eef6372958265ff4b0b919c424a163
AUX virtualenv-16.7.8-tests-pypy.patch 3133 BLAKE2B 37d544c96a1546aa0df4e820014ee6091d4b4ca5155da86280aaebfb1a8d26ce9c6a055e47b11129509d7d00abcee0e3a915bd6ff4665b289cfce399f2dfd3b6 SHA512 f99cd435fe9fa98465addc6b22310e5d708c87edef224cdf540556a2ab1a70bebf06e828c02148bb597d163c31b2816845c0c8126727d1d25b38ffcb91c2251e
DIST virtualenv-16.7.10.tar.gz 5116776 BLAKE2B 42f0a4b4330850b504f8febd991ef6ecdcbb0821efdd94ca324a8cc34a68a760a8a98de97f0cb2384d8e6cbb0ce8f261995c6433886444e29b75ba0ce09ca12c SHA512 f06d7c354ce1910f04dbcbe1a77e60392653bbe4f638bafbe9284454db2c0e5d63cf9159201d0916fc01aaba91d45fb733b63096c38517fcd83fd00ed8b26d28
DIST virtualenv-20.0.31.tar.gz 8300305 BLAKE2B 1574b553b2bc8e05bf00584379f80c1e5c0ee9798595255830059eedea62f02f02d216c421aa2cb312bc9e60694f6a409d0c2495858a89fc1ad7aaddea7965ff SHA512 46220bda37b3b860e44c4d0775a89c22a7ba775287f05438d1d3698201cc213a05b2718ef40be302627005ae349dc59a3141c7a30cc1dab6dc81f7692c7f16a5
-EBUILD virtualenv-16.7.10.ebuild 1908 BLAKE2B d8ce09b748bfefb3d797581b5ff98c54fb19a681fa6776173cb690b7d42f05961bc977f34b9614b0790b0f508d3d756db1dd92ea8e228e07ec65bcd06c728487 SHA512 c0706e594946916b393ed7ef148ddb10276886d4b880669ba977dfc81cfdd4cbfca95c78e150f23c57a65dd5df872592b97bfe834c71fa8dddf297efa447448b
-EBUILD virtualenv-20.0.31.ebuild 2618 BLAKE2B 58ad54219c048ac81ac05ffd6910e4805e13fa30e68a3d09231e0a598741107a998a015e7f4a2ed3f78ac49c12a98e62c5e4fde760b18280afd24bd30b7310cb SHA512 47b80c4b372475f1003126d6a5960f4b4957c54ccc0f965f14a5db9626294fb972129d74ff8062e6ef9c27baa13c8d5e3b1c387a4d464666dd0494b9bb7718d5
+EBUILD virtualenv-16.7.10-r1.ebuild 1959 BLAKE2B 90c31ff96e46d24169602a0f034bf02f0d5fcc4132b1ef12a06226580ed2737398c889a0f752cd14c99f310a72642664aacc27024a65840a8541e580ef601deb SHA512 ab7f3e64008dc6320e2d0a280087b7ae26f934eaa7d571e2f8e01c4e21db7356476fd002918b6217bb52827f22bcd6f8e527e53c1011824d8d32be99c452bec8
+EBUILD virtualenv-20.0.31-r1.ebuild 2562 BLAKE2B 35176197536991d7e46aa5cba9f655875617663bae8d2287858af479f61927dc20e28d203f0e94c708b5a37b288c2bc693d4e49596965376d758f6e2c0cd7799 SHA512 11920e53a2253b3d62700256626ef44d1b361783ca121770608eabdb74dfe47071435442fe815a3bfa5a6555756d231f5d000c2f748c80b017c5d02aaa0f5fc4
MISC metadata.xml 380 BLAKE2B 9a15805179f82d4e5c60aeb56191e690f9fe9260e34d9b4e0b893a51522fdc61246f02b20c1b55084709e06d6ce53b2e6436947aa178e2d413a923102d7ee125 SHA512 b6385fef70c6988548a00e6987bf5004979d139ad6c501d3f7b739bacef06eafa39a40bee8cc2d1164e01bb425f131aeea13f4b58ed6e75d66773a4f1c1df824
diff --git a/dev-python/virtualenv/virtualenv-16.7.10.ebuild b/dev-python/virtualenv/virtualenv-16.7.10-r1.ebuild
index e4d99e7a79d0..898e23e80b64 100644
--- a/dev-python/virtualenv/virtualenv-16.7.10.ebuild
+++ b/dev-python/virtualenv/virtualenv-16.7.10-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
DISTUTILS_USE_SETUPTOOLS=manual
inherit distutils-r1
@@ -26,16 +26,14 @@ RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/setuptools-19.6.2[${PYTHON_USEDEP}]"
BDEPEND="${RDEPEND}
test? (
- $(python_gen_cond_dep '
- >=dev-python/pip-19.3.1-r1[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pypiserver[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- ' -3)
+ >=dev-python/pip-19.3.1-r1[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pypiserver[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
)"
DOCS=( docs/index.rst docs/changes.rst )
@@ -55,13 +53,14 @@ distutils_enable_sphinx docs \
dev-python/towncrier
python_test() {
- if ! python_is_python3; then
- ewarn "Tests are skipped on py2, please test externally"
- return
- fi
-
cp "${S}"/LICENSE.txt "${BUILD_DIR}"/lib || \
die "Could not copy LICENSE.txt with ${EPYTHON}"
pytest -vv tests || die "Tests fail with ${EPYTHON}"
}
+
+pkg_postinst() {
+ elog "Please note that while virtualenv package no longer supports"
+ elog "Python 2.7, you can still create py2.7 virtualenvs via:"
+ elog " $ virtualenv -p /usr/bin/python2.7 ..."
+}
diff --git a/dev-python/virtualenv/virtualenv-20.0.31.ebuild b/dev-python/virtualenv/virtualenv-20.0.31-r1.ebuild
index 874b73871c3e..4e1a69e4749a 100644
--- a/dev-python/virtualenv/virtualenv-20.0.31.ebuild
+++ b/dev-python/virtualenv/virtualenv-20.0.31-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6..9}} pypy3 )
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
DISTUTILS_USE_SETUPTOOLS=manual
inherit distutils-r1
@@ -29,15 +29,11 @@ RDEPEND="
>=dev-python/setuptools-41[${PYTHON_USEDEP}]
>=dev-python/six-1.9.0[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
- >=dev-python/contextlib2-0.6.0[${PYTHON_USEDEP}]
- >=dev-python/pathlib2-2.3.3[${PYTHON_USEDEP}]
- ' -2)
- $(python_gen_cond_dep '
>=dev-python/importlib_metadata-0.12[${PYTHON_USEDEP}]
- ' -2 python3_{6,7} pypy3)
+ ' python3_{6,7} pypy3)
$(python_gen_cond_dep '
>=dev-python/importlib_resources-1.0[${PYTHON_USEDEP}]
- ' -2 python3_6 pypy3)"
+ ' python3_6 pypy3)"
# coverage is used somehow magically in virtualenv, maybe it actually
# tests something useful
BDEPEND="
@@ -79,10 +75,7 @@ src_configure() {
}
python_test() {
- if ! python_is_python3; then
- ewarn "Tests are skipped on py2, please test externally"
- return
- elif [[ ${EPYTHON} == pypy3 ]]; then
+ if [[ ${EPYTHON} == pypy3 ]]; then
# TODO: skip with better granularity
ewarn "Skipping broken tests on pypy3"
return
@@ -92,3 +85,9 @@ python_test() {
pytest -vv || die "Tests fail with ${EPYTHON}"
}
+
+pkg_postinst() {
+ elog "Please note that while virtualenv package no longer supports"
+ elog "Python 2.7, you can still create py2.7 virtualenvs via:"
+ elog " $ virtualenv -p 2.7 ..."
+}