summaryrefslogtreecommitdiff
path: root/dev-python/uvicorn
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/uvicorn')
-rw-r--r--dev-python/uvicorn/Manifest2
-rw-r--r--dev-python/uvicorn/uvicorn-0.28.0.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/uvicorn/Manifest b/dev-python/uvicorn/Manifest
index f597ffab42ff..2bd0487e8db8 100644
--- a/dev-python/uvicorn/Manifest
+++ b/dev-python/uvicorn/Manifest
@@ -1,3 +1,5 @@
DIST uvicorn-0.27.1.gh.tar.gz 718990 BLAKE2B a520bcb2cde4ed6125c0d64b06d3d301471c1722f7642adb09320b6a6386fe6206a501f171ed4bfe4f95f333c323d1e9f65efc89c1669abc398a57ad0ad27b16 SHA512 57946b71e3f332a9c549ec48ea25375d5ddad4e7f0d5b406690569ed492c305d8441b3ded5386d6d3295e62007cfcd2ae2f0816266cf493391e813db3ef44109
+DIST uvicorn-0.28.0.gh.tar.gz 718359 BLAKE2B a8e08c3abe6ea1e9d596ad57ef6d0efa0b219bdba89eb27aa6c7f6efa383cc2edfc2d755b8fb58f84d8eb5307fb33ca6c5c15cf2f4de361ee5dbb81cb6b2e897 SHA512 7e001e4d40092f9cc6f230f53958f71150ab6818ab883cd7edfe4a2b7269d5d17ce98d3b279e74b9b58026bcef9b48d1944405df253cfaf18b943979f1a1835d
EBUILD uvicorn-0.27.1.ebuild 1800 BLAKE2B 5557757a14b43a185a03f7ef1e7633a58c1b5a60ca70f7f43e73819a17676195939d444ae58bbf854142b77d571bf904ca94afc4a166387a78eef83ad3a5f8a1 SHA512 770843b6a50257f9d09fbbbf0115da4a8ffefe5e3b138d725f6928f19ebdb430ed8d14e6909e369b2f43f2d754319e5fd310d54f6177d38de66d340e47829a43
+EBUILD uvicorn-0.28.0.ebuild 1808 BLAKE2B 8f262be545e48e4d2a72777eab91f29abc675445a7c46db0a891c97cb00aea4a9124637444ec4603fe5f9ebe45d5ee45bb6d13b6f2b6a683b0884c976cfa7725 SHA512 73573c071e76d9fd837d1a58da2467850cc3576d3ed50e6b6f5dd3fdc88900d91a683844aa9ede03609e53180115ad295056993936932634be73fbd74dd64263
MISC metadata.xml 451 BLAKE2B af9be617c95128297e3455b503e198e13c373244094f6aa9c80837945c3f9f023f1874efa28d4ffa8b241feb9a4e8c7f3d3534e96966733bd5593bffb90904a5 SHA512 4d76bab5c20f7cad81fa56a28c9be07bf2c2ebc412fc647f073215d437a2550eca247b8419df71d04200d0fdf545520684db0b6f4953e73848f69a4f4ad6931e
diff --git a/dev-python/uvicorn/uvicorn-0.28.0.ebuild b/dev-python/uvicorn/uvicorn-0.28.0.ebuild
new file mode 100644
index 000000000000..5950d3bc0878
--- /dev/null
+++ b/dev-python/uvicorn/uvicorn-0.28.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Lightning-fast ASGI server implementation"
+HOMEPAGE="
+ https://www.uvicorn.org/
+ https://github.com/encode/uvicorn/
+ https://pypi.org/project/uvicorn/
+"
+# as of 0.28.0, no tests in sdist
+SRC_URI="
+ https://github.com/encode/uvicorn/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test-rust"
+
+RDEPEND="
+ >=dev-python/asgiref-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/h11-0.8[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/a2wsgi[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/websockets-10.4[${PYTHON_USEDEP}]
+ dev-python/wsproto[${PYTHON_USEDEP}]
+ test-rust? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ dev-python/watchfiles[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # too long path for unix socket
+ tests/test_config.py::test_bind_unix_socket_works_with_reload_or_workers
+ )
+ case ${EPYTHON} in
+ pypy3)
+ # TODO
+ EPYTEST_DESELECT+=(
+ tests/middleware/test_logging.py::test_running_log_using_fd
+ )
+ ;;
+ esac
+
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "auto reload on file changes" dev-python/watchfiles
+}