summaryrefslogtreecommitdiff
path: root/dev-python/urllib3
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/urllib3')
-rw-r--r--dev-python/urllib3/Manifest4
-rw-r--r--dev-python/urllib3/urllib3-1.26.11.ebuild78
-rw-r--r--dev-python/urllib3/urllib3-1.26.12.ebuild2
3 files changed, 2 insertions, 82 deletions
diff --git a/dev-python/urllib3/Manifest b/dev-python/urllib3/Manifest
index 8251daf08a4e..d605edff92b1 100644
--- a/dev-python/urllib3/Manifest
+++ b/dev-python/urllib3/Manifest
@@ -1,5 +1,3 @@
-DIST urllib3-1.26.11.tar.gz 299255 BLAKE2B bf4d5f0b9f8a95c825b9f8fd963a1dc46688123641c3198812dedc11155f445f75ca321e3e283b649bc30cda8de497d0fb88298d6ad41660d91b8843121e50a2 SHA512 d2cc0f57469b640147f2087e2844a7c2c45e5a374ad0f28c1639d9a38ff6d6760f65b9b3187409cee29782d854468a1e4bc1b20d96e010fdd1fd4213bf1cd924
DIST urllib3-1.26.12.tar.gz 299806 BLAKE2B 17c1f02382101b5a44fbc456344befe671c9579f6208ea307866ae0e2fabbe017fdd4b751a6053a6d014bf007f114ca4fc81e2149c9814ab5bef057ffcbce2d0 SHA512 c34bc2cb92ff5fb4e27948b6b8bf286d1f3993d8e399a7dc99e8c1cb07b364f16f9c8d6fc3e5e22e6f2d9285454a945174a9a1de3cb0fcf08e673ba316bc5469
-EBUILD urllib3-1.26.11.ebuild 2307 BLAKE2B 3f7465fe5eb0d5babf0f63795bf1e529c94c74b7db3083d0827071f8a3f96968ba294ecfe8056fbaec34522956be80849568ff013e48a02d787d50190d45fe1f SHA512 8b3574e934e7598b20e8be3409aca9ee7ce969b95adfa2ac6f70521ae8b49595597ce66c4c94b9fcb88e808dee1fb8b04b843f59a04885bcf07372020c92488c
-EBUILD urllib3-1.26.12.ebuild 2315 BLAKE2B ec115b8e76fca07a4b2c8405a97187ff99cb69647275300a0ceb884709ea311010b7f605db8076969e2c8db5682b3c5a8cda0d04e197ad97b698c1579e9e7c9e SHA512 ddef2fb641fa2cd8b4e1679716b8b914eeba0f7f0f38e10e7106bfe6487eb7d9bf93fe50142fc627bf8cb9f3b79297684276f92bfdcf71ffc1d56f40f4ee00e5
+EBUILD urllib3-1.26.12.ebuild 2307 BLAKE2B 3f7465fe5eb0d5babf0f63795bf1e529c94c74b7db3083d0827071f8a3f96968ba294ecfe8056fbaec34522956be80849568ff013e48a02d787d50190d45fe1f SHA512 8b3574e934e7598b20e8be3409aca9ee7ce969b95adfa2ac6f70521ae8b49595597ce66c4c94b9fcb88e808dee1fb8b04b843f59a04885bcf07372020c92488c
MISC metadata.xml 531 BLAKE2B 3ddfea4b8817c827437a79abae8cf4e9cda95addb1c6505ef13018587720bba0cf0788041c0b4cc8b25f319e7cb1c94117ae25b3cbb567f24373e8e89bedaa7b SHA512 7e7191f0338c4c47f01bdceb3d2c6ed94de2241e77fb3be6cbf3ecf8a0682730392a9ee5adf24304d9a322acc06bd84f4f90f1dddcb258cb2e9ba0de9952b693
diff --git a/dev-python/urllib3/urllib3-1.26.11.ebuild b/dev-python/urllib3/urllib3-1.26.11.ebuild
deleted file mode 100644
index 9f87338afe5a..000000000000
--- a/dev-python/urllib3/urllib3-1.26.11.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-PYTHON_REQ_USE="ssl(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
-HOMEPAGE="
- https://github.com/urllib3/urllib3/
- https://pypi.org/project/urllib3/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="brotli test"
-RESTRICT="!test? ( test )"
-
-# dev-python/{pyopenssl,cryptography,idna,certifi} are optional runtime
-# dependencies. Do not add them to RDEPEND. They should be unnecessary with
-# modern versions of python (>= 3.2).
-RDEPEND="
- >=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
- <dev-python/PySocks-2.0[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- brotli? ( dev-python/brotlicffi[${PYTHON_USEDEP}] )
-"
-BDEPEND="
- test? (
- $(python_gen_cond_dep "
- ${RDEPEND}
- dev-python/brotlicffi[\${PYTHON_USEDEP}]
- dev-python/mock[\${PYTHON_USEDEP}]
- dev-python/pytest[\${PYTHON_USEDEP}]
- dev-python/pytest-freezegun[\${PYTHON_USEDEP}]
- >=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
- >=www-servers/tornado-4.2.1[\${PYTHON_USEDEP}]
- " python3_{8..11})
- )
-"
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # unbundle urllib3
- rm src/urllib3/packages/six.py || die
- find -name '*.py' -exec sed -i \
- -e 's:\([.]*\|urllib3\.\)\?packages\.six:six:g' \
- -e 's:from \([.]*\|urllib3\.\)\?packages import six:import six:g' \
- {} + || die
-}
-
-python_test() {
- local -x CI=1
- # FIXME: get tornado ported
- # please keep in sync with BDEPEND!
- if ! has "${EPYTHON}" python3.{8..11}; then
- einfo "Skipping tests on ${EPYTHON}"
- return
- fi
-
- local EPYTEST_DESELECT=(
- # unstable (relies on warning count)
- test/with_dummyserver/test_proxy_poolmanager.py::TestHTTPProxyManager::test_proxy_verified_warning
- )
- has "${EPYTHON}" python3.{8..10} && EPYTEST_DESELECT+=(
- test/contrib/test_pyopenssl.py::TestPyOpenSSLHelpers::test_get_subj_alt_name
- )
-
- epytest
-}
diff --git a/dev-python/urllib3/urllib3-1.26.12.ebuild b/dev-python/urllib3/urllib3-1.26.12.ebuild
index 47fa4076e5a4..9f87338afe5a 100644
--- a/dev-python/urllib3/urllib3-1.26.12.ebuild
+++ b/dev-python/urllib3/urllib3-1.26.12.ebuild
@@ -19,7 +19,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="brotli test"
RESTRICT="!test? ( test )"