summaryrefslogtreecommitdiff
path: root/dev-python/urllib3/urllib3-1.24.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/urllib3/urllib3-1.24.2.ebuild')
-rw-r--r--dev-python/urllib3/urllib3-1.24.2.ebuild23
1 files changed, 16 insertions, 7 deletions
diff --git a/dev-python/urllib3/urllib3-1.24.2.ebuild b/dev-python/urllib3/urllib3-1.24.2.ebuild
index 5c781b4effa6..82e560366169 100644
--- a/dev-python/urllib3/urllib3-1.24.2.ebuild
+++ b/dev-python/urllib3/urllib3-1.24.2.ebuild
@@ -14,7 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="test"
RESTRICT="!test? ( test )"
@@ -25,15 +25,19 @@ RDEPEND="
>=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
>=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
>=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
- virtual/python-ipaddress[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/ipaddress[${PYTHON_USEDEP}]
+ ' -2)
"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
- ${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- >=www-servers/tornado-4.2.1[$(python_gen_usedep python{2_7,3_{5,6,7}})]
+ $(python_gen_cond_dep "
+ ${RDEPEND}
+ dev-python/mock[\${PYTHON_USEDEP}]
+ dev-python/pytest[\${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.2.1[\${PYTHON_USEDEP}]
+ " 'python3*')
)
"
@@ -51,7 +55,12 @@ python_prepare_all() {
python_test() {
# FIXME: get tornado ported
case ${EPYTHON} in
- python2*|python3.[567])
+ python2*)
+ ewarn "Tests are being skipped for Python 2 in order to reduce the number"
+ ewarn "of circular dependencies for Python 2 removal. Please test"
+ ewarn "manually in a virtualenv."
+ ;;
+ python3*)
pytest -vv || die "Tests fail with ${EPYTHON}"
;;
esac