summaryrefslogtreecommitdiff
path: root/dev-python/uri_template
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/uri_template')
-rw-r--r--dev-python/uri_template/Manifest2
-rw-r--r--dev-python/uri_template/uri_template-1.3.0.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/uri_template/Manifest b/dev-python/uri_template/Manifest
index e732981daee7..13e1c06ee89a 100644
--- a/dev-python/uri_template/Manifest
+++ b/dev-python/uri_template/Manifest
@@ -1,3 +1,5 @@
+DIST uri-template-v1.3.0.tar.bz2 17076 BLAKE2B e8d6c1c35190beab4b2b51cf82dacd6e7bf51397abb142f89f975ce4e7c3067dd9c59895127446deafd84420b63ef62c1484c29037dd9e3833e0d0d55950dcc4 SHA512 654eb700de68a5b992b910e1ff0a038ed699453f021d1eb844d71ddebb32e3ffb77851b5704879bf3eb894eaca33477a0173223a5d9df6a06e33fdc27f6b0f5c
DIST uri_template-v1.2.0.tar.gz 18284 BLAKE2B cf857ccd8496111f61fb95af020514f1c484e5c3ff19829f28bc2dc112887fe276dac68aa21e0d092d42a22319e8d6ac8aff95c734aadd8417c56f57b0076256 SHA512 81b046bbc2dc4d5c0b40a76f13713c10e69d803e3d9da13ab69cc6d40569ef0a39c786a6637a66651a5c3d3e68807f923ad48a7feaf898ae3ca6fd03c0e68c37
EBUILD uri_template-1.2.0-r1.ebuild 841 BLAKE2B 6a0658aa45201ce5cc34f9fd6b420d73738d9c6a11075cd695489d4eb814d355a48e179e3577921ba76551ac4d3b087d58d947964ac502ef0161bc71e7fa580b SHA512 f4c6889cf0a82a6463cfdfc37aebacce066d426c5d4ffaa05b16aa7dca1d18a400b8ddac702df623390aeeb899d10404e371da9b8251562c26880482c1f083fb
+EBUILD uri_template-1.3.0.ebuild 852 BLAKE2B 6d6909569c00e38004c4589d24fd14aeef0d9a718e2fc4074a0421cb41c52418d79649cb17fdb0b136e29fd590e14b0f348b1ec5cbc58240d3a4d879dbc1d4f8 SHA512 247bad331714c43b03fa7f22ad469fd249947197baf6afbdc38365b62f9f7cb30785e98c8bedd8c55472f73d98335d5138487f0f9fd1206bd68371cbb881aeb6
MISC metadata.xml 340 BLAKE2B fa3cfe1b2c6ef81f0ac969adda1ef8acc343c72f401c558a85450c992d38f22dca596aecd65de5328a855763379876c55f9d4bd0d2c69c771521e8fe11f43f85 SHA512 8c740d7dd56ecb9fc6a0a06a478878028058c67de06a68ad49f181b08982793874ae571ba5c1ba8f519f988c41588275e5ebbf6c0ea8de992ac1ee82d9effd5d
diff --git a/dev-python/uri_template/uri_template-1.3.0.ebuild b/dev-python/uri_template/uri_template-1.3.0.ebuild
new file mode 100644
index 000000000000..fc68ea7848d9
--- /dev/null
+++ b/dev-python/uri_template/uri_template-1.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P="uri-template-v${PV}"
+DESCRIPTION="URI Template expansion in strict adherence to RFC 6570"
+HOMEPAGE="
+ https://gitlab.linss.com/open-source/python/uri-template/
+ https://pypi.org/project/uri-template/
+"
+SRC_URI="
+ https://gitlab.linss.com/open-source/python/uri-template/-/archive/v${PV}/${MY_P}.tar.bz2
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ "${EPYTHON}" "test.py" || die "Tests fail with ${EPYTHON}"
+}