summaryrefslogtreecommitdiff
path: root/dev-python/uri_template/uri_template-1.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/uri_template/uri_template-1.3.0.ebuild')
-rw-r--r--dev-python/uri_template/uri_template-1.3.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/uri_template/uri_template-1.3.0.ebuild b/dev-python/uri_template/uri_template-1.3.0.ebuild
new file mode 100644
index 000000000000..fc68ea7848d9
--- /dev/null
+++ b/dev-python/uri_template/uri_template-1.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P="uri-template-v${PV}"
+DESCRIPTION="URI Template expansion in strict adherence to RFC 6570"
+HOMEPAGE="
+ https://gitlab.linss.com/open-source/python/uri-template/
+ https://pypi.org/project/uri-template/
+"
+SRC_URI="
+ https://gitlab.linss.com/open-source/python/uri-template/-/archive/v${PV}/${MY_P}.tar.bz2
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ "${EPYTHON}" "test.py" || die "Tests fail with ${EPYTHON}"
+}